MotoSoft®

MotoPallet EG
User’s Manual

Part Number: 152380-1
Revision: 0
COMPLETE OUR ONLINE SURVEY

Motoman is committed to total customer satisfaction! Please give us your feedback on the technical manuals you received with your Motoman robotic solution.

To participate, go to the following website:

http://www.motoman.com/forms/techpubs.asp
Table of Contents

Chapter 1
Introduction .......................................................... 1
  1.1 About This Document ........................................... 1
  1.2 Overview ..................................................... 3
    1.2.1 Specifications ........................................... 3
  1.3 MotoPallet EG Components ..................................... 4
  1.4 System Requirements .......................................... 4
  1.5 Reference to Other Documentation ............................ 4
  1.6 Customer Service ............................................ 5

Chapter 2
Safety ................................................................. 7
  2.1 Introduction ................................................ 7
  2.2 Important Advisory Information .............................. 8
  2.3 General Safeguarding Tips .................................. 8
  2.4 Mechanical Safety Devices .................................. 9
  2.5 Installation Safety ......................................... 9
  2.6 Programming, Operation, and Maintenance Safety ......... 10

Chapter 3
Installation .......................................................... 13
  3.1 Installing the Software ...................................... 13
  3.2 Installing the Hardware Key .................................. 16

Chapter 4
Understanding the MotoPallet EG Process ....................... 17
  4.1 PLC Cell Controller ....................................... 18
  4.2 MotoPallet EG Operating Structure ......................... 19
    4.2.1 Database Files ....................................... 20
    4.2.2 POS Files ........................................... 20
    4.2.3 Tool Wizard.dll ...................................... 21
    4.2.4 LookAheadComponent.dll ............................. 21
Chapter 5
Creating a Palletizing Simulation Cell ........................................... 23
  5.1 Creating a Cell Using MotoSim EG ........................................... 24
     5.1.1 Setup Model Property in MotoSim EG ............................. 24
  5.2 Create a Cell Using MotoPallet EG Cell Wizard ......................... 24
  5.3 Modify a Cell Using MotoSim EG ............................................ 27
     5.3.1 Position Models in Cell (MotoSim EG) .............................. 27
     5.3.1.1 Robot Origin (Controller vs. MotoSim EG) .................... 28
     5.3.2 Modify Tool Data (MotoSim EG) ..................................... 30
     5.3.2.1 Setting Tool Load Information ................................ 31
     5.3.3 Setup User Frames (MotoSim EG) .................................... 31
     5.3.3.1 Mouse Picking Mode ............................................. 32
     5.3.3.2 Robot Calculation Mode ....................................... 33
     5.3.3.3 Confirm Model Type Names ................................... 34
     5.3.3.4 Conveyor User Frame Placement Requirements ............. 34
     5.3.3.5 Pallet User Frame Placement Requirements ................ 35
  5.4 MotoPalletEG Setup Message Boxes ...................................... 36
     5.4.1 Valid Palletizing Sequence Message Box ......................... 37
     5.4.2 Conveyor/Pallet Legal Combinations Message Box ............. 37
     5.4.3 MotoPalletEG User Frame Assignment Message Box ........... 38
     5.4.4 Orientation Jobs Message Box ................................... 39
     5.4.5 Cell Build Preferences Message Box ............................... 39

Chapter 6
Setting Up the MotoPallet EG Cell .............................................. 41
  6.1 Setting Conveyor/Pallet Combinations .................................. 42
  6.2 Setting Conveyor/Pallet Sequencing .................................... 43
     6.2.1 Round Robin / Custom ........................................... 43
     6.2.2 IO Controlled ....................................................... 43
  6.3 Setting Conveyor/Box Placement ....................................... 45
  6.4 Assigning User Frames .................................................... 46
  6.5 Setting Conveyor Tool Pickup Orientation .............................. 48

Chapter 7
Defining and Using Gripper Tools .............................................. 49
  7.1 Types of Gripper Tools ..................................................... 49
     7.1.1 Fork Grippers ....................................................... 49
     7.1.2 Side Grippers ..................................................... 49
     7.1.3 Suction Grippers .................................................. 50
     7.1.4 Uni-Grippers ..................................................... 50
  7.2 Gripper Tool Center Point ................................................. 52
7.2.1 Fork Gripper TCP ................................................................. .52
7.2.2 Side Gripper TCP ................................................................. .52
7.2.3 Suction Gripper TCP .............................................................. .52
7.2.4 Unigripper TCP ................................................................. .52
7.3 Tool Attachment Point ................................................................. .53
7.3.1 Fork/Side Attachment Point ......................................................... .53
7.3.2 Suction Gripper Attachment Point ................................................. .54
7.3.3 UniGripper Attachment Point ....................................................... .54
7.4 Setting Up and Using an Existing Gripper ................................................ .54
7.4.1 Required Gripper Components ................................................... .54
7.4.2 Copying Gripper Model Files to Cell Folder ......................................... .55
7.4.3 Correcting Gripper Position ......................................................... .55
7.4.4 Configuring the Tool Gripper ...................................................... .56
7.5 Setting Up and Using a New Gripper .................................................... .57
7.6 Attachment Point ................................................................. .59
7.6.1 Understanding Tool Path and X and Y Offsets for Fork and Side Grippers ................................................ .59
7.7 Gripper Specification .............................................................. .62
7.7.1 Box Orientation ................................................................. .62
7.8 Gripper Approach Orientation ........................................................ .62

Chapter 8
Defining Robot Settings .............................................................. .65
8.1 Creating Named Motion Sequences ................................................ .66
8.1.1 Defining Box Pickup Motion .................................................... .66
8.1.2 Defining Box Setdown Motion .................................................... .67
8.1.3 Defining Tiersheet Pickup Motion ................................................ .67
8.1.4 Defining Tiersheet Setdown Motion ............................................... .68
8.1.5 Defining Orientation Jobs ......................................................... .68

Chapter 9
Creating Pallet Patterns .............................................................. .77
9.1 Importing Cape Pack 99 Data ...................................................... .78
9.2 Defining Boxes ................................................................. .78
9.3 Defining Pallets ................................................................. .79
9.4 Defining Layer Patterns ........................................................... .81
9.4.1 Using the 3D Drag and Drop Editor ............................................. .82
9.4.1.1 Positioning Boxes ............................................................. .85
9.4.1.2 Creating Interlocking Layers ................................................ .86
9.4.1.3 Changing the Layer Pattern Position Order ................................ .86
9.5 Creating Pallet Builds ............................................................ .87
# Chapter 10

## Creating Robot Jobs

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>10.1 Creating a Cell Build</td>
<td>92</td>
</tr>
<tr>
<td>10.1.1 Automatically Generated Jobs</td>
<td>95</td>
</tr>
<tr>
<td>10.2 Creating Build Jobs</td>
<td>98</td>
</tr>
<tr>
<td>10.2.1 Numbered Job Format</td>
<td>105</td>
</tr>
<tr>
<td>10.2.2 Cell Build Options</td>
<td>108</td>
</tr>
<tr>
<td>10.2.3 Creating Accurate User Frames (User Coordinates)</td>
<td>110</td>
</tr>
<tr>
<td>10.2.3.1 Uploading “Real” User Frames from Robot Controller to MotoPallet EG</td>
<td>111</td>
</tr>
<tr>
<td>10.3 Required Manual Programming</td>
<td>112</td>
</tr>
<tr>
<td>10.3.1 Programming Best Practices</td>
<td>113</td>
</tr>
<tr>
<td>10.3.2 Sample Master Job</td>
<td>114</td>
</tr>
<tr>
<td>10.3.3 Supplemental Programming</td>
<td>115</td>
</tr>
<tr>
<td>10.3.4 Supplemental Programming for Tier Sheets</td>
<td>116</td>
</tr>
<tr>
<td>10.3.5 Supplemental Programming for External Equipment</td>
<td>117</td>
</tr>
<tr>
<td>10.4 Pre-production Testing</td>
<td>118</td>
</tr>
<tr>
<td>10.4.1 Simulate Palletizing and Refine Robot Jobs</td>
<td>118</td>
</tr>
<tr>
<td>10.4.2 Loading Jobs and Performing Test Run</td>
<td>118</td>
</tr>
</tbody>
</table>

## Appendix A

### Asynchronous Place

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>A.1 Overview</td>
<td>119</td>
</tr>
<tr>
<td>A.1.1 Features</td>
<td>120</td>
</tr>
<tr>
<td>A.1.2 Limitations</td>
<td>120</td>
</tr>
</tbody>
</table>

## Appendix B

### B-Variables

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
</table>

## Appendix C

### Troubleshooting

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
</table>

## Appendix D

### User Frame Fixture Drawings

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
</table>

## Appendix E

### Using MotoPallet EG with a Tool of 5 or More Boxes

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>E.1 Tool Definition in the “ToolData” Database Table</td>
<td>131</td>
</tr>
<tr>
<td>E.2 Asynchronous Pick &amp; Place</td>
<td>131</td>
</tr>
<tr>
<td>E.3 Gripper I/O</td>
<td>132</td>
</tr>
</tbody>
</table>

## Glossary

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
</table>

## Index

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
</table>
Chapter 1

Introduction

MotoPallet EG is an optional add-on software package that provides palletizing simulation capabilities for the MotoSim EG simulation software. MotoSim EG provides the core simulation and off-line programming tools, while MotoPallet EG provides the palletizing capabilities.

MotoPallet EG is used to provide rapid simulation of robotic palletizing systems. These simulated robotic palletizing cells can be used to optimize cell layouts and create robotic palletizing jobs for minimum cycle time and maximum product throughput. Robotic palletizing jobs can then be downloaded directly to the robot controller, reducing online programming time.

Included with your MotoPallet EG package are pre-engineered libraries of Motoman products including: robots, risers, grippers, pallets and conveyors. When used with the Cell Wizard, these models provide quick and easy setup of new simulations. In addition, five example simulation cells are included. These cells can be modified to reflect your system or used as learning tools to better understand how to create MotoPallet EG simulations.

Box layer and pallet patterns are either imported using Cape Pack, an industry leader in pallet pattern creation, or created using the MotoPallet EG drag-and-drop editor. Patterns are stored in a Microsoft® Access® database and can be reused on any palletizing system designed with MotoPallet EG. These patterns are applicable to both simulated and real robotic palletizing cells.

1.1 About This Document

Please read this manual for safety precautions, installation instructions, and other important information before using MotoPallet EG. This manual is intended as an introduction and overview for personnel who are familiar with the operation of their Motoman robot model, MotoSim EG terms and operation, and Microsoft® Windows®/PC usage. This manual contains the following chapters:

CHAPTER 1 - INTRODUCTION
Provides general information about MotoPallet EG, a list of reference documents, and customer service information.

CHAPTER 2 - SAFETY
This chapter provides general information regarding the safe use and operation of MotoPallet EG.
CHAPTER 3 - INSTALLATION
Provides instructions for MotoPallet EG software installation, hardware key installation, and first time use.

CHAPTER 4 - UNDERSTANDING THE MOTOPALLET EG PROCESS
Provides a general overview of the basic operating structure for MotoPallet EG.

CHAPTER 5 - CREATING A PALLETTIZING SIMULATION CELL
Provides a general overview and step by step procedures for creating a palletizing simulation cell in MotoPallet EG. This includes setup, modification, tool data, and user frames.

CHAPTER 6 - SETTING UP THE MOTOPALLET EG CELL
Provides a general overview and step by step procedures for conveyor, pallet, and box specifications for your cell.

CHAPTER 7 - DEFINING AND USING GRIPPER TOOLS
Provides a general overview and step by step procedures for defining tool center point (TCP), attachment point, gripper configuration.

CHAPTER 8 - DEFINING ROBOT SETTINGS
Provides a general overview and step by step procedures for the various settings and parameters that must be setup to define how the robot interacts with the functions and features defined in the palletizing simulation cell.

CHAPTER 9 - CREATING PALLET PATTERNS
Provides a general overview and step by step procedures for creating pallet patterns for your MotoPallet EG cell.

CHAPTER 10 - CREATING ROBOT JOBS
Provides a general overview and step by step procedures for creating robot jobs with your MotoPallet EG cell.

APPENDIX A - ASYNCHRONOUS PLACE
Provide a detailed description of the Asynchronous Place function including features and limitations.

APPENDIX B - B-VARIABLES
Provides definitions of B-variables used with MotoPallet EG.

APPENDIX C - TROUBLESHOOTING
Provide a detailed description of the MotoPallet EG error messages along with their meaning and corrective action required.

APPENDIX D - USER FRAME FIXTURE DRAWINGS
Provides detailed descriptions of the automatically generated jobs.

APPENDIX E - USING MOTOPALLET EG WITH A TOOL OF 5 OR MORE BOXES
Provides drawings for several user frame fixtures that can be used with various grippers to help define user frames.

GLOSSARY
Provides definitions of various MotoPallet EG terms.
1.2 **Overview**

MotoPallet EG includes the following features:

**Pallet Pattern Creation**
MotoPallet EG’s drag-&-drop pallet building function and cell wizard make building pallet layers very easy. MotoPallet EG allows assembly of layers and tier sheets into custom pallet builds and saves builds for later use.

**Cape Pack 99 Interface**
MotoPallet EG can import Cape Pack 99 files. Cape Pack 99 automatically generates pallet patterns from box and pallet inputs.

**Asynchronous Pick and Place**
Motopallet EG analyses both the box pattern on the gripper, and the box pattern on the pallet to determine the most optimum pick and place sequence. During the place sequence the software may plan split or asynchronous drops (i.e. pick 4 boxes from the conveyor; orient and place 2 boxes on the pallet; orient and place 1 box; orient and place the last box) All sequencing is performed automatically and results in quicker and easier operation for the MotoPallet EG operator.

**Compiler Job Options**
MotoPallet EG can create individual jobs for each pick, place, or pallet; or MotoPallet EG can place all jobs into one “master” job. Creating one “master” job per pallet reduces cycle time by reducing the number of jobs the controller is required to load. This can reduce cycle time by as much as 0.2 seconds for each job combined into the “master” job.

**MotoSim EG Integration**
Internal parameters, such as robot types, pallet sizes and locations are read directly from MotoSim EG.cel files.

1.2.1 **Specifications**

- Supports up to 8 pallets
- Supports up to 8 conveyors
- Supports up to 32 Box Asynchronous Pick/Place
- Supports suction cup, side grip, fork, and unigripper tools
- Supports Motoman ERC, MRC, XRC and NX100 Controllers
- Does not support pallet unloading
- Asynchronous place requires boxes contact each other during gripper pickup
- Does not automatically check for boxes on pallet
- Smallest box size: 25 x 25 x 1mm (X x Y x Z)
- Smallest pallet size: 254 x 254mm
- Minimum gripper size: 25 x 25mm
- Minimum gripper cup size: 2mm dia.
1.3 MotoPallet EG Components

- “Motoman CD Browser” CD-ROM
- MotoPallet EG User’s manual (P/N 152380-1)
- MotoSim EG User's Manual (P/N 152002-1)
- Hardware Key (Part number differs depending on software order)

1.4 System Requirements

MotoPallet EG is a MotoSim EG client application and will run well within MotoSim EG’s minimum system requirements. MotoPallet EG requires an additional 25-30 megabytes of hard disk space, plus an additional 1-2 megabytes for each MotoSim EG cell. The robot controller may need additional RAM and configuration by a Motoman technician (see Section A.2 “Expanding Global Variables in the Robot Controller”).

MotoPallet EG’s on-line help requires Microsoft Internet Explorer 3.02 or later. Internet Explorer 4.0 or later is recommended and provided on the Motoman CD Browser.

1.5 Reference to Other Documentation

For additional information, refer to the following:

- MotoSim EG User's manual (P/N 152002-1)
- Operator's Manual for Handling (P/N 149231-1)
- Manipulator Manual for your robot model
- Motoman Conveyor Modeler User's manual
1.6 Customer Service

If you need assistance with any aspect of your MotoPallet EG system, please contact Motoman Customer Support at the following 24-hour telephone number –

**937. 847. 3200**

For **routine** technical inquiries, you can also contact Motoman Customer Support at the following e-mail address –

**techsupport@motoman.com**

When using e-mail to contact Motoman Customer Support, please provide a detailed description of your issue, along with complete contact information. Please allow approximately 24 to 36 hours for a response to your inquiry.

*Note: Please use e-mail for routine inquiries, only. If you have an urgent or emergency need for service, replacement parts, or information, you must contact Motoman Customer Support at the telephone number shown above.*

Please have the following information ready before you call –

If you are in need of technical assistance, contact the Motoman service staff at (937) 847-3200. Please have the following information ready before you call:

- MotoPallet EG version
- MotoSim EG version
- Operating system (Microsoft® Windows® 95/98/NT/2000/XP)
- System configuration (hard disk capacity, memory, software, etc.)
- List of all software installed after shipment from Motoman
- Description of difficulty (make note of any error messages)
- Application specific information including robot jobs, process details etc.
NOTES
Chapter 2
Safety

2.1 Introduction

It is the purchaser's responsibility to ensure that all local, county, state, and national codes, regulations, rules, or laws relating to safety and safe operating conditions for each installation are met and followed.

We suggest that you obtain and review a copy of the ANSI/RIA National Safety Standard for Industrial Robots and Robot Systems (ANSI/RIA R15.06-1999). You can obtain this document from the Robotic Industries Association (RIA) at the following address:

RoboticIndustriesAssociation
900VictorsWay
P.O.Box3724
AnnArbor,Michigan48106
TEL:(734)994-6088
FAX:(734)994-3338
www.roboticsonline.com

Ultimately, well-trained personnel are the best safeguard against accidents and damage that can result from improper operation of the robot system. The customer is responsible for providing adequately trained personnel to operate, program, and maintain the robot cell. NEVER ALLOW UNTRAINED PERSONNEL TO OPERATE, PROGRAM, OR REPAIR THE ROBOT SYSTEM!

We recommend approved Motoman training courses for all personnel involved with the operation, programming, or repair of the robot system. This training is designed to familiarize personnel with the safe and correct operation of the robot system.
This safety section addresses the following:

- Standard Conventions (Section 2.2)
- General Safeguarding Tips (Section 2.3)
- Mechanical Safety Devices (Section 2.4)
- Installation Safety (Section 2.5)
- Programming, Operation, and Maintenance Safety (Section 2.6)

### 2.2 Important Advisory Information

Throughout this manual you will find advisory paragraphs (denoted by graphic symbols and bold typeface). All of these (except “NOTE”) direct the reader’s attention to information and procedures that are essential to the safety of personnel or protection of equipment.

The type of information contained in the various advisories is described below. These are listed here in descending order of importance to the safety of personnel and protection of equipment.

**DANGER!**
Information appearing under the DANGER caption concerns the protection of personnel from an immediate and imminent hazards that, if not avoided, will result in immediate, serious personal injury or loss of life in addition to equipment damage.

**WARNING!**
Information appearing under the WARNING caption concerns the protection of personnel and equipment from potential hazards that can result in personal injury or loss of life in addition to equipment damage.

**CAUTION!**
Information appearing under the CAUTION caption concerns the protection of personnel and equipment, software, and data from hazards that can result in minor personal injury or equipment damage.

*Note: Information appearing in a Note caption provides additional information that can be helpful in understanding the item being explained.*

### 2.3 General Safeguarding Tips

All operators, programmers, plant and tooling engineers, maintenance personnel, supervisors, and anyone working near the robot must become familiar with the operation of this equipment. All personnel involved with the operation of the equipment must understand potential dangers of operation. General safeguarding tips are as follows:

- Improper operation can result in personal injury and/or damage to the equipment. Only trained personnel familiar with the operation of this robot, the operator’s manuals, the system equipment, and options and accessories should be permitted to operate this robot system.
• Do not enter the robot cell while it is in automatic operation. Programmers must have the teach pendant when they enter the robot cell.

• Improper connections can damage the robot. All connections must be made within the standard voltage and current ratings of the robot I/O (Inputs and Outputs).

• The robot must be placed in Emergency Stop (E-Stop) mode whenever it is not in use.

• In accordance with ANSI/RIA R15.06-1999, section 4.2.5, Sources of Energy, use lockout/tagout procedures during equipment maintenance. Refer also to Section 1910.147 (29CFR, Part 1910), Occupational Safety and Health Standards for General Industry (OSHA).

2.4 Mechanical Safety Devices

The safe operation of the robot, positioner, auxiliary equipment, and system is ultimately the user’s responsibility. The conditions under which the equipment will be operated safely should be reviewed by the user. The user must be aware of the various national codes, ANSI/RIA R15.06-1999 safety standards, and other local codes that may pertain to the installation and use of industrial equipment. Additional safety measures for personnel and equipment may be required depending on system installation, operation, and/or location. The following safety equipment is provided as standard:

• Safety fences and barriers

• Light curtains and/or safety mats

• Door interlocks

• Emergency stop palm buttons located on operator station, robot controller, and programming pendant

Check all safety equipment frequently for proper operation. Repair or replace any non-functioning safety equipment immediately.

2.5 Installation Safety

Safe installation is essential for protection of people and equipment. The following suggestions are intended to supplement, but not replace, existing federal, local, and state laws and regulations. Additional safety measures for personnel and equipment may be required depending on system installation, operation, and/or location. Installation tips are as follows:

• Be sure that only qualified personnel familiar with national codes, local codes, and ANSI/RIA R15.06-1999 safety standards are permitted to install the equipment.

• Identify the work envelope of each robot with floor markings, signs, and barriers.

• Position all controllers outside the robot work envelope.

• Whenever possible, install safety fences to protect against unauthorized entry into the work envelope.

• Eliminate areas where personnel might get trapped between a moving robot and other equipment (pinch points).
• Provide sufficient room inside the workcell to permit safe teaching and maintenance procedures.

2.6 Programming, Operation, and Maintenance Safety

All operators, programmers, plant and tooling engineers, maintenance personnel, supervisors, and anyone working near the robot must become familiar with the operation of this equipment. Improper operation can result in personal injury and/or damage to the equipment. Only trained personnel familiar with the operation, manuals, electrical design, and equipment interconnections of this robot should be permitted to program, operate, and maintain the system. All personnel involved with the operation of the equipment must understand potential dangers of operation.

• Inspect the robot and work envelope to be sure no potentially hazardous conditions exist. Be sure the area is clean and free of water, oil, debris, etc.

• Be sure that all safeguards are in place. Check all safety equipment for proper operation. Repair or replace any non-functioning safety equipment immediately.

• Do not enter the robot cell while it is in automatic operation. Be sure that only the person holding the programming pendant enters the workcell.

• Check the E-Stop button on the programming pendant for proper operation before programming. The robot must be placed in Emergency Stop (E-Stop) mode whenever it is not in use.

• Back up all programs and jobs onto suitable media before program changes are made. To avoid loss of information, programs, or jobs, a backup must always be made before any service procedures are done and before any changes are made to options, accessories, or equipment.

• Any modifications to PART 1, System Section, of the robot controller concurrent I/O program can cause severe personal injury or death, as well as damage to the robot! Do not make any modifications to PART 1, System Section. Making any changes without the written permission of Motoman will VOID YOUR WARRANTY!

• Some operations require standard passwords and some require special passwords. Special passwords are for Motoman use only. YOUR WARRANTY WILL BE VOID if you use these special passwords.

• The robot controller allows modifications of PART 2, User Section, of the concurrent I/O program and modifications to controller parameters for maximum robot performance. Great care must be taken when making these modifications. All modifications made to the controller will change the way the robot operates and can cause severe personal injury or death, as well as damage the robot and other parts of the system. Double-check all modifications under every mode of robot operation to ensure that you have not created hazards or dangerous situations.

• Check and test any new or modified program at low speed for at least one full cycle.

• This equipment has multiple sources of electrical supply. Electrical interconnections are made between the controller and other equipment. Disconnect and lockout/tagout all electrical circuits before making any modifications or connections.
• Do not perform any maintenance procedures before reading and understanding the proper procedures in the appropriate manual.
• Use proper replacement parts.
• Improper connections can damage the robot. All connections must be made within the standard voltage and current ratings of the robot I/O (Inputs and Outputs).
Chapter 3
Installation

This chapter provides instructions for MotoPallet software installation, hardware key installation, and first time use.

3.1 Installing the Software

MotoPallet EG is a MotoSim EG client application and therefore requires MotoSim EG to run. MotoSoft software is provided on a single CD-ROM with a browser/installer utility. (Motoman CD-ROM Browser, P/N 141720-1). Please refer to the CD Browser for detailed installation instructions.

MotoPallet EG is installed in c:\Program Files\Motoman\MotoPallet EG\. The MotoPallet EG example file directory is installed in the same directory as the MotoSim EG examples: c:\Program Files\Motoman\MotoSimEG\Examples\MotoPallet EG\.

To install MotoPallet EG, proceed as follows:

1. Insert the CD-ROM browser into your CD-ROM drive.
2. The setup program executes automatically.

Note: Setup executes automatically when the CD is inserted into the CD-ROM drive unless auto execute has been disabled on your computer. If the setup program does not auto execute, select demo32.exe from the CD-ROM Open Properties dialog. Demoshield Player appears and prompts you for a .dbd file. Double-click *.dbd to begin the install process.

3. The introduction screen appears. Click Next to continue.
4. Click the Simulation Software button. The Motoman Software License Agreement page appears.

5. Click the Accept button to agree to the terms outlined in the scrolling window. The software selection screen appears.
6. Click either the MotoPallet EG or MotoPallet EG with Cape button, depending on which software bundle you purchased. The software package screen appears.

Note: Although you may install any of the software titles on the CD-ROM, you must install a hardware security key for each software bundle purchased. If the hardware key is not installed, you will be unable to run the software.

7. Click either the MotoPallet EG or MotoPallet EG with Cape button, depending on which software package you purchased, to begin the installation process. The MotoPallet EG install wizard begins.

8. Follow the MotoPallet EG install wizard instructions as it guides you through the installation process.
3.2 Installing the Hardware Key

The hardware key supplied with MotoPallet EG must be installed on your computer or MotoPallet EG will not function properly. The hardware key attaches to the computer’s parallel or USB port. The parallel port is commonly used to connect printers and other peripheral devices to your computer. To attach the hardware key to the parallel port, proceed as follows:

1. Disconnect any device currently connected to your computer’s parallel port.
2. Carefully insert the hardware key into the parallel port. If the key does not fit, do not force it. The key should fit snugly but does not require significant force to insert.
3. Connect your peripheral cable to the free end of the hardware key. The key will not interfere with the operation of your printer or other peripheral devices.

If you are using two or more MotoSoft products that require the use of different hardware keys, you can “stack” the keys (connect in series).
Chapter 4

Understanding the MotoPallet EG Process

MotoPallet EG is a complete palletizing solution that starts with cell setup and design, and ends with the creation of ready-to-run robotic palletizing jobs. The following block diagram highlights these functions at an introductory level.
As the diagram shows, MotoPallet EG is an offline or PC-based tool that uses a built-in Cell Wizard to work with MotoSim EG to create palletizing cell simulations and jobs. Once jobs are created, they can be transferred to the robot controller using a variety of PC to Robot Controller communication packages or they can be transferred directly to the controller using a PCMCIA card.

### 4.1 PLC Cell Controller

Robot jobs, created using MotoPallet EG, are designed to work with a cell controller PLC. The PLC runs the cell and is responsible for determining the operational status of the cell. It is responsible for controlling, monitoring and planning the throughput of the system. The PLC also determines which conveyor to pick from and which pallet station to place the product.

MotoPallet EG creates a master job that acts as a slave to the cell controller. The master job loops through the robot IO groups looking for a Pick and Place command. Once a command is received, the Master job calls the correct Pick and Place jobs for a specific pallet pattern (usually dictated by the PLC) being placed on one of the cell's pallet stations.

The MotoPallet EG jobs keep track of each pallet's status. This status includes:

- Current layer for each pallet
- Current height of the pallet
- Number of layers the pattern contains
- Number of picks per layer,
- Current pick for the layer
- Current robot status (idle, picking or placing boxes).

MotoPallet EG uses a set of robot variables (mostly B Variables) to keep track of each pallet's state. The system programmer can use these variables to implement a number of optional functions and features.

The optional feedback and commands are required because there are no standard methods for implementing many of the required commands. This requires a certain amount of manual
programming to implement. For example; if the robot misses a pick because a box is damaged, how is this situation to be corrected? A number of options exist.

Options include:

- Attempt to re-pick the boxes
- Stop the system and manually clear the layer
- Stop the system and manually complete the layer

Each of these solutions would be implemented in different ways. MotoPallet EG programs can work with any of these solutions.

### 4.2 MotoPallet EG Operating Structure

The following diagram shows the basic file structure for MotoPallet EG.
4.2.1 Database Files

The core of MotoPallet EG data is contained in three Microsoft Access databases. These databases contain the descriptions of the boxes and pallets used in your cell, along with the palletizing data for each cell.

**Box.mdb**
Contains box descriptions

**Pallet.mdb**
Contains pallet descriptions

**MotoPalletEG.mdb**
Contains palletizing data for each cell. This is a complex database containing 17 individual tables.

4.2.2 .POS Files

The .pos files are simple ASCII files that help define each layer pattern. The first line defines the name of the pattern and the second line defines the number of boxes on the layer. Each box location is then defined using World (Cartesian) coordinates X, Y, and Z. The box orientation is defined as 0, 90, 180, or 270 degrees. 0 is defined when the box length is parallel to pallet length. The Vector Pallet X and Y directions determine box placement from pallet origin (0=no vector direction, +1=positive vector dimension, -1=negative vector direction). Vector Pallet directions for the first box are typically zero.

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Example042.POS</td>
<td>Pattern Name</td>
</tr>
<tr>
<td>11</td>
<td>Number of Boxes on Layer</td>
</tr>
<tr>
<td>Box 1</td>
<td></td>
</tr>
<tr>
<td>25.2002</td>
<td>X-Coordinate</td>
</tr>
<tr>
<td>101.6</td>
<td>Y-Coordinate</td>
</tr>
<tr>
<td>100</td>
<td>Z-Coordinate</td>
</tr>
<tr>
<td>0</td>
<td>Rz-Coordinate (Box Orientation)</td>
</tr>
<tr>
<td>0</td>
<td>Vector Pallet X</td>
</tr>
<tr>
<td>0</td>
<td>Vector Pallet Y</td>
</tr>
</tbody>
</table>
4.2.3 Tool Wizard.dll

This file is required to create jobs with Suction Cup or Unigripper tools. It is also required to run the Gripper Configuration Software. This file must be registered by the RegEx32 utility before it can be used. Registration is automatically performed during MotoPalletEG installation. If the registration fails, the RegEx32 utility can be used to force registration.

4.2.4 LookAheadComponent.dll

This dll is required to create Look Ahead Jobs that tell the PLC how many boxes to release in the next slug of boxes.
Chapter 5
Creating a Palletizing Simulation Cell

Palletizing simulation cells can be created in two distinctly different ways; using the MotoPallet EG Cell Wizard, or using MotoSim EG. The MotoPallet EG Cell Wizard allows the user to use a standard template along with a library of pre-modeled pallets and other cell components. By creating your cell files using MotoPallet EG, you avoid the difficult process of setting up each model property in MotoSim EG.
5.1 Creating a Cell Using MotoSim EG

Refer to “2.2 Cell Construction” in your MotoSim EG manual for detailed instruction.

5.1.1 Setup Model Property in MotoSim EG

A valid MotoPallet EG Simulation cell must contain a number of optional and mandatory elements. Each of these elements must be assigned a Model Property Name. MotoPallet EG uses this name to find the elements programmatically. Missing or misspelled names will generate warnings and errors when the cell is opened and MotoPallet EG will not have a correct description of the palletizing cell. These elements, along with the minimum and maximum numbers allowed, are described in the table below.

<table>
<thead>
<tr>
<th>Element</th>
<th>Minimum/Maximum Number</th>
<th>Model Property Name</th>
<th>Default Robot User Frame Numbers</th>
</tr>
</thead>
<tbody>
<tr>
<td>Robot</td>
<td>1/1</td>
<td>Robot</td>
<td>N/A</td>
</tr>
<tr>
<td>Riser</td>
<td>0/1</td>
<td>Riser</td>
<td>N/A</td>
</tr>
<tr>
<td>Conveyor</td>
<td>1/8</td>
<td>Conveyor</td>
<td>Yes 1 to NC&lt;br&gt;NC = number of conveyors</td>
</tr>
<tr>
<td>Gripper</td>
<td>1/1</td>
<td>Gripper</td>
<td>N/A</td>
</tr>
<tr>
<td>Pallets</td>
<td>1/8</td>
<td>Pallet</td>
<td>Yes NC + 1 to NC + NP&lt;br&gt;NC = number of conveyors&lt;br&gt;NP = number of pallets</td>
</tr>
<tr>
<td>Tiersheets or Slipsheet Holder</td>
<td>0/8</td>
<td>Tiersheet</td>
<td>Yes NC+NP + 1 to NC+NP+NT&lt;br&gt;NC = number of conveyors&lt;br&gt;NP = number of pallets&lt;br&gt;NT = number of tiersheets</td>
</tr>
</tbody>
</table>

5.2 Create a Cell Using MotoPallet EG Cell Wizard

The MotoPallet EG Cell Wizard is used to create new Palletizing Cells. It provides a single form that allows the user to select from a large number of pre-modeled palletizing models.

To create a palletizing cell using the MotoPallet EG cell wizard, proceed as follows:

2. Add parts from the MotoPallet Parts Library you want to include in the new cell. Add parts by ‘drag and drop’, or double click parts on you want to include. To remove items from the New Cell list, select the item and press the [Remove Item] button.

3. When you have finished adding parts, press the [Create Cell] button. The Create New Cell window appears.

4. Enter a cell name (use a descriptive name so you can easily locate the file) and press [Save]. MotoSim EG starts and the new cell models are copied to the new palletizing cell directory.

Note: All models are placed into the MotoSim EG cell at the origin (World Coordinates 0,0,0).
5. When the Wizard imports models it creates three entries in the CAD Tree.

   Entry 1 is the model Name
   — It is referenced with the red arrow in the picture below.
   — It is the parent of the next two models.
   — It is given the ObjectName_X where ObjectName is Pallet, Gripper, Conveyor, etc. and X is an integer that indicates its number within the MotoSimEG cel Structure.

   Entry 2 is the CAD Model
   — It is referenced with the blue arrow.
   — It is a child of the Object Model.
   — It is named as ObjectNameY_X_Picture where ObjectName is Pallet, Gripper, Conveyor, etc. and Y is an integer that indicates its number within the Cel Wizard Database and X is an integer that indicates its number within the MotoSimEG cel Structure.

   Entry 3 is the Axis 6 Model
   — It is referenced with the green arrow.
   — It is a child of the Object Model.
   — It is named as ObjectNameY_X_ where ObjectName is Pallet, Gripper, Conveyor, etc. and Y is an integer that indicates its number within the Cel Wizard Database and X is an integer that indicates its number within the MotoSimEG cel Structure.
Note: When positioning the object, always select and move the base model (Model Pointed to by the Red arrow). This will automatically move the CAD Model and the Axis 6 Model together.

5.3 Modify Cell Using MotoSim EG

5.3.1 Position Models in Cell (MotoSim EG)

Position each model by specifying the values in the Position dialog box.

1. With the CAD Tree open, click the [Pos] button or select Attribute > Set Position. The Position window appears.
5.3.1.1 Robot Origin (Controller vs. MotoSim EG)

**Note:** The following procedure is not required for any known Robot model within MotoSim EG. However, it is retained as a check for customers with issues or who want to verify that their robot model is properly setup.

In the controller, the robot’s origin is the intersection of the S- and L-axes. In MotoSim EG, the robot’s origin is the intersection between the S-axis and the floor. If you generate jobs using MotoPallet EG and MotoSim EG, and download them to the controller without modifying the job to compensate for this difference, the controller will interpret the coordinates used in the robot jobs with a negative Z-axis offset.

To modify the MotoSim simulation cell’s robot origin to match the controller’s robot origin, proceed as follows:

<table>
<thead>
<tr>
<th>Table 1 Position dialog box</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Item</strong></td>
</tr>
<tr>
<td><strong>Operation</strong></td>
</tr>
<tr>
<td><strong>[matrix] button</strong></td>
</tr>
<tr>
<td><strong>[OK] button</strong></td>
</tr>
<tr>
<td><strong>[Cancel] button</strong></td>
</tr>
</tbody>
</table>
1. (MotoSim) Select Robot > Controller > Information... The Robot Properties window appears.

2. Click the [Offset of Robot Frame] button. The Axis6 Dialog window appears.

3. Make note of the Z-offset value.

4. Change the value of the Z-offset to 0.

5. Click OK and close all dialog boxes.

6. Click the CAD button in the tool bar. The Cad Tree window appears.
7. Select the highest level robot model and click the [Pos] button. The Position window appears.

8. Add the offset value noted in Step 3 to the value of the existing Z-offset.

9. Click OK and close the CAD tree dialog.

10. Save the cell file from the MotoPallet EG file menu, not the MotoSim EG file menu.

5.3.2 Modify Tool Data (MotoSim EG)

To modify the tool data, proceed as follows:

1. Select Robot > Data Setting > Tool Data. The TOOL Editor window appears.

2. Select the tool number, then modify the tool data using the button at the side of each edit box or by entering the value directly.
Verify tool position 4.3.1

5.3.2.1 Setting Tool Load Information

TOOL Editor dialog box extends to show the tool load information as follows when [Exp. >>] button is selected.

Note: Tool load information setting is not available for YASNAC MRC, MRC II, ERC robots.

<table>
<thead>
<tr>
<th>Item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>[OK] button</td>
<td>Closes the dialog box after modifying the tool data.</td>
</tr>
<tr>
<td>[Apply] button</td>
<td>Modifies the tool data; does not close the dialog box.</td>
</tr>
<tr>
<td>[Cancel] button</td>
<td>Closes the dialog box without modifying the data to the new values.</td>
</tr>
<tr>
<td>[Exp. &gt;&gt;] button</td>
<td>Displays tool load information, enabling data setting.</td>
</tr>
</tbody>
</table>

Table 2 TOOL Editor Dialog Box

5.3.3 Setup User Frames (MotoSim EG)

Create a user frame for each pallet, conveyor, and tier sheet dispenser to be used in a pick or place task. MotoSim EG Library models have Axis6 points for convenient “snap-to” placement of user frames.

You can manually assign user frames to models. However, if you don’t assign user frames, MotoPallet EG will, by default, assign user frames to conveyors first, pallets second, and tier sheet dispensers third. Within each model group, the user frames are assigned in the order the models were added to the cell (as displayed in the MotoSim EG CAD Tree).

Note: User Frames should be set up so that the frame x-axis is aligned with the long side of the conveyor or pallet.
5.3.3.1 **Mouse Picking Mode**

The user frame can be plotted using with mouse picking operation.

1. Select Robot > Data Setting > Set User Frame. The Set User Frame window appears.

**Procedure**

1. Check the [Active] check box in the dialog box. Click the point where the user frame is to be plotted on the cell window. The user frame appears.

2. Move the user frame as necessary: to move the user frame, set its moving direction and moving distance, and move it with the [+]/[-] buttons.

3. Click on [Close] to complete creation of the user frame.

**Table 3** Set User Frame Dialog Box

<table>
<thead>
<tr>
<th>Item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>[Active] check box</td>
<td>Enables mouse picking operation. Set the mode (Free/Vertex/Center) by selecting Screen &gt; Mouse Picking. Refer to “5.4.2 Mouse Picking Mode of your MotoSim EG manual for details.</td>
</tr>
<tr>
<td>[Close] button</td>
<td>Closes the dialog box.</td>
</tr>
</tbody>
</table>

**Note:** Once the physical cell is built, create user frames with the robot and copy the UFRAME.cnd file into the robot folder before opening the cell in MotoPallet EG.
5.3.3.2 **Robot Calculation Mode**

The user frame is defined by three points which are taught by axis key operation. The three defined points are OO, OX, and OY as shown in the following figure.

![User frame defining points](image)

- **OO**: Origin of user frame
- **OX**: Point on user frame X-axis
- **OY**: Point on user frame Y-axis

Select **Robot > Data Setting > Calculate User Frame**... The Calculate User Frame window appears. Refer to Section 12.2 “User Frame Setting” of your MotoSim EG manual for detailed use of the user frame setting.

### Table 4 Calculate User Frame Dialog Box

<table>
<thead>
<tr>
<th>Item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>[Clear User Frame] button</td>
<td>Deletes the user frame selected from the combo box for UFRAME.</td>
</tr>
<tr>
<td>[Close] button</td>
<td>Closes Calculate User Frame dialog box.</td>
</tr>
</tbody>
</table>
Procedure

1. Select the user frame number from the combo box for UFRAME.
2. Select the [OO] radio button.
3. Move the robot to the point that will be the origin of the user frame, then click [Register Pulse]: the current pulses of each axis (S, L, U, R, B, T) are displayed.
4. Register “OX” and “OY” in the same way as “OO” following steps 2 to 3.
5. Select any of [OO], [OX], [OY] radio buttons, and move the robot to each registered point using [Robot Pose] to verify posture.
6. Click [Calc User Frame] to calculate the user frame.
7. Click [Save User Frame] to register the user frame.

5.3.3.3 Confirm Model Type Names

1. Right-mouse click each model and select Property from the popup menu. The Property window appears.
2. Confirm Model Type name.

Note: All models created with Cell Wizard are correctly named.
3. Modify Model Type for legal shape names.

Note: If you change Model Type names, you must Save, Close, and reopen the cell file within MotoPallet EG for the changes to take effect.

MotoPallet EG can accommodate up to eight conveyors. Unless a conveyor is used for a pick/place operation, disable it by changing or deleting its Model Type name so MotoPallet EG will not recognize it. Otherwise, an error will be generated. For example, outfeed pallet conveyors are not used for pick-and-place operations, instead, pallets are used.

The following illustrations show the required locations of the Conveyor and Pallet User Frames.

5.3.3.4 Conveyor User Frame Placement Requirements

1. X-Axis is parallel to the longest Conveyor Axis.
2. Y-Axis is parallel to the shortest Conveyor Axis.
3. The User Frame is placed on top of the rollers or conveyor surface (i.e. where the boxes ride).
4. The user Frame is placed where the box will stop, assuming the box is right justified on the conveyor. This location is at the intersection of the Right Hand Side Stop and the End Stop.
5.3.3.5 Pallet User Frame Placement Requirements

1. X-Axis must be parallel to the Pallet Longest Side.
2. Y-Axis must be parallel to the Pallet Shortest Side.
3. User Frame must be placed at the bottom of the pallet.
4. User Frame may be placed in one of two corners that will allow the X-axis of the user frame to be parallel to the pallet's longest axis.
5.4 MotoPalletEG Setup Message Boxes

After the new cell is created in MotoSimEG, MotoPalletEG displays a number of Setup Information Message Boxes. These boxes inform the user that the new palletizing cell has had a number of automatic behaviors implemented so that he can start creating palletizing jobs very quickly.

<table>
<thead>
<tr>
<th>Behavior</th>
<th>Default Assignments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Conveyor/Pallet Legal Combinations</td>
<td></td>
</tr>
<tr>
<td>Conveyor/Pallet Feed Sequence</td>
<td></td>
</tr>
<tr>
<td>User Frames</td>
<td></td>
</tr>
<tr>
<td>Orient Job</td>
<td></td>
</tr>
<tr>
<td>Cell Build Preferences</td>
<td></td>
</tr>
</tbody>
</table>

**Figure 1** Cell Build Default Preferences

![Cell Build Default Preferences](image-url)
Each of these boxes are displayed each time the cell is open as a reminder to the user to set or confirm the preset behavior to his desired choices. As each behavior is set and saved, the corresponding information box will no longer be displayed when the cell is opened. Therefore no Message Boxes at Cell Open means all Cell behaviors have been properly setup by the user.

5.4.1 **Valid Palletizing Sequence Message Box**

The Palletizing Sequence Message box informs the user that the default palletizing sequence will be used until setup by the user. The default sequence is Infeed Conveyor #1 to Pallet #1.

To resolve this issue, select the Set Conveyor/ Pallet Sequence button and set the Conveyor/Pallet options as desired. See Section 6.2 Setting Conveyor/Pallet Sequencing for more details.

5.4.2 **Conveyor/Pallet Legal Combinations Message Box**

The Conveyor/Pallet Legal Combinations Message box informs the user he is using the default Conveyor/pallet legal combination of Conveyor #1 will feed Pallet #1 only.

To resolve this issue, select the Set Conveyor/ Pallet Combinations button and set the Conveyor/Pallet legal feed as desired. See Section 6.1 Setting Conveyor/Pallet Combinations for more details.
5.4.3 MotoPalletEG User Frame Assignment Message box

The User Frame Assignment box informs the operator that the user frames setup in MotosimEG have not been assigned palletizing elements within the MotoPalletEG database.

To resolve this issue, select the Set User Frame Assignment button and assign the correct user frame to each palletizing conveyor and Pallet and Slipsheet station as desired. See Section 6.4 Assigning User Frames for more details.
5.4.4 **Orientation Jobs Message Box**

The Orientation Jobs box informs the operator that the orientation JBIs have not been set up for the cell file.

To resolve this issue, select the Set Orientation Jobs button and assign Orient Jobs for each desired Conveyor and Pallet station as desired. See Section 8.1.5 Defining Orientation Jobs for more details.

5.4.5 **Cell Build Preferences Message Box**

The Cell Build Preferences box informs the operator that no cell build preferences have been saved for the MotoSim cell file.

To resolve this issue, select the Cell Build button and assign setup job build options as desired. See Section 10 for more details.
Chapter 6
Setting Up the MotoPallet EG Cell

Cell setup operations are typically performed once and remain the same for the life of the palletizing cell. Changes to the original cell setup usually occur only when changes to the cell are made, such as when a new tool is created and used.
6.1 Setting Conveyor/Pallet Combinations

These settings determine which conveyor feeds each pallet. This setting defines allowable combinations. The pickup sequence determines which conveyor is actually used to feed a pallet. The order in which a conveyor or pallet is added to the cell determines the number of the conveyors and pallets.

1. Click on the Conveyor/Pallet Combination button or select Tools > Cell Setup... > Conveyor/ Pallet Combination. The Conveyor/Pallet Combinations window appears.

![Conveyor/Pallet Combinations window]

2. To view the pallet assignments for a conveyor, select the desired conveyor using the slider on the left side of the panel.

3. The pallets assigned to the selected conveyor appear in the top portion of the panel. Alternatively, you can also view the pallet assignments in the Set Conveyor/Pallet Combination matrix.

4. Select from three preset conveyor/pallet combinations:
   - All-to-All - All available conveyors and pallets can be used in any combination.
   - One-to-One - Each conveyor is paired with the same number pallet. No other combinations are allowed.
   - User Defined - All available conveyors and pallets can be selected from the matrix.

![Set Conveyor/Pallet Combinations matrix]

Note: The MotoSim EG cell file determines how many conveyors and pallets are available.

The Select Conveyor/Pallet Combination matrix displays a white check box for each possible conveyor/pallet combination. Click a box to enable a combination. Conveyors are displayed along the left side of the matrix and pallet numbers are displayed across the top of the matrix. Gray boxes indicate that the combination is not possible.

5. Make your selections and click OK.
6.2 Setting Conveyor/Pallet Sequencing

The Conveyor/Pallet Sequencing settings determine:

- The duration of the build. The conveyor can be set to supply product one box at a time, one layer at a time, or until an entire pallet is built.
- The sequence of picks and places from the conveyor to the pallet. The sequence list changes depending on which sequencing option is selected.

6.2.1 Round Robin / Custom

Round Robin and Custom Modes are used primarily for palletizing simulations. In these modes, a pre-defined palletizing sequence can be created by the user. This mode is useful during initial cell layout.

For example if a system has 3 in-feed conveyors and one conveyor (Conveyor #1) has a high speed product that runs 3 times as fast as products on Conveyer #2 and #3. A fixed sequence could then be defined that would have the robot pick and place 3 times from conveyor 1, and then perform one pick and place operation from conveyor #2 and one pick and place from conveyor #3. Different conveyor and robot placement options could be evaluated to minimize conveyor movement.

**Single Pick** - Uses every allowed conveyor, pallet combination for a single pick.

**Layer** - Uses every available conveyor/pallet combination for an entire layer.

**Pallet** - Uses every available conveyor/pallet combination for an entire pallet.

6.2.2 IO Controlled

This mode is used when a PLC or other cell Controller is running the Palletizing Cell. This is the normal mode

In this mode the robot is a slave to the PLC controller. The PLC Controller is responsible for detecting which type box and how many boxes are on each in-feed conveyor and on which pallet they are to be placed. The PLC monitors the system status and must decide the next pick and place command for the robot.

The controller tells the Robot which conveyor to pick from and which pallet to place the boxes on. MotoPallet's master job loops until it receives these commands via IO. Once received, the robot performs the required Pick and Place and returns to the MotoPallet master job to wait for the next command. The following options are available to allow you to link conveyors to I/O groups:

**Duration Selection** - represents a single pick (1), a layer full of placed boxes (2), or a pallet full of placed boxes (3).
Pallet/Group - represents sets of 16 I/O variables that appear together in the MotoSim EG I/O Monitor dialog. Choose a unique group for the duration, conveyor, and pallet parameters.

Note: To display the I/O Monitor dialog box, click on or select Tool > Monitor > I/O > I/O Monitor. Select the group number specified in MotoPallet EG for the desired duration, conveyor, and pallet parameters. Check the boxes in the group to represent a binary number (the first box = 1, second box = 2, third box = 4, etc.)

To setup the palletizing sequence, proceed as follows:

1. Click on the Conveyor/ Pallet Sequence button or select Tools > Cell Setup... > Conveyor/ Pallet Sequence. The Palletizing Sequence Setup window appears.

Note: This sequence repeats endlessly in both simulation and actual production.

1. Select the desired Pick and Place sequence.
2. Select the conveyor/pallet combination.
3. Select a duration and then click Add to create additional combinations.
4. Click Selected or All to remove the selected step or all steps respectively.
5. Click Ok to save your changes or Cancel to exit without saving changes.
6.3 Setting Conveyor/Box Placement

1. Click on the Conveyor Box Placement button or select Tools > Cell Setup... > Conveyor/Box Alignment. The Conveyor/Box Placement window appears.

This dialog allows you to specify how a box is positioned when it reaches the end of the conveyor.

*Note: These settings do not control the conveyor. They inform the robot of the box pickup location on the conveyor.*

You may position the box to the left or right side of the conveyor, the center of the conveyor, or any fixed position on the conveyor. You can also set the rotated position of the box.

1. Click the left, right, center, or fixed option for each valid conveyor. You must have four Axis6 points specified at each top corner of the conveyor model for this function to work properly. Refer to the MotoSim EG User’s Manual for additional information.

2. If you selected Fixed, enter the desired position (in millimeters) relative to the conveyor user frame in the Box Fixed Position area and click OK.

3. Set the desired rotation of the box. Options are 0°, 90°, 180°, and 270°.

4. When finished, click OK.
6.4 Assigning User Frames

1. Select Tools > Cell Setup... > User Frames > Display User Frame Grid. The User Frames Grid window appears.

The User Frames Grid panel displays database fields for conveyor, pallet, and slip sheet user frames that correspond to user frames defined in the cell.

Each category can have up to eight user frames assigned to it. To assign user frames:

1. Click [Add] to add a line to the table.
2. Enter the current cell's name in the first column. Enter the desired user frame ID number (1 through 24) in the available conveyor, pallet, and slip sheet columns. Scroll left and right using the window scroll bar to view all columns.

   Note: Entering a user frame ID in a column of a component that does not exist will not create a user frame.

3. Add or delete cell user frames using the [Add] and [Delete] buttons.
4. Click [Refresh] to update the table to display any changes made by others while you had the table open.
5. Click [Close] to close the window and save your changes.

User frames assignments can be edited using the Assign User Frames window. If you do not assign user frame numbers, MotoPallet EG will assign default user frame numbers in the following manner:

- When using multiple pallets with tier sheets, user numbers are assigned consecutively to all conveyors, followed by pallets, followed by tier sheet dispensers.
- User frame numbers are assigned within each of the previous groups based on the order the models were added to the cell (also the order they are displayed in the CAD Tree dialog).
- MotoPallet EG only assigns user frame numbers to models with legal shape names and user frame numbers are assigned even if user frames do not yet exist.
To assign user frame numbers, proceed as follows:

1. Click on the Edit User Frame Assignments button or select Tools > Cell Setup... > User Frames > Edit User Frame Assignments. The Assign User Frames window appears.

2. Enter the desired user frame ID number (1 through 24) in the available Conveyors, Pallets, and slip sheets columns.

3. Press [Return] to save your assignments.
6.5 Setting Conveyor Tool Pickup Orientation

The Tool Pickup Orientation settings determine the gripper orientation during product pickup. This option is only used with non-suction cup grippers. When using side clamp and shovel grippers, it is necessary to determine if the robot is picking up a box from the front or either side of the conveyor. This flexibility allows the tool to pickup the box from the long or short side of the box.

*Note: For suction cup grippers, the longest dimension of the box is automatically oriented along the longest axis of the suction cup set. No override is allowed.*

1. Click on the Conveyor/Tool Pickup Orientation button or select Tools > Cell Setup... > Conveyor/ Tool Pickup Options. The Conveyor/Tool Pickup Orientation window appears.

   ![Conveyor/Tool Pickup Orientation Window](image)

   The Robot Name field displays the name of the active robot as defined in the cell file. This is for reference only.

   1. Click the Tool Name field and select the desired gripper (if multiple grippers are available).
   2. Select the desired Tool Pickup Orientation. Tool Pickup Orientation controls the rotation of the gripper during pickup (0°, 90°, 180°, and 270°). These orientations are based on the conveyor's origin and rotate counter-clockwise about the conveyor's Z-axis.

   *Note: If you have multiple conveyors, set the desired pickup orientation for each conveyor.*

   3. Click [OK] to save changes or [Cancel] to exit without saving changes.
Chapter 7
Defining and Using Gripper Tools

7.1 Types of Gripper Tools

Today’s industrial handling robots use gripper tools to pickup, carry and release the boxes that are being palletized. There are four major types of grippers used in palletizing; side, fork, suction, and unigripper. MotoPallet EG includes a library of standard grippers. Each of these grippers differs in how they pick up boxes and the number of boxes they can pickup simultaneously.

7.1.1 Fork Grippers

Fork Grippers use a fork to pickup and carry product (box) much like a shovel. The gripper uses the fork to get underneath the box and lifts if from the bottom. The gripper moves all the way underneath the box until the box is at the ninety degree bend between the fork tongs and legs. Some fork grippers use retractable tongs to improve mobility.

Fork grippers are the most restrictive type of gripper and may limit the type and number of patterns and box label positions.

7.1.2 Side Grippers

Side grippers work by pressing or squeezing on two sides of the boxes. One side is fixed and the other side is moveable. The fixed side is placed on one side of the box and the movable side moves inward providing enough compression to lift the box.

Side grippers work best with patterns that allow or have gaps, and use simple patterns.
7.1.3 Suction Grippers

Suction cup grippers are the work horse of the industry. They give good overall reliability and offer the most flexibility of all gripper types. This flexibility is achieved because the gripper stays above the boxes that are being palletized, allowing the robot to create virtually any pallet pattern that can be designed. MotoPallet EG automatically determines suction cup gripper setup based on box orientation and other options.

Suction Cup Grippers are further defined by how they are attached to the robot, and how boxes are carried. Boxes can be carried in either a side-to-side or end-to-end orientation. See figures below:

MotoPallet EG requires that each box is held by 4 suction cups. Therefore, if a gripper is defined as a 3 box gripper, it will have 12 suction cups in its description. While this is recommended to ensure that the box is held securely without large box vibrations, it is not required on the physical tool.

7.1.4 Uni-Grippers

The unigripper works as a grid array of suction cups. The distance between each suction cup is small (0.5 to 1.5 in.). Vacuum is controlled by each cup individually. Each cup has a mechanical plunger that turns the vacuum OFF for that cup so that no vacuum is lost if the suction cup is not over the part. While this gripper requires a large amount of vacuum, it works very well with irregularly shaped products and has been used successfully to move empty wooden pallets.

Suction is controlled by zones. The number and size of the zones are pre-determined. Generally a 4 zone gripper can handle 1 to 3 boxes at a time. The gripper is typically zoned for minimum and maximum size boxes and typically has one zone that is as wide as a the maximum box width. The second zone is as wide as the smallest width box. A number of smaller zones are also available that can be turned ON and OFF, in various combinations, to accommodate boxes between the minimum and maximum width.

Box width to zone mapping must be performed for each box size and is performed automatically by MotoPallet EG.
Table 5

<table>
<thead>
<tr>
<th>Gripper Type</th>
<th>Sub-</th>
<th>Maximum Number of Boxes</th>
<th>Attachment Point (TCP to Box)</th>
<th>Reliability/ Flexibility</th>
<th>Box Arrangement on Gripper</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fork</td>
<td></td>
<td>1</td>
<td>Bottom center of the box</td>
<td>Extreme Reliability/ Low Flexibility</td>
<td>Side to Side or End-to-End</td>
<td>Fragile or glass boxes, shrink wrap boxes, heavy cartons, bags, patterns with or which allow gaps and simple patterns.</td>
</tr>
<tr>
<td>Side</td>
<td></td>
<td>1</td>
<td>Bottom center of the box</td>
<td>Excellent Reliability/ Low Flexibility</td>
<td>Side to Side or End-to-End</td>
<td>Fragile or glass boxes, shrink wrap boxes, bags, patterns which allow or have gaps, simple patterns</td>
</tr>
<tr>
<td>Suction Linear</td>
<td>1-4</td>
<td>Top of box - group centered on TCP</td>
<td>Good Reliability/ Excellent Flexibility</td>
<td>Side to Side or End-to-End</td>
<td>Corrugated Boxes, Multiple Pick and Place</td>
<td></td>
</tr>
<tr>
<td>Row</td>
<td>4-16</td>
<td>Top of box - group centered on TCP</td>
<td>Good Reliability/ Good Flexibility</td>
<td>Side to Side</td>
<td>Corrugated Boxes, Multiple Pick and Place, Simple patterns, row picking</td>
<td></td>
</tr>
<tr>
<td>Uni-Gripper</td>
<td>1-4</td>
<td>Top of box - group centered on TCP</td>
<td>Very Good Reliability/ Very Good Flexibility</td>
<td>Side to Side</td>
<td>Corrugated boxes, objects with structures that have air gaps, holes or open areas</td>
<td></td>
</tr>
</tbody>
</table>
7.2 **Gripper Tool Center Point**

Industrial robots define a point on the tool called the tool center point or TCP. Each gripper has a pre-defined TCP. MotoPalletEG and MotoSimEG plan the robot palletizing paths using this gripper TCP.

The following section explains where the TCP is located for various grippers. It also explains where the gripper is attached to the boxes.

7.2.1 **Fork Gripper TCP**

The fork gripper TCP is defined as the center of the ninety degree bend between the leg and fork tongs.

7.2.2 **Side Gripper TCP**

The side gripper TCP is defined as the center point on the bottom edge of the fixed arm.

7.2.3 **Suction Gripper TCP**

The suction gripper TCP is defined as the top center point of the group of boxes that is being carried.

7.2.4 **Unigripper TCP**

The Unigripper TCP changes with box size as the zone to box mapping changes with box size. (See examples below) Once Box size is set, MotoPallet EG calculates the box positions on the gripper and calculates the TCP for that box group.
7.3 Tool Attachment Point

MotoPallet EG defines an Axis6 point, called the “attachment point,” as a reference for positioning the gripper and the box on the pallet.

The attachment point is an Axis6 point on the box (or tier sheet) model to which the Tool TCP is positioned while carrying a box (or tier sheet) model.

7.3.1 Fork/Side Attachment Point

For fork and side grippers, the attachment point location is a function of the approach orientation and the box orientation with respect to the conveyor during pickup. The Fork Gripper TCP attaches at the center of the box edge. It may be located at either the side or the end of the box. See figure below:
7.3.2 Suction Gripper Attachment Point

The suction gripper TCP is defined as the top center point of the group of boxes that is being carried.

7.3.3 UniGripper Attachment Point

The UniGripper attachment location is based on the zone size and the box size. See the examples below. Box 1 is always justified to the inner edge of Zone 1. Box 2 is mapped to Zone 2 at a minimum. Zone 3 maybe used for box 2 or 3 and zone 4 is used for box 2, 3 or not at all.

7.4 Setting Up and Using an Existing Gripper

7.4.1 Required Gripper Components

To use a gripper in a MotoPallet EG cell, the following must be true:

1. You have a Gripper CAD Model - This can be as basic as a block or a cylinder, to a complex CAD model created in an advanced CAD system. The model is used primarily for visual feedback in the simulation system.

2. The gripper CAD model has a MotoSim EG Property of “Gripper”.

3. The CAD Model Name and the MotoPallet EG Tools Table in the MotoPallet EG .mdb Access database must match.

4. The gripper is setup in the MotoPallet EG Tool Database.
7.4.2 Copying Gripper Model Files to Cell Folder

To copy an existing gripper file to your MotoPalletEG cell, proceed as follows:

1. Locate the desired gripper folder in the MotoSim EG directory (Motoman/MotoSimEG/lib/Gripper).
2. Right click on the desired gripper folder and select Copy.
3. Browse to your cell folder (Motoman/MotoSimEG/Cells).
4. Right click on the Models folder and select Paste. The new gripper files are pasted into your cell folder. You must now add them to your MotoSim EG cell.
5. With your cell open in MotoSim EG, open the CAD tree.
6. Right click on the robot flange and select New Model. The Add Model Dialog appears.
7. Browse to your gripper model files and add both “GRIPSUC...” files. The new gripper appears in the CAD tree beneath the robot flange.
8. Right click on the new gripper and select Property. The Property... dialog appears.
9. Make sure the Model is named “Gripper”.

Note: MotoPallet EG looks for the model name “Gripper” to build. If you have multiple grippers in your MotoSim EG cell, make certain the correct gripper has the Model name “Gripper”.

7.4.3 Correcting Gripper Position

Now that the correct gripper file has been added to your cell, you must correct it’s position on the robot flange and place the robot in a known orientation.

1. From the CAD tree, right click on the new gripper and select Set Position. The Position dialog appears.
2. Adjust the Z (mm) value to correctly place the gripper at the end of the robot tool flange.
3. Click the [Position and Job View] button . Both the Position and Job windows appear.
4. From the Position window, set the Display Reference Frame to Pulse and set the S- and Tz-Axes to 0.
7.4.4 Configuring the Tool Gripper

Now that the gripper has been added to the cell and correctly positioned, you must now configure the tool gripper so that it matches the real robot cell. It is critical that the MotoSim EG gripper attachment is modeled correctly. First, determine your gripper attachment and how the boxes are held (i.e. Y-Axis, X-Axis, side to side, and end to end).

1. From the MotoPallet EG toolbar, select Tool > Tool Data > Configure Gripper. The Gripper Configuration window appears.

2. Set the values for the Qty of “X” Boxes and Qty of “Y” Boxes for X-Axis gripper or Y-Axis gripper.
3. Set the Box Orientation to either Side by Side or End to End.

4. Click Save to save the gripper configuration.

5. Gripper dimensions and unigripper zone configurations can also be set using the Gripper Configuration window.

### 7.5 Setting Up and Using a New Gripper

*Note: Step 2 through Step 5 are automatically performed by the Cell Wizard and are only required if you want to manually change a tool after initial cell creation.*

1. Select Tools > Tool Data > Display Tools Data Grid. The Tool Data window appears.

![Tool Data Grid](image)

The Tool Data panel displays a database that defines gripper layout, gripper TCP, gripper size, box pickup quantity, gripper cup position, gripper cup I/O, conveyor I/O, and side gripper dimensions.

The database accepts parameters for multiple tools. This is particularly useful if you use different grippers on the same robot.

2. Enter data in the database table for the various parameters. Scroll left and right using the window scroll bar to view all the columns.

3. Add or delete tool data using the Add and Delete buttons.

4. Use the Refresh button to refresh the display. Click Refresh to update the table to display any changes that may have been made by others while you had the table open.

5. Click Refresh to send your changes to the database.

6. Click Close to close the table.

Tool parameter explanations and variables are listed in the following table.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th>Variable</th>
</tr>
</thead>
<tbody>
<tr>
<td>ModelName</td>
<td>Name of the gripper model in the cell</td>
<td></td>
</tr>
<tr>
<td>GripperType</td>
<td>Gripper type</td>
<td>Fork, Side, Suction</td>
</tr>
<tr>
<td>BoxOnPlusSideOfGripper</td>
<td>(For side grippers only. As the box is gripped, is the box positioned on the positive side of the axis perpendicular to the paddles?)</td>
<td>0 = No -1 = Yes</td>
</tr>
<tr>
<td>MaxBoxes</td>
<td>Maximum number of boxes that can be lifted by the gripper defined in GripperType</td>
<td>1-32</td>
</tr>
<tr>
<td>ToolNum</td>
<td>Robot Tool number used for this tool</td>
<td>1-16</td>
</tr>
<tr>
<td>NumOfCups</td>
<td>Number of cups present on the gripper (suction gripper only)</td>
<td>1-16</td>
</tr>
<tr>
<td>CupDiameter</td>
<td>Cup diameter measured in millimeters</td>
<td></td>
</tr>
<tr>
<td>Layout</td>
<td>Arrangement of the suction cups on the gripper (suction gripper only)</td>
<td>Linear, Square</td>
</tr>
<tr>
<td>TcpXYZ</td>
<td>Gripper’s Tool Control Point X, Y, and Z offset from T-axis flange measured in millimeters</td>
<td></td>
</tr>
<tr>
<td>GripperSizeXYZ</td>
<td>Gripper’s overall dimensions Gripper size measured in millimeters</td>
<td></td>
</tr>
<tr>
<td>XQuantBoxes</td>
<td>Number of boxes that can be held along the gripper’s X-axis</td>
<td>1,2,3,4 for inline gripper; 1,2 for square gripper</td>
</tr>
<tr>
<td>YQuantBoxes</td>
<td>Cup positions relative to the center of the T-axis flange</td>
<td>1,2,3,4 for inline gripper; 1,2 for square gripper</td>
</tr>
<tr>
<td>SideToSide</td>
<td>Grip boxes side to side</td>
<td>0 = No -1 = Yes</td>
</tr>
<tr>
<td>Cup[n]XYZ</td>
<td>Cup positions relative to the center of the T-axis flange</td>
<td>X, Y, and Z positions measured in millimeters</td>
</tr>
<tr>
<td>OutputNumCup1</td>
<td>Output channel for each cup for use in I/O control</td>
<td>1-16. Assignments depend on the vacuum hose connections to the cups.</td>
</tr>
</tbody>
</table>

MotoPalletEG uses B Variables to record the state of each pallet. See Appendix B for more details on B Variable usage. MotopalletEG can create jobs for ERC, MRC, XRC and NX100 Controllers. Each Controller has a set number of default B Variables.

The controller memory can be adjusted to allow for more global B Variables to be available.
Note: Only a Motoman factory technician can expand the amount of global byte-type arithmetic variables.

7.6 Attachment Point

7.6.1 Understanding Tool Path and X and Y Offsets for Fork and Side Grippers

This section applies to Fork and Side Grippers only.

Positioning and orientation of the gripper and box is relative to multiple coordinate systems or user frames. Understanding which coordinate system applies during each step will allow you to specify the correct values for job parameters, such as the orientation angle of the box to the conveyor, approach angle for the gripper to the conveyor, and orientation of the box on the pallet.

When creating box models, it is a good practice to assign the first dimension to the X-axis of the box's coordinate system. Assigning the length to the first dimension value, and width to the second, will make it easier to follow the box orientation during simulations. When the box is on the conveyor or pallet, the face which is perpendicular to the positive x-axis has a different color than the other five faces. This face is the one the positive x-axis passes through last as it pierces the box.

MotoPallet EG treats tier sheets as very short boxes and positions them at zero-degrees orientation with respect to the tier sheet dispenser user frame. Before the box is picked up by the gripper, MotoPallet EG orients the conveyor's positive x-axis to the box's positive X-axis. MotoPallet EG also rotates the box coordinate system 180 degrees about the box positive X-axis so that the box positive Z-axis aligns with the TCP's positive Z-axis. This is the first step in making the gripper the parent of the box.

To define the gripper's approach direction to the conveyor, MotoPallet EG orients the gripper's positive X-axis to the conveyor's positive X-axis. You have already specified the value for the angle in "Tool Pickup Orientation" in the Conveyor/Tool Pickup Orientation window.

Once the gripper picks up the box, robot instructions use the robot coordinate system and the gripper/TCP user frame to interpret translation and orientation from the pick point to the place point.

However, the "attachment point" coordinate system dictates how MotoPallet EG interprets your values for the X-Offset, Y-Offset, and Z-Offset parameters in the four Named Motion Sequences (box pick, box place, tiersheet pick, tiersheet place). The Figure below shows where these offset are entered.
See Example of Attachment Coordinate System named 11MPick below.

Answering the following three questions will help you determine the orientation of the attachment point coordinate system.
1. How is the box's coordinate system oriented to the conveyor coordinate system? Initially, the attachment coordinate system aligns to the box coordinate system. Also, the attachment coordinate system rotates with the box coordinate system as the box rotates with respect to the conveyor coordinate system (Conveyor/Box Placement dialog).

2. Is your gripper a double pick gripper? Specifically, is it an "X-line, end-to-end"; "X-line, side-to-side"; "Y-line, end-to-end"; or "Y-line, side-to-side" gripper? End-to-end means the shortest sides of the boxes touch when held by the gripper. Side-to-side means the longest sides of the boxes touch when held by the gripper. An X-line gripper aligns its positive X-axis to the direction of the shortest dimension (side to side), or the longest dimension (end to end) of the boxes it will pick up. A Y-line gripper aligns its positive Y-axis to the direction of the shortest dimension (side to side), or the longest dimension (end to end) of the boxes it will pick up.

3. Is your gripper a suction, fork or side gripper? Fork and side grippers may align their axes with the box in any of four angles and the attachment point's coordinate system will not change. HOWEVER, when an X-line or Y-line suction gripper aligns to the boxes, the attachment point coordinate system rotates (independently of the box) about its Z-axis to align itself WITH THE GRIPPER'S COORDINATE SYSTEM. For a Y-line suction gripper, the attachment point coordinate system orients its positive Y-axis with the gripper Y-axis. For an X-line suction gripper, the attachment point coordinate system orients its positive X-axis with the gripper X-axis. Finally, MotoPallet EG reverses the direction of the attachment point's positive z-axis so that it points upward. A positive Z-offset will cause the box/ gripper to move up.

In conclusion, when you want to program X and Y offsets in either pick or place sequences, first input your box orientation to the conveyor, second input your gripper's angle of approach if it's a fork or side gripper ONLY, and then input the offsets in your motion sequences.

As the gripper/box moves to place the box, the final box orientation dictates the angle of approach. The final box orientation angle is the angle from the pallet's positive x-axis to the box's positive X-axis.

However, the offsets you input for each step in the place motion sequence also contribute to the motion of the gripper/box.
7.7 **Gripper Specification**

Create a record in the ToolData2 database as described in Section 7.5.

7.7.1 **Box Orientation**

1. Select Tools > Cell Setup > Conveyor Box Alignment. The Conveyor/Box Placement window appears.

![Conveyor/Box Placement Window](image)

2. Specify box orientation for pickup with respect to conveyor and click [OK].

7.8 **Gripper Approach Orientation**


![Conveyor/Tool Pickup Orientation Window](image)

2. Specify gripper orientation and click [OK].
Note: Pallets #5 to 8 repeat the same pattern in groups of 13.

Expanding Global Variables in the XRC Controller

If you are using more than 2 pallets, you will need to expand the global variable registers in your controller. The default limit is 39 B-variables.

Only a Motoman factory technician can expand the amount of global byte-type arithmetic variables in the XRC.

Note: If the controller is used for intensive job operations and communications among other devices, you may want to consider expanding the job memory capacity by adding an MMM02 Memory Module. Call Motoman Service if you need help determining exactly how much additional memory you need.
Chapter 8
Defining Robot Settings

Various robot settings and parameters must be setup to define how the robot interacts with the functions and features defined in the palletizing simulation cell. These include various aspects of the robot jobs including types of motion, velocity, accuracy or position levels, and if additional jobs are to be called. A sequence of pickup operations and options are stored together.
8.1 Creating Named Motion Sequences

This function allows you to create a Named Motion Sequence that contains frequently-used sequence instructions in a pick or place task, which MotoPallet EG adds to your robot jobs.

**Move Type** - Descriptive tag used to identify the purpose of the step (Approach, Gripper On/Off, Pickup, Place, CheckLoad, SafeDepart).

**Motion Type** - Standard motion descriptors used by robot controller (MOVJ, MOVL).

**Velocity** - Standard velocity setting used by robot controller (millimeters per second or an integer representing percentage of full speed, based on motion type).

**Function** - Standard robot functions that are executed with the move associated with a sequence step. You must have a move in the sequence to execute any function (INFORM II functions).

**Motion Options** - Move function parameters in INFORM II (i.e. CONT [default], NWAIT, PL=n [n=0,1,2,3,4]).

**XYZ Offset** - Offset of the TCP using the attachment point coordinate system (millimeters).

*Note: Offsets are not cumulative. Each offset is relative to the TCP location at the beginning of the sequence.*

8.1.1 Defining Box Pickup Motion

1. Click on the Edit Box Pickup Template button or select Tools > Robot Setup > Edit Box Pickup Template. The Box Pickup Template Editor appears.

2. Create a pickup sequence (approach, gripper on, pick up, check load, safe departure).

3. Click Return.
8.1.2 Defining Box Setdown Motion

1. Click on the Edit Box Setdown Template button or select Tools > Robot Setup > Edit Box Setdown Template. The Box Setdown Template Editor appears.

   ![Box Setdown Template Editor](image)

2. Create a place sequence (approach, place, safe departure).

3. Click Return.

8.1.3 Defining Tiersheet Pickup Motion

1. Click on the Edit Tiersheet Pickup Template button or select Tools > Robot Setup > Edit Tiersheet Pickup Template. The Tiersheet Pickup Template Editor appears.

   ![Tiersheet Pickup Template Editor](image)

2. Create a tiersheet pickup sequence (approach, gripper on, pick up, check load, safe departure).

3. Click [Return].
8.1.4 Defining Tiersheet Setdown Motion

1. Click on the Edit Tiersheet Setdown Template button or select Tools > Robot Setup > Edit Tiersheet Setdown Template. The Tiersheet Setdown Template Editor appears.

2. Create a tiersheet place sequence (approach, place, safe departure).

3. Click Return.

8.1.5 Defining Orientation Jobs

Orientation jobs are used to minimize unnecessary rotation of the tool when moving between the conveyor and pallet. Without these jobs, the robot T-Axis has a tendency to rotate the tool unnecessarily, causing potential cable damage, hose leakage, and dropped product.

The T-axis values calculated at pickup and setdown are a combination of orientation change between Conveyor and Pallet, Type of Tool being used, orientation of the boxes on the pallet and orientation of the boxes on the conveyor.

Additionally, the robot T-Axis has over 360 degrees of movement. Therefore some of the Conveyor Pickup and Pallet Setdown orientations of 0, 90, 180, and 270 degrees have multiple solutions or T-Axis values.

See the table and figures below. These four figures show that the tool is in the same position and in the pictures in the right column both User Frame 1, Rz values are 0. But in column 2 the T Axis has been rotated 360 degrees and as a difference in T axis counts of 331,776! This type of ambiguity in the Rz values are the are one of the major causes of the extra rotations in the T Axis.
The purpose of the Orientation Jobs is simply to specify which set of T-Axis Joint Values are preferred at each given User Frame Rz value of 0, 90, 180 and 270 degrees.

Orientation jobs must be created for every pallet and conveyor used in your cell.

To create orientation jobs for your cell, proceed as follows:

1. Open your cell in MotoSim EG.

   *Note: Cell setup and tool definition must be complete before orientation jobs can be created (see Chapter 5 through Chapter 7).*

2. Create a new job for conveyor orientation. Name the job something appropriate like conv1orient.jbi so you can easily locate it in the future.

<table>
<thead>
<tr>
<th>Solution 1 User Frame 1, Rz = 0.0</th>
<th>T = -207783 Counts</th>
</tr>
</thead>
<tbody>
<tr>
<td>Solution 2 User Frame 1, Rz = 0.0</td>
<td>T = 123993 Counts</td>
</tr>
</tbody>
</table>
Note: To create a new job, click on or select Robot > Controller > Select Job.

3. Click on the Position and Job View button $\text{Position and Job View}$ button. Both the Position and Job windows appear.

4. Press the Top View button $\text{Top View}$ to change the camera angle to view the gripper from the top.

5. Using the Position window, select the user frame coordinate system for this conveyor and move the tool roughly in place above the conveyor.

6. Switch to Pulse Frame on the Position Window and set $T = 0$.

7. Using the T-Axis, rotate the tool so that its major axis (Axis with multiple Boxes - See Section 7.4.4 for more detail) is aligned with the Conveyors long axis. Move the T-Axis in a direction that minimizes movement of the tool. See Figure below.
8. Once the Tool and Conveyor T-axes are aligned, add a MOVJ Instruction to your job.
9. Using only the T-Axis buttons, add three additional MOVJ instructions to your job corresponding to \( Rz = 90^\circ, 180^\circ, \) and \( 270^\circ \) in that order.

*Note: You may need to use \(-90^\circ\), rather than \(270^\circ\), to minimize rotational travel or robot limits.*

10. Write down the Tool T-Axis value that corresponds to the selected Tool pickup orientation for this conveyor. In the example above that would be a tool orientation on the conveyor of \( Rz = 0 \) degrees, and a T = \(-42090 \) counts.

11. Create a new job for pallet orientation. Name the job something appropriate like p1orient.jbi so you can easily locate it in the future.

12. From the Position window, set the Display Reference Frame to Pulse and Joint Angle (deg). Using only the S-Axis to avoid unnecessary joint motion, move the tool roughly in place over the pallet.

13. Set the T-Axis to the value recorded in step 10 above.

14. Using the T-Axis, rotate the tool so that its major axis (Axis with multiple Boxes - See Section 7.4.4 for more details) is aligned with the Pallets long axis. Move the T Axis in a direction that minimizes movement of the tool. See Figure below.
15. Once the Tool and Conveyor major axes are aligned, add a MOVJ Instruction to your job.

16. Using only the T-Axis buttons, add three additional MOVJ instructions to your job corresponding to Rz = 90°, 180°, and 270° in that order. The following pictures show the proper tool location at the Rz = 90, 180, and 270 degree positions.
17. Click File > Save.
18. Open the MotoPallet EG menus.
19. Click on the Set Orientation Jobs button or select Tools > Robot Setup > Orientation Setup JBIs. The Orientation Job Setup window appears. From this panel, you can specify which orientation job is used for each conveyor and pallet in your cell.

Note: Perform this step only once per cell. The orientation jobs are saved in the MotoSimEG robot folder.

20. Check the box of the conveyor or pallet number.
21. Type the name of the orientation job file or click the "…” button to browse to the orientation job.

Note: You may need to use -90°, rather than 270°, to minimize rotational travel or robot limits.
Notes
This section describes how to setup reusable pallet patterns. These patterns are comprised of boxes, a pallet, and a group of layer patterns. The layer patterns are combined to create a pallet of up to 25 layers. Each layer can be comprised of the same boxes with the same or different pallet patterns.

Note: This section is robot and gripper independent. Once a pallet pattern is defined, it is stored in the MotoPallet EG database as a series of *.pos files. These stored pallet patterns can then be re-used in different robot pallet stations and different palletizing cells as often as needed.
9.1 Importing Cape Pack 99 Data

Cape Pack 99 is a popular pallet layout suite used to generate pallet diagrams for manually loaded pallets. You may already have Cape pallet files that you would like to transfer to your robotic palletizing operation. This feature allows you to import Cape Pack (*.crf) pallet files into MotoPallet EG. Please consult the documentation that came with your Cape software for instructions on using the Cape Pack 99 programs.

1. Click Cape button or select Tools > Pallet Patterns > Import Cape > Default.
2. Select a Cape Pack 99 data file (.crf) for import.

Note: MotoPallet EG requires pallets be oriented with the longest edge along the X-axis. However, pallets created using Cape Pack may be oriented differently. If this is the case, use the Clockwise and Counter Clockwise buttons to import the pallet rotated 90° as appropriate.

9.2 Defining Boxes

Box dimensions must be entered into MotoPallet EG so pallet layouts can be calculated. Changes to box dimensions can only be made when Edit Mode is selected in the Database Navigation block. To define box dimensions, proceed as follows:

Note: Some fields in this panel are optional and are not required by MotoPallet EG to generate robot jobs.

1. Click the Box Editor button or select Tools > Product Setup > Boxes > Single View. The Box Specifications window appears.

Note: Grid View displays a database table showing all the box records at the same time. This is helpful when you want to copy the contents of one record and paste it into another record.
2. Check the Edit Mode box in the Database Navigation block.

3. SKU Number - Required. Enter a SKU code or plain text box description. You will refer to this box name when creating layers.

4. Box Contents - Optional. This is a purely informational field. It is a good idea to use this field if a box contains fragile or expensive product and you need to make other users aware.

5. Box Dimensions (mm) - Required. Enter the length, width, and height of the box in millimeters. The length must be greater than the width.

6. Bar code Faces- Required. Check the locations of the bar code labels.

7. Box Stacking Criteria - Optional. Specify parcel characteristics such as fragility, crush ability, drop test factor, and toxicity for I/O logic programming applications.

8. Database Navigation - Optional. Click [Add], [Delete], and [Update], to edit box records.

9. Click [Return] to save changes to data.

10. Create a new box description for each new box type you will be using. Be sure to document the box name for future reference.

9.3 Defining Pallets

MotoPallet EG also needs to know the dimensions of the pallet(s). Many of the fields on this panel are optional and used for informational purposes only. MotoPallet EG uses the geometry in the database, not the geometry of the MotoSim EG model when positioning boxes in a simulation. If the geometry of the MotoSim EG simulation does not match the geometry of the pallet.mdb record, the simulation may appear flawed. However, the robot jobs will run properly as long as the actual pallet matches the data in pallet.mdb.
Note: The MotoSim EG library contains all the pallets already entered in the pallet database.

1. Click the Pallet Editor button or select Tools > Product Setup > Pallet > Single View. The Pallet Specifications window appears.

Note: Grid View displays a database table showing all the pallet records at the same time. This is helpful when you want to copy the contents of one record and paste it into another record.

2. Check the Edit Mode box in the Pallet Database block.

3. ID Number - Required. This is the name of the model in the cell.

4. Pallet Description - Optional. A plain text name for the pallet which describes its construction and style.

5. Manufacturer - Optional. Displays the name of the pallet manufacturer.

6. Material - Optional. Displays the material the pallet is constructed.

7. Features - Optional. Describes design characteristics of the pallet. For example, if the pallet has a 4-way fork entry, it can be listed here.

8. Pallet Details (Dimensions in mm) - Optional. Overall dimensions of the pallet (mm) and weight (lb.).

9. Inventory - Lists the number of pallets available in inventory and the number ordered.

10. Pallet Loading Restrictions (Dimensions in mm) - Optional. Loading restrictions such as maximum height and overhang are recorded here.

11. Pallet Database - Use the [Add], [Delete], and [Update] buttons to add and delete pallets from the database.

12. Click [Return] to save changes to data.

13. Create a new box description for each new box type you will be using. Be sure to document the box name for future reference.

14. Be sure to document the pallet name for future reference.

Note: Required data field displays default data. These field values can be changed.
9.4 Defining Layer Patterns

This section demonstrates how to create a new layer and new pallet build. Before you can create pallet layouts, you must define how each pallet layer is built. To build a multilayer pallet that is stable when loaded, alternate at least two unique layer patterns that interlock.

1. Click the Layer Editor button or select Tools > Pallet Patterns > Build > Layer > Single View. The Layer Editor window appears.

   Note: Grid View displays a database table showing all the pallet records at the same time. This is helpful when you want to copy the contents of one record and paste it into another record.

2. Click New. The New Style block appears.

3. Enter a unique Style Name for the new layer.
4. Select a Pallet ID from the drop down menu.
5. Select a Product ID from the drop down menu an click OK.
6. Click Create New POS. The 3-D Drag and Drop Editor window appears.

9.4.1 Using the 3D Drag and Drop Editor

The 3D Drag and Drop Editor allows you to construct a layer by simply clicking on a box and dragging the box directly to the desired location on the layer. A variety of tools are available to help align boxes, define gaps, and alter views until your layer is defined the way you want. For best results, we recommend starting from the corner and building outward.

Note: The pallet coordinate system origin is the lower left corner of the pallet (right hand rule) with the +X direction horizontal to the right. The long dimension of the pallet always lies on the X axis.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Adds a new box to be positioned on the layer. New box appears centered on pallet origin.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the last box placed.</td>
</tr>
<tr>
<td>Rotate</td>
<td>Rotates the selected box in 90° steps.</td>
</tr>
<tr>
<td>Align X</td>
<td>Creates an attraction in the X-Axis to the nearest box or pallet boundary.</td>
</tr>
<tr>
<td></td>
<td>Allowing placed boxes to “snap” into place against the nearest box or pallet boundary.</td>
</tr>
</tbody>
</table>
The 3D menu provides multiple rendering, interaction, and view options as described below:

### Table 8 3D Menu

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Interaction** | Drag Drop Boxes  
Allows you to freely drag and drop box locations or use the axis data fields to enter location coordinates directly or “nudge” X and Y values up or down using the arrow keys.  
**Lock Boxes**  
Disables drag and drop functionality. However, the axis data fields can still be used to enter location coordinates directly or “nudge” X and Y values up or down using the arrow keys. |
| **Render Level** | Wire Frame  
Sets the display to wire frame, displaying hollow frames of boxes and pallets.  
**Painted**  
Sets the display to Painted, displaying solid boxes and pallets.  
**Flat Z**  
Sets the display to Flat Z, a two dimensional, top-down view. |
| **Move Center** | X+ Shifts the pallet and boxes incrementally in the positive X direction.  
X- Shifts the pallet and boxes incrementally in the negative X direction.  
Y+ Shifts the pallet and boxes incrementally in the positive Y direction.  
Y- Shifts the pallet and boxes incrementally in the negative Y direction. |
| **View Point** | X+ Shifts viewpoint to the positive X direction.  
X- Shifts viewpoint to the negative X direction.  
Y+ Shifts viewpoint to the positive Y direction.  
Y- Shifts viewpoint to the negative Y direction.  
Z+ Shifts viewpoint to the positive Z direction.  
Z- Shifts viewpoint to the negative Z direction. |
| **Zoom** | X+ Magnifies view in the positive X direction.  
X- Reduces view in the negative X direction.  
Y+ Magnifies view in the positive Y direction.  
Y- Reduces view in the negative Y direction.  
Z+ Magnifies view in the positive Z direction.  
Z- Reduces view in the negative Z direction. |
| **Perspective** | Toggles the 3D perspective view On and Off. |
The Tools menu provides alignment and orientation options including:

### Table 9 Tools Menu

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Initialize</strong></td>
<td>Clears the current layer configuration.</td>
</tr>
<tr>
<td><strong>Gap</strong></td>
<td>Allows you to define gap configurations using the X Gap Properties window.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Gap Control (On/Off)</strong></td>
<td>Turns gap control On or Off for the X, and Y Axes.</td>
</tr>
<tr>
<td><strong>X Gap Control (mm)</strong></td>
<td>-</td>
</tr>
<tr>
<td><strong>Y Gap Control (mm)</strong></td>
<td>-</td>
</tr>
</tbody>
</table>

**Box Color**

Allows you to change box color. To change box color, select Tools > Box Color. Choose a color from the color panel and click [OK]. To define a custom color, click the Define Custom Color >> button and select a color using the color graph or enter the desired RGB value along with desired Hue, Saturation, and Luminance. Click [Add to Custom Colors] to add new color to the color graph.
9.4.1.1 Positioning Boxes

Boxes can be positioned in a variety of different ways depending on your needs. The drag and drop method is probably the easiest. However, you can also use the X and Y position fields to “nudge” boxes into the appropriate location. Set the Increment field to fine tune the amount of motion that occurs when using the up/down keys. You can also simply enter the X and Y coordinate data directly.
9.4.1.2 Creating Interlocking Layers

Interlocking layers can be created very easily using MotoPallet EG’s Flip commands. Once you have created a pallet layer, simply select one of the Flip commands located under the Tools > Placement command. You can use this to create alternating layer pattern.

9.4.1.3 Changing the Layer Pattern Position Order

The 3-D Drag and Drop Editor allows you to easily determine the order in which boxes are specified in the Cape Pack data file or the order in which the boxes are added in the MotoPallet EG layer editor. This is called the “layer pattern position order.” Right-click anywhere in the background and the boxes are selected in the order specified in the Cape Pack data file, or in the order created in the MotoPallet EG layer editor. The layer pattern position order is important because it may serve as the basis for the order the boxes are placed on the pallet. Some of the automated box placement sequence strategies and manual override use this order of specification. To change the order, proceed as follows:
1. With the 3-D Drag and Drop Editor open, press the Shift key and click on the box you want to change the pattern position order. The Desired Sequence Number window appears.

![Desired Sequence Number](image)

2. The current sequence number for the box is displayed in the top list box. The available sequence numbers are displayed in the bottom list box. Scroll and click to highlight the new sequence number.

3. Click [OK]. The box you selected trades position numbers with the box presently assigned to that position number.

When you have defined your pallet layer, click File > Save, or Save As... to save the layer and exit. Click File > Exit to exit without saving changes.

9.5 **Creating Pallet Builds**

Once you have created layers, you can stack them in various combinations to build your pallet.

1. Click the Pallet Build button or select Tools > Pallet Patterns > Build > Pallet > Single View. The Custom Pallet Build window appears.

*Note: Grid View displays a database table showing all the pallet records at the same time. This is helpful when you want to copy the contents of one record and paste it into another record.*
2. Click New. The New Build block appears.

3. Enter a unique Build Name for your family of patterns.

   Note: The name must be different from all other pallet build names in the database or an error will occur. Ensure all parameters/database tables have been entered before attempting to save the pallet build data.

4. Select a Pallet Style from the torpedoing menu.

5. Click Save to create a new pallet style.
6. Use the horizontal arrows to scroll through the list until you find your Build Name listed.

7. Click the [Add New Layer] button to add layers to your custom pallet build. The [Remove Last Layer] button is used to delete the latest layer.

8. Use the drop down menu to select the desired Layer Name.

9. Tier Sheets are defined in the Tier Sheet Detail (mm) block and can then be added to desired layers by checking the Tier Sheet box for that layer.

10. Click [View]. The 3D Build Pallet View window appears. This presents a 3D rendering of your pallet build.

![3D Build Pallet View](image)

The 3D menu provides multiple rendering and view options as described below:

### Table 10 3D Build Pallet View Toolbar

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Render Level</strong></td>
<td></td>
</tr>
<tr>
<td>Wire Frame</td>
<td>Sets the display to wire frame, displaying hollow frames of boxes and pallets.</td>
</tr>
<tr>
<td>Painted</td>
<td>Sets the display to Painted, displaying solid boxes and pallets.</td>
</tr>
<tr>
<td>Flat Z</td>
<td>Sets the display to Flat Z, a two dimensional, top-down view.</td>
</tr>
<tr>
<td><strong>View</strong></td>
<td></td>
</tr>
<tr>
<td>X+</td>
<td>Shifts viewpoint to the positive X direction.</td>
</tr>
<tr>
<td>X-</td>
<td>Shifts viewpoint to the negative X direction.</td>
</tr>
<tr>
<td>Y+</td>
<td>Shifts viewpoint to the positive Y direction.</td>
</tr>
<tr>
<td>Y-</td>
<td>Shifts viewpoint to the negative Y direction.</td>
</tr>
<tr>
<td>Z+</td>
<td>Shifts viewpoint to the positive Z direction.</td>
</tr>
<tr>
<td>Z-</td>
<td>Shifts viewpoint to the negative Z direction.</td>
</tr>
</tbody>
</table>
When you are ready to return to the Custom Pallet Build window, select File > Return.

When you are finished with your Custom Pallet Build, click [Return].

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zoom</td>
<td>Magnifies or reduces the display.</td>
</tr>
<tr>
<td>Perspective</td>
<td>Toggles the 3D perspective view On and Off.</td>
</tr>
</tbody>
</table>
Chapter 10

Creating Robot Jobs

Creating robot jobs is a two step process. It includes Step 1, creating cell builds and Step 2 creating the robot jobs. Step 1, Creating cell builds is the process of assigning a generic pallet pattern to a specific cell palletizing station that will be built by a specific robot and gripper. The user must also choose the sequence planner options during this stage.

The output of this stage is a set of pick and place sequence commands that are used in Step 2 to create the actual robot jobs. This process can be completed for each pallet station in the cell.

Step 2, Creating Robot Jobs takes the pick and place commands, created in Step 1, along with a large number of user options and creates a set of robot jobs that make the robot build the desired palletizing pattern.
10.1 Creating a Cell Build

1. Click the MotoPallet Quick Start button or select Tools > Robot Setup > Create JBIs.... The Cell Build window appears.

2. Click the [Load Pallet Build] button. The Build Options window appears.

The Build Options window provides multiple build options as described below:
### Table 11  Build Options window

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Robot</strong></td>
<td>Lists the available robot models</td>
</tr>
<tr>
<td><strong>Build Filter</strong></td>
<td>The build filter limits build selection to only those builds available for this cell. Note: If &quot;No Filter&quot; is selected, all builds are made available, regardless of usability in the cell. If you are unfamiliar with build uses, it is recommended that you use the appropriate filter for your cell.</td>
</tr>
<tr>
<td><strong>Build</strong></td>
<td>Select a Build from the list of available builds for your cell. The Tools by Layer list is populated with the corresponding tools.</td>
</tr>
<tr>
<td><strong>Tier Sheet Tool</strong></td>
<td>The tier sheet tool number appears only if tier sheets are included in the build. Tools are numbered 0,1,2,3… (up to the number of tools you have in the cell) in the order that the models were added to the cell.</td>
</tr>
<tr>
<td><strong>Pallet Model</strong></td>
<td>Select the pallet model to receive this build.</td>
</tr>
</tbody>
</table>
Asynchronous Place Options

The Asynchronous Place options control the strategy used to determine the order of box placement when loading the pallet. Box sets are created based on the gripper type/configuration and the box sequence and/or locations. “Place combinations” are then generated. Final place sequence and vectoring are then calculated. Each of these tasks may be performed in a variety of different ways depending on user specifications and/or the current rule used.

Best

The Best option passes each layer pattern through ten or more strategies that weigh acceptance criteria such as: number of picks, number of places, number of places with single vectoring, and number of places with no vectoring. Use this option to create a suite of different rule sets to determine the best possible solution for maximizing vectoring. This option gives cycle time second priority.

Note: The “Y-major” rule should only be used with square grippers.

The major rule-sets are briefly described below:

Reverse X: The boxes are sorted according to reverse X-major. The sets are created according to box-order. The place combinations are generated using the set order. Final place sequence and vectoring are then calculated.

Reverse Y: The boxes are sorted according to reverse Y-major. The sets are created according to box-order. The place combinations are generated using the set order. Final place sequence and vectoring are then calculated.

X-major: The boxes are sorted according to X-major. The sets are created according to box order. The sets are sorted according to X-major. The place-combinations are generated using the set-order. Final place sequence and vectoring are then calculated.

X-Y: The boxes are sorted according to X-major. The sets are created according to box order. The sets are sorted according to Y-major. The place-combinations are generated using the set-order. The final place sequence and vectoring are then calculated.

Y-X: The boxes are sorted according to Y-major. The sets are created according to box order. The sets are sorted according to X-major. The place-combinations are generated using the set-order. Final place sequence and vectoring are then calculated.

Strict File order: Same as the ordered option.

Full

Minimizes the number of picks at the cost of allowing places with single or no vectoring. This option sorts boxes according to their location on the pallet using Y-major. Using full optimization minimizes the number of sets created. Sets are sorted according to their position on the pallet using Y-major. Place combinations are then created to minimize the number of “picks” from the conveyor. The final place sequence and vectoring are then calculated to maximize vectoring. This typically results in the best possible cycle time at the cost of vectoring, which is given lesser priority.

Caution!

Place operations with single or no vectoring may result in collisions during placement if gaps between boxes are too small to compensate for placement position error.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Asynchronous Place Options</td>
<td>The Asynchronous Place options control the strategy used to determine the order of box placement when loading the pallet. Box sets are created based on the gripper type/configuration and the box sequence and/or locations. “Place combinations” are then generated. Final place sequence and vectoring are then calculated. Each of these tasks may be performed in a variety of different ways depending on user specifications and/or the current rule used.</td>
</tr>
</tbody>
</table>

Note: The “Y-major” rule should only be used with square grippers.

The major rule-sets are briefly described below:

Reverse X: The boxes are sorted according to reverse X-major. The sets are created according to box-order. The place combinations are generated using the set order. Final place sequence and vectoring are then calculated.

Reverse Y: The boxes are sorted according to reverse Y-major. The sets are created according to box-order. The place combinations are generated using the set order. Final place sequence and vectoring are then calculated.

X-major: The boxes are sorted according to X-major. The sets are created according to box order. The sets are sorted according to X-major. The place-combinations are generated using the set-order. Final place sequence and vectoring are then calculated.

X-Y: The boxes are sorted according to X-major. The sets are created according to box order. The sets are sorted according to Y-major. The place-combinations are generated using the set-order. The final place sequence and vectoring are then calculated.

Y-X: The boxes are sorted according to Y-major. The sets are created according to box order. The sets are sorted according to X-major. The place-combinations are generated using the set-order. Final place sequence and vectoring are then calculated.

Strict File order: Same as the ordered option.

Y-major: The boxes are sorted according to Y-major. The sets are created according to box order. The sets are sorted according to Y-major. The place-combinations are generated using the set-order. Final place sequence and vectoring are then calculated.

Full

Minimizes the number of picks at the cost of allowing places with single or no vectoring. This option sorts boxes according to their location on the pallet using Y-major. Using full optimization minimizes the number of sets created. Sets are sorted according to their position on the pallet using Y-major. Place combinations are then created to minimize the number of “picks” from the conveyor. The final place sequence and vectoring are then calculated to maximize vectoring. This typically results in the best possible cycle time at the cost of vectoring, which is given lesser priority.

Caution!

Place operations with single or no vectoring may result in collisions during placement if gaps between boxes are too small to compensate for placement position error.
Table 11  Build Options window

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Asynchronous Place Options** | Ordered  
Manual override. Boxes are placed in the order that their layer pattern positions are listed in the *.pos file and the Cape Pack *.crf file. The layer editor allows you to determine the layer pattern position order and edit the layer pattern position order. Use this option to control the sequence order of the boxes to be placed on the pallet. Boxes are placed in the same order sequence as the boxes are input in the layer editor.  
Simplified  
This algorithm works from the farthest position away from the robot to the closest position. Keep in mind that not all pallet patterns can be used with the Simplified approach. |
| **Maintain Orientation**  | Controls whether or not MotoPallet EG uses the orientation specified in the *.pos files or it substitutes an orientation of 0° for 180° and 90° for 270°. Rotating boxes to 180° or 270° increases cycle time but may be necessary to show a particular face of the box (for example, a box with a label or graphics).  
*Note: This option is disabled for grippers that pick four boxes in a square (2x2) configuration.* |
| **Allow modifications of asynch output files** | This option pauses the build after each layer, allowing you to modify the asynch files for each layer of each pallet. When the build pauses, locate the *.aso file in the cell folder and manually make any necessary modifications. |

After you have selected the build options, click [OK]. The build options for the next pallet appears. While the Pallet model is automatically incremented, you may select the Build for each pallet.

When a pattern is assigned to the last pallet station and [OK] is selected, this form closes and the user is automatically returned to the The Cell Build dialog.

In a cell that has multiple pallet stations, you may also need to build jobs for a subset of the pallet stations. In this case, select the pallet station and options as before and click the [OK]. When the last desired station is complete, press the [Return] button to force a return to the Cell Build Dialog.

To undo the assignment of a pallet build to a pallet, click [Remove Last Build].

10.1.1  Automatically Generated Jobs

Asynch11.asi

The first number means pallet 1, the second number means layer 1. The “asi” files contain the input data of each layer to MotoPallet EG’s algorithm for box placement sequence strategies. Information includes the options set in the cell build dialogue box and gripper dimensions, box coordinates in the pallet user frame and cup coordinates for suction grippers in the gripper TCP user frame. This file also lists boxes in order of input.
Asynch11.aso

The first number means pallet 1, the second number means layer 1. The “aso” files list the pick and place sequence for each layer. The “Place” lines list whether or not vectoring occurs for each place. The fifth and sixth values are ±1 if vectoring occurs, zero otherwise. Sets, which are boxes picked or placed simultaneously, are listed together on the box line.

Asynch11.asi.ou2

The first number means pallet 1, the second number means layer 1. The xxx.asi.ou2 files contain inputs, intermediate values and outputs of the box sequence strategies used in the “Best” options of the JBI creation mechanism. At the end of each strategy, there is a section called ‘Place Debug output’ – this lists the ‘place’ values for that particular strategy. The picks, places, vectoring and cycle times are listed for the previous and current strategies and the newer strategy is chosen if “ChangeFlg = 1”. The criteria for choosing the winning strategy includes number of picks, number of places with minimum no / single vectoring and overall estimated cycle time.

Note: Example shows only the first and last pages of the (typically) long file.

Asynch11.asi.ou1

The first number means pallet 1, the second number means layer 1. The xxx.asi.ou1 files contain inputs, intermediate values and outputs of the box sequence strategies used in the “Full optimization “options of the JBI creation mechanism. At the end of the file, there is a section called ‘Place Debug output’ – this lists the final ‘place’ values generated.

10.1.2 AS0 File Example and Format

ASO Files are created for each layer in the pallet. Pick and place order is determined by the location in the file. For example, boxes 4 and 5 are placed before boxes 2 and 6 in the job below. Changing the order in this file changes the order the pallet is built.

Split drops are indicated by multiple Place commands after a Pick command.

Note: Caution should be used when editing the *.aso files. No syntax checking is performed. An error in the *.aso file will cause an error when jobs are created.

AS0 File Example

Total Picks, 2
Pick, 152, 254, 100, 0, 0, 0, 32, 31, 32, 31, 31, 32, 31, 32
Zones, 0, 0, -127, 0, 1, 0, 127, 0
Boxes, 4, 5
Place, 888, 508, 221, 90, 1, 1, 32, 31, 32, 31
Zones, 0
Boxes, 4
Place, 939, 254, 221, 90, -1, 1, 31, 32, 31, 32
Zones, 1
Boxes, 4
Place, 736, 914, 221, 0, -1, -1, 31, 32, 31, 32
Zones, 1
Boxes, 2
Place, 787, 101, 221, 0, 1, 1, 32, 31, 32, 31
Zones, 0
Boxes, 6

<table>
<thead>
<tr>
<th>Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total Picks, 2</td>
<td>Total Number of Picks from the conveyor</td>
</tr>
</tbody>
</table>
| Pick, 152, 254, 100, 0, 0, 32, 31, 32, 31, 31, 32, 31 | Pick- Pickup Command  
152, 254, 100, 0 is the X, Y, Z, Tz - TCP Location of the gripper on the conveyor  
0,0 - Vector direction X=0, Y=0 indicates vectoring is not used during pickup  
32, 31, 32, 31, 32, 31, 32 - Not Used |
| Zones, 0, 0, -127, 0, 1, 0, 127, 0 | Gripper Zones - location of the center of the box relative to the gripper TCP  
0, 0, -127, 0 is Gripper Zone 0, X=0, Y=-127, Z=0  
1, 0, 127, 0 is Gripper Zone 1 X=0, Y=127, Z=0 |
| Boxes, 4, 5 | Picking up two boxes on the conveyor. They will be placed in Box 4 and 5 positions on the pallet |
| Place, 888, 508, 221, 90, 1, 1, 32, 31, 32, 31 | Place location of the boxes on the pallet - Gripper TCP location in pallet coordinates 888,508, 221, 90 is Gripper TCP at pallet coordinate X=888, Y=508, Z=221, Gripper Tz=90,1, means vector from X positive and Y positive direction 32,31,32,31 Not Used |
| Zones, 0 | Gripper Zone = 0, means release box from Gripper Zone 0 |
| Boxes, 4 | Release Box # 4 |
| Place, 939, 254, 221, 90, -1, 1, 31, 32, 31, 32, 31 | Place location - Gripper TCP location in pallet coordinates  
939, 254, 221, 90 is Gripper TCP at pallet coordinate X=939, Y=254, Z=221, Gripper Tz=90  
-1,1, means vector from X Negative and Y positive direction  
31,32,31, 32 Not Used |
| Zones, 1 | Gripper Zone=1, means release box from Gripper Zone 1 |
| Boxes, 5 | Release Box # 4 |
| Pick, 152, 254, 100, 0, 0, 31, 32, 31, 32, 31, 32, 31 | Pick- Pickup Command  
152, 254, 100, 0 is the X, Y, Z, Tz - TCP Location of the gripper on the conveyor  
0,0 - Vector locations of the gripper during pickup  
32, 31, 32, 31, 32, 31, 32 - Not Used |
| Zones, 1, 0, 127, 0, 0, 0, -127, 0 | Gripper Zones - location of the center of the box relative to the gripper TCP  
0,0,-127,0 is Gripper Zone 0, X=0, Y=-127, Z=0  
1,0,127,0 is Gripper Zone 1 X=0, Y=127, Z=0 |
10.2 Creating Build Jobs

MotoPallet EG converts the pick and place locations and sequences into complete robotic palletizing jobs when the [Create JBI] button is selected.

This process, at a minimum, creates a master job, pickup jobs, place jobs, initialization jobs, and a status control job that controls and increments the B-Variables that track the status of the pallet pattern.

The jobs also include a complete pickup and place motion sequences that allow the boxes to be picked up, and moved safely for the in-feed conveyor and placed on the pallet station.

Depending on the options selected, the number and type of jobs created varies greatly. In the following chart, a single build is compiled into jobs with a number of different options. The chart shows the resulting jobs and their major uses.
<table>
<thead>
<tr>
<th>Use</th>
<th>Build</th>
<th>Options</th>
<th>Jobs Created</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Same as above with smaller total pickup job size. (more jobs but much smaller in size)</td>
<td>Example02</td>
<td>1. Combined Robot Jobs 2. Use Numbered Jobs 3. Pallet1 pattern# 1 4. Compressed Pickup Jobs</td>
<td>11000001.jbi Master Pickup Jobs</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>11011001.jbi Pickup Layer 1, 1 box</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>11012001.jbi Pickup Job Layer 1, 2 boxes</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>11021001.jbi Pickup Job Layer2, 1 box</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>11022001.jbi Pickup Job Layer 2, 2 boxes</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>1200001.jbi All Place Jobs</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>1300001.jbi Increment B Variable Job</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>1400001.jbi Initialization Job</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>10001.jbi Master Job</td>
<td></td>
</tr>
<tr>
<td>Example02</td>
<td>Example02</td>
<td>1. Combined Robot Jobs 2. Use Named Jobs 3. Pallet1 Pattern # Not used for Named jobs</td>
<td>1UPP.JBI Pickup Jobs</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>1SDWN.JBI All Place Jobs</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>1INCBX.JBI Increment B Variable Job</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>1NPAL.JBI Initialization Job</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>EXAMPLE0.jbi Master Job</td>
<td></td>
</tr>
<tr>
<td>Good for trouble shooting which position is causing errors or reach problems</td>
<td>Example02</td>
<td>1. Individual Robot Jobs 2. Use Named Jobs 3. Pallet1 pattern# 1</td>
<td>1UPP.JBI Master Pickup Job</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>1UL1LP1.JBI to 1UL1LP6.JBI Layer 1 Pickup Jobs</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>1UL2LP1.JBI to 1UL2LP6.JBI Layer 2 Pickup Jobs</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>1SDWN.JBI Master Place Jobs</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>1P1L1.JBI to 1P6L1.JBI Layer 1 Individual Place jobs</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>1P1L2.JBI to 1P6L6.JBI Layer 2 Individual Place jobs</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>1INCBX.JBI Increment B Variable Job</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>1NPAL.JBI Initialization Job</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>EXAMPLE0.jbi Master Job</td>
<td></td>
</tr>
</tbody>
</table>
**Example0.jbi**

MotoPallet EG generates a master job and names it using the first 8 characters of the cell file. The sample shown is for a single pallet cell with no tier sheets in the build and dictated by sequence, not controller I/O. MotoPallet EG would locate a call to place the 0th tier sheet after the ^PALL11 line. The master job calls the initializing job, the pick jobs, the place jobs, and the job to pick/place the 0th tier sheet.

**1upp.jbi**

The 1 means pallet 1, and each pallet has its own upp.jbi. Selecting the “Pallets” option during the JBI creation process generates this job. Selecting the “Single” option generates separate files for each section in the “Upp.jbi.” All the pick jobs are written sequentially in this file, with conditional logic based on the B variable values controlling the branching, exit and entry to the jobs. The list of coordinates for all the robot move points helps identify requests to move outside the reach envelope. Those points have coordinates of 0. Vpp.jbi jobs do not call any other job.

**1sdwn.jbi**

The 1 means pallet 1, and each pallet has its own sdwn.jbi. Selecting the “Pallets” option during the JBI creation process generates this job. All the place jobs are written sequentially in this file, with conditional logic based on the B variable values controlling the branching, exit and entry to the jobs. The list of coordinates for all the robot move points helps identify requests to move outside the reach envelope. Those points have coordinates of 0. “Sdwn.jbi” jobs call INCBX.jbi when each set is placed successfully.

**1npal.jbi**

This job initializes the B variables storing the status of the pallet build.

**1incbx.jbi**

The 1 means pallet 1, and each pallet has its own incbx.jbi. This job is always created.

**1slipp0.jbi**

1slipp0.jbi1 means pallet 1, 0 means tiersheet 0. This job places the tier sheet and is structured like a box place. A tier sheet job is created for all layers even though the build doesn't specify one.
Example1.jbi

Master job for a cell with a single conveyor, a single pallet, the build has no slip sheets and the sequence is not controlled by I/O.

/JOB
//NAME EXAMPLE1
//POS
///NPOS 0,0,0,0,0,0
//INST
///DATE 1999/05/25 12:59
///ATTR SC,RW
///GROUP1 RB1
NOP
'MotoPallet Made!
CALL JOB:1NPAL
SET B009 1
*MAINLINE
*PALL11
'CALL JOB:EJECTPX IF B009=1
'CALL JOB:MOVPX IF B009=1
SET B009 0
SET B001 1
SET B003 1
SET B002 1
'Add Via Point here
'D001 to 8 has pallet height
CALL JOB:1UPP
'Add Via Point here
'D001 to 8 has pallet height
CALL JOB:1SDWN
JUMP *PALL11 IF B001<>0
JUMP *MAINLINE
END
Example2.jbi

Master job for a cell with a single conveyor, four pallets, the build has slip sheets on all 4 pallets, and the sequence is not controlled by I/O.

/JOB
//NAME EXAMPLE2
//POS
///NPOS 0,0,0,0,0
//INST
///DATE 1999/05/26 08:44
///ATTR SC,RW
///GROUP1 RB1
NOP
'MotecPallet Made!
CALL JOB:1NPAL
SET B009 1
CALL JOB:2NPAL
SET B022 1
CALL JOB:3NPAL
SET B035 1
CALL JOB:4NPAL
SET B048 1
*MAINLINE
DIN B001 IG#(1)
DIN B002 IG#(2)
DIN B003 IG#(3)
JUMP *PALLET1 IF B002=1
JUMP *PALLET2 IF B002=2
JUMP *PALLET3 IF B002=3
JUMP *PALLET4 IF B002=4
JUMP *MAINLINE
*PALLET1
JUMP *N_SLIP0 IF B009=0
CALL JOB:1SLIPU
CALL JOB:1SLIPPO
*N_SLIP0
'CALL JOB:EJECTPX IF B009=1
'CALL JOB:MOVPX IF B009=1
SET B009 0
'Add Via Point here
'D001 to 8 has pallet height
CALL JOB:1UPP
'Add Via Point here
'D001 to 8 has pallet height
CALL JOB:1SDWN
JUMP *PALLET1 IF B001<>0
JUMP *MAINLINE
*PALLET2
JUMP *N_SLIP0 IF B022=0
CALL JOB:2SLIPU
CALL JOB:2SLIPPO
*N_SLIP0
'CALL JOB:EJECTPX IF B022=1
'CALL JOB:MOVPX IF B022=1
SET B022 0
'Add Via Point here
'D001 to 8 has pallet height
CALL JOB:2UPP
'Add Via Point here
'D001 to 8 has pallet height
CALL JOB:2SDWN
JUMP *PALLET2 IF B001<>0
JUMP *MAINLINE
*PALLET3
JUMP *N_SLIP0 IF B035=0
CALL JOB:3SLIPU
CALL JOB:3SLIPPO
*N_SLIP0
'CALL JOB:EJECTPX IF B035=1
'CALL JOB:MOVPX IF B035=1
SET B035 0
'Add Via Point here
'D001 to 8 has pallet height
CALL JOB:3UPP
'Add Via Point here
'D001 to 8 has pallet height
CALL JOB:3SDWN
JUMP *PALLET3 IF B001<>0
JUMP *MAINLINE
*PALLET4
JUMP *N_SLIP0 IF B048=0
CALL JOB:4SLIPU
CALL JOB:4SLIPPO
*N_SLIP0
'CALL JOB:EJECTPX IF B048=1
'CALL JOB:MOVPX IF B048=1
SET B048 0
'Add Via Point here
'D001 to 8 has pallet height
CALL JOB:4UPP
'Add Via Point here
'D001 to 8 has pallet height
CALL JOB:4SDWN
JUMP *PALLET4 IF B001<>0
JUMP *MAINLINE
JUMP *MAINLINE
END
Example3.jbi

Master job for a cell with a single conveyor, 4 pallets, the build has slip sheets on all 4 pallets, and the sequence is controlled by I/O.

/JOB
//NAME EXAMPLE3
//POS
///NPOS 0,0,0,0,0,0
//INST
///DATE 1999/05/25 16:33
///ATTR SC,RW
///GROUP1 RB1
NOP
'MotoPallet Made!
CALL JOB:1NPAL
SET B009 1
CALL JOB:2NPAL
SET B022 1
*MAINLINE
*PALL11
JUMP *N_SLIP1 IF B009=0
CALL JOB:1SLIPU
CALL JOB:1SLIPP0
*N_SLIP1
'CALL JOB:EJECTPX IF B009=1
'CALL JOB:MOVPX IF B009=1
SET B009 0
SET B001 2
SET B003 1
SET B002 1
'Add Via Point here
'D001 to 8 has pallet height
CALL JOB:1UPP
'Add Via Point here
'D001 to 8 has pallet height
CALL JOB:1SDWN
JUMP *PALL11 IF B001<>0
*PALL22
JUMP *N_SLIP2 IF B022=0
CALL JOB:2SLIPU
CALL JOB:2SLIPP0
*N_SLIP2
'CALL JOB:EJECTPX IF B022=1
'CALL JOB:MOVPX IF B022=1
SET B022 0
SET B001 2
SET B003 1
SET B002 2
'Add Via Point here
'D001 to 8 has pallet height
CALL JOB:2UPP
'Add Via Point here
'D001 to 8 has pallet height
CALL JOB:2SDWN
JUMP *PALL22 IF B001<>0
JUMP *MAINLINE
END
10.2.1 Numbered Job Format

X 'U''P''P' Pickup Job
X 'S''D''W''N' Place Job
X 'I''N''C''B''X' Box Count Increment Job
X 'N''P''A''L' New Pallet Job
X 'D''E''L''S''I''M' Delete Simulation Element
X 'S''L''I''P''U' Slip Sheet Pickup Job
X 'S''L''I''P''P' Slip Sheet Setdown Job


Layered Pick and Place Jobs

X 'T' 0 0 0 P P
| | | | + - ? Pattern Number (2 digit)
| | | | + ? ? ? Zero (Placeholder)

Job Types

| 1 | Pickup Job(s) |
| 2 | Place Job(s) |
| 3 | Box Count Increment Job |
| 4 | New Pallet Job |
| 5 | Individual Pickup Job (See Details) |
| 6 | Delete Simulation Element |
| 7 | Slip Sheet Pickup Job |
| 8 | Slip Sheet Setdown Job(s) |
### Pickup Jobs - Named

**Master Pickup Job**

```
X 'U' 'P' 'P'
```

**'Individual Job'**

**Option Selected**

```
X 'U' 'L' Z 'P' Y
| | | | + ? ? Package Number
```

**'Combined Job'**

**Option Selected**

No Individual pickup jobs created

### Pickup Jobs - Numbered

**Master Pickup Job**

```
X 1 0 0 0 P P
| | | | + - ? Pattern Number (2 digit)
| | | + ? ? ? Zero (Placeholder)
```

**Layer Jobs Created**

**If Using the 'Compress Pickup Jobs' Option**

```
X 1 L L N P P
| | | | + - ? Pattern Number (2 digit)
| | | + ? ? ? Qty of Boxes (1-4)
```
MotoPallet EG
152380-1

Place Jobs - Named
Master Place Job

|   |   |   | + | ? | ? | ? | Letter 'N'
|   |   |   | + | ? | ? | ? | Letter 'W'


'Individual Job'
Option Enabled

X 'P' 'Z' L 'Y'

|   |   |   | + | ? | ? | ? | Layer Number

'Combined Job'
Option Enabled

No Individual Place jobs created

Place Jobs - Numbered
Master Place Job

| 2 | 0 | 0 | 0 | P | P
|   |   |   |   | + | - | ? | Pattern Number (2 digit)
|   |   |   |   | + | ? | ? | Zero (Placeholder)
|   |   |   | + | ? | ? | ? | Zero (Placeholder)

Layered Place Jobs
Created if 'Split by Layer' Option is Selected

X 2 L L O P P

|   |   |   |   | + | - | ? | Pattern Number (2 digit)
|   |   |   |   | + | ? | ? | Zero (Placeholder)
|   | + | - | ? | ? | ? | Layer Number (2 digit)
10.2.2 Cell Build Options

The Cell Build window contains option buttons and a tree control that displays values for various option settings. To expand the trees branches, click “+” and to collapse a branch, click “-.” Once your selections have been made, click the [Create Robot JBIs] button. The various job options are described as follows:

Table 12 Build Options window

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Build Status</td>
<td>The Build Status tree contains the following information:</td>
</tr>
<tr>
<td></td>
<td>Cell Name</td>
</tr>
<tr>
<td></td>
<td>• Path name to robot directory where JBIs are stored</td>
</tr>
<tr>
<td></td>
<td>• Name of master job that MotoPallet EG generates</td>
</tr>
<tr>
<td></td>
<td>• The pallet builds used in the cell</td>
</tr>
<tr>
<td></td>
<td>• Pallet model name</td>
</tr>
<tr>
<td></td>
<td>• User frame number</td>
</tr>
<tr>
<td></td>
<td>• Robot model name</td>
</tr>
<tr>
<td></td>
<td>• Gripper assignments for each layer</td>
</tr>
<tr>
<td>Installation Information</td>
<td>• Path name for all MotoPallet EG data bases</td>
</tr>
<tr>
<td></td>
<td>• General database name</td>
</tr>
<tr>
<td></td>
<td>• Pallet database name</td>
</tr>
<tr>
<td></td>
<td>• Box database name</td>
</tr>
<tr>
<td>Conveyor information</td>
<td>• Conveyor model name</td>
</tr>
<tr>
<td>Pallet information</td>
<td>• Pallet model names</td>
</tr>
<tr>
<td>Path to JBI archive directory</td>
<td>Tier sheet I/O control data</td>
</tr>
<tr>
<td></td>
<td>• Tier Sheet I/O toggle setting</td>
</tr>
<tr>
<td></td>
<td>• Control I/O input number for Tier sheet 0</td>
</tr>
<tr>
<td></td>
<td>• Control I/O input number for remaining Tier sheets</td>
</tr>
<tr>
<td>Name.JBI data</td>
<td>* Name JBI comment</td>
</tr>
</tbody>
</table>

Robot Job Creation Options

Create Individual Robot Jobs
Creates a single job file for each pick and place operation. Individual Jobs Mode is typically used for troubleshooting purposes by isolating individual pick/place operations. However, it generates a large number of small jobs which can be difficult to manage.

Create Combined Robot Jobs
Creates a single job file that contains all pick and place operations. This reduces cycle time by eliminating 0.2 seconds for each job call.

Place Simulation Comments in Jobs
Creates job files with comments. This enables MotoSim EG to depict boxes. Be aware that JBIs with comments can only be run in MotoSim EG. If you attempt to run JBIs with comments on the robot controller, syntax errors will be generated. MotoPallet EG jobs should be modified in a text editor, or rebuilt with this option unchecked, to remove unnecessary comments before downloading to the robot controller.
### Table 12: Build Options window (Continued)

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Use Orientation Jobs</strong></td>
<td>Orientation job files minimize the T-axis rotation required to place boxes on the pallet. Check this selection if your are using orientation setup JBI files for all pallets and conveyors.</td>
</tr>
<tr>
<td><strong>Adjust Pickup to Clear Top of Pallet</strong></td>
<td>Automatically sets the departure point height for a box pick based on the layer height.</td>
</tr>
<tr>
<td><strong>Archive Jobs</strong></td>
<td>Creates backup copies of the JBIs (except DelSim.jbi) that MotoPallet EG generates into a subdirectory which you specify. Copies of these JBIs, in addition to a DelSim.jbi for each pallet, are always placed in the cell’s robot subdirectory. Backups allow you to organize multiple versions of jobs generated using the same cell in the same MotoPallet EG session.</td>
</tr>
<tr>
<td><strong>Compress Pickup Jobs</strong></td>
<td>Creates a separate pickup job to be called from the main pickup job.</td>
</tr>
<tr>
<td><strong>Use Tier Sheet IO Control</strong></td>
<td>Use Robot I/O to control tier sheet job call.</td>
</tr>
<tr>
<td><strong>Create a Robot Name Job</strong></td>
<td>Creates a file Name.jbi containing a 31-character comment you define. This allows you to identify a group of JBIs downloaded to the controller. View the contents of Name.jbi with the programming pendant. Name.jbi is necessary to distinguish between groups of jobs because MotoPallet EG always uses the same file names for JBIs it generates.</td>
</tr>
<tr>
<td><strong>Create a JBR (Related Job)</strong></td>
<td>Combines all required jobs for a single pattern into one *.jbr file for ease of transfer to the robot controller. Jobs are extracted into separate files when the.jbr file is executed on the robot controller.</td>
</tr>
<tr>
<td><strong>Use Soldier Look Ahead</strong></td>
<td>Creates jobs with boxes placed on end. Contact Motoman Customer Support for additional information.</td>
</tr>
<tr>
<td><strong>Approach Vector Magnitude (mm)</strong></td>
<td>Vectoring minimizes collisions between boxes already on the pallet and new boxes placed on the pallet. When creating a job for a box place, MotoPallet EG automatically adds vectoring towards each adjacent box, in both X and Y directions. X and Y directions are defined by the attachment point coordinate system. The amount of vectoring needed is determined in two parts. Use the offsets defined in the Named Motion Sequence instruction for the approach point of the box place. Vector magnitudes increase the offset of all approach points by the specified value. Magnitude values may range from 25 to 75 millimeters in 5 mm increments and the X-magnitude may differ from the Y-magnitude.</td>
</tr>
</tbody>
</table>
| **Numbered Jobs**              | **Use Numbered Jobs** Names pallet jobs according to specified nomenclature (see Appendix F).  
**Split Numbered Jobs by Layer** Creates uniquely named jobs for each layer.  
**Use Custom JBR Name** Allows you to enter a custom name for the related job (.jbr) file. |
10.2.3 Creating Accurate User Frames (User Coordinates)

Before you can create safe and accurate build jobs that can be safely used in the real cell, you must make sure the user frames used in MotoPallet EG are identical to those used in the actual cell. To do this, create a user frame file for your cell using the robot controller and import this file into MotoPallet EG (refer to Section 10.10.2 “User Coordinate Setting” in the Operator’s Manual for Handling (P/N 149231-1)).

**WARNING!**
Always create new user frame files for each cell. Even cells with the same equipment and floor plans have unique user frames.

Most palletizing operations use 4-axis robots which require that the 3 points that define a user frame lie on a plane parallel to the robot’s base. The Z-coordinate in the robot’s user frame must be the same for all three points.

When creating user frames with tools that do not have physical TCPs, special user frame fixtures can be created to help measure the user frame points. For example, most suction grippers do not have a physical TCP, so a pointer is needed to align its TCP.
Similarly, the user frame for most conveyors is located at the corner created by the siderail, end stop, and conveyor surface, a location impossible for a pointer to access. In this case, it helps to offset the user frame in the +Z-Axis using a box or other physical structure that can be accurately measured.

Refer to the Appendix D, "User Frame Fixture Drawings" for examples of measuring fixtures.

Interference between the gripper and other equipment may prevent use of fixtures. Therefore, solutions are application dependent. The important thing is that the user frames in the real cell are arranged just as they are in the simulation cell.

10.2.3.1 Uploading “Real” User Frames from Robot Controller to MotoPallet EG

**Manual Method**

1. The controller generates a Uframe.cnd file containing all user frames for your cell. Upload this file from the controller to your computer.

2. Overwrite the Uframe.cnd file in the robot directory in your simulation cell.

3. Launch MotoPallet EG and open the cell.

>Note: Be sure to manually overwrite the Uframe.cnd file before opening the cell in MotoPallet EG, or the old user frame file will be used.

**Automatic Method**

The automatic method is useful for creating, within the same MotoPallet EG session, jobs for two cells with the same equipment and floor plan.

1. The controller generates a Uframe.cnd file. Upload this file from the controller to your computer.

2. Launch MotoPallet EG and open the cell.

4. Select Preferences > Choose Uframe.cnd. The “Select a New Uframe.cnd file for Use in the Cell” dialog appears.

5. Browse for the desired Uframe.cnd file and click Open. The selected file is placed in the current cell's robot folder and the cell it replaced is copied to a folder “OldUframe” in the robot folder.

10.3 Required Manual Programming

MotoPallet EG automates many aspects of programming palletizing cells, but there are a few things which must be set up manually based upon the setup of your cell. These include:

- Creating intermediate safe points (also known as “via points”) between pick and place locations to avoid box interference when returning the robot to the pick location.
- Reassigning other memory registers in your controller to gain more B-variables (if you are using three or more pallets in your cell). See Appendix B for additional information.

If you selected the “Place Simulation Comments in Jobs” option from the Cell Build window, MotoPallet EG places comments into the master job that indicate the call locations for your manually created JBIs.
10.3.1 Programming Best Practices

The following lists programming tips to help you create quality palletizing programs.

- Program I/O in small job and call these jobs from the Master job.
- Use NWAIT instruction to minimize robot delays while I/O is executing.
- Use Create Combined Robot Jobs, not Create Individual Robot Jobs, to generate JBs. Individual Jobs Mode is used for troubleshooting purposes and generates a large number of small jobs which can be difficult to manage.
- Program a short a delay when establishing vacuum to ensure gripper has time to secure the box.
- Program a short delay or turn vacuum OFF during approach to assure suction grippers releases the box before departure.
- Reduce speed if boxes are thrown during a robot move. Inertia of the box may exceed the gripper's holding force. Reducing speed may eliminate box crashes.
- Box pickup locations should be positioned so that the gripper can pick the box on its longest/ widest side.
- Accurately measure and enter box dimensions. Accurate measurements will prevent TCP errors and reduce the need for programming offsets.
10.3.2 **Sample Master Job**

Supplemental programming can be performed in a master job or you can create jobs from scratch and call them within the pick/place sequences. Brackets denote which job should be modified (e.g.: [master] or [sequence]). “Sequence” refers to jobs called by the master job.

**Sample Master Job (master.jbi)**

```
/JOB
//NAME MASTER
//POS
///NPOS 1,0,0,1,0,0
///TOOL 0
///POSTYPE PULSE
///PULSE
C0000=-126991,52220,-87316,0,0,60505
///USER 4
///POSTYPE USER
///RECTAN
///RCOFN 0,0,0,0,0,0,0,0
P127=0.000,0.000,1310.800,0.00
,0.00,0.00
///INST
///DATE 1999/04/06 11:19
///ATTR SC,RW
///GROUP1 RB1
NOP
CLEAR STACK
Clears stack from jump to master in CHANGPALL job
DOUT OT#(5) OFF
Starts infeed conveyor
CALL JOB:1NPAL
SET B009 1
WAIT IN#(81)=ON
*MAINLINE
*PALL11
CALL JOB:CHNGPALL IF
IN#(57)=ON
Changes pallet on outfeed conveyor
JUMP *N_SLIP1 IF B009=0
DIN B015 IN#(59)
Slip sheet I/O
JUMP *N_SLIP1 IF B015=0
CALL JOB:1SLIPU
CALL JOB:1SLIPPO
*N_SLIP1
SET B009 0
SET B001 1
SET B003 1
SET B002 1
'AFTER CRASH RESET B005
'AND B004
```
Supplemental Programming

Pickup

1. [master] Create intermediate safe points (also known as “via points”) between pick and place locations to avoid box interference when the robot returns to the pick location. The height of the current pallet is stored in a D-variable (see Appendix for list of variables) so that the height of the point is calculated based on the height of the stacked boxes and eliminate unnecessary robot motion.

2. [sequence] Activate gripper (VACON).

3. [sequence] Error checking.
   — confirm proper number of boxes and proper placement for pickup.
   — confirm boxes are attached to gripper.
   — confirm proper recovery from an error (retry, pause, etc.)
Setdown

1. [sequence] Deactivate gripper (VACOFF).
2. [sequence] Error checking
   — Confirm box is gone (from gripper) after place.
3. [master] MotoPallet EG can automatically create an intermediate point between the pick and place if this option is selected.

Note: Automatic intermediate point works only if there is one pallet in the cell and only between pick and place, not place and pick.

10.3.4 Supplemental Programming for Tier Sheets

New Job [call from sequence]

A new job orients the gripper on pickup to control gripper orientation (T-axis) in the sequence position definition parameters. This job is called from the master job.

Controlling rotation of the gripper minimizes wrapping of hoses/cables about the T-axis and allows placement of tier sheets on pallets which are oriented differently in the cell.

Search Job [call from sequence]

As tier sheets are consumed, the stack height changes. Relying on physical contact with the gripper would cause an overdrift crash of the robot.

Use a search job to detect the top of the tier sheet stack using a gripper-mounted proximity sensor. The gripper approaches the tier sheet stack from a safe position directly above the pickup location and descends until the proximity sensor signals the robot to stop.

The search job can use either an UNTIL command or a SEARCH command to detect layer height.

Note: The Search command is an advanced programming feature that requires a purchased option.

Sample Tier Sheet Job Using MOVL and UNTIL Commands

```
/JOB
//NAME SLIPSHT
//POS
///NPOS 4,0,0,1,0,0
///TOOL 0
///POSTYPE PULSE
///PULSE
C0000=-186043,24292,-54547,0,0,88495
C0001=-186043,69892,-96497,0,0,88495
C0002=-186043,24292,-54547,0,0,88495
C0003=-138960,-20,-53788,0,0,64609
///POSTYPE ROBOT
```
Set down [call from sequence]

Tier sheets tend to be made from thin, flimsy material that must be draped onto the pallet rather than being simply picked and placed. The setdown job defines coordinates so that the gripper can rotate and drape the tier sheet on top of the pallet without folding the tier sheet over.

**CAUTION!**
When generating named motion sequence offsets, the coordinates used for tier sheet handling are in the attachment point axis system, not the pallet’s.

**I/O Control for Tier Sheets**

MotoPallet EG will provide instructions for checking input values and using conditional logic (if-then) to decide whether or not to pick/place a tier sheet in the sequence. A unique place job is automatically written to check MRC input status for each tier sheet that you specify in the master job.

The master job contains the first tier sheet conditional instruction. All remaining conditional instructions must be manually added to the tier sheet pickup jobs.

**10.3.5 Supplemental Programming for External Equipment**

External programming usually consists of special I/O to control safety interlocks, conveyors, and other non-robotic equipment in the cell. Create external programming jobs and call them from the master job.
10.4 Pre-production Testing

10.4.1 Simulate Palletizing and Refine Robot Jobs

A major advantage of MotoPallet EG is its ability to work with MotoSim EG to perform off-line cycle time and reach analysis. This allows you to test, analyse, and adjust palletizing jobs before uploading them to the controller. This permits the robot to remain in production until the new job is loaded instead of taking the robot off-line to program and test jobs.

**Note:** Make sure the user frames used in MotoPallet EG are identical to those used in the actual cell. Make sure you are using the “real” user frames (the Uframe.cnd files created on with the robot) for pre-production test simulations (Section 10.2.3, "Creating Accurate User Frames (User Coordinates)").

Manual programming is required to complete the MotoPallet EG programming process. Add your manually programmed jobs to the cell and run in the simulation. MotoSim requires the INFORM II command “RET” before “END” in every JBI file or MotoSim EG will stop executing a simulation when the job is called.

MotoPallet EG creates a JBI called DelSimx.jbi (x=pallet number). These files are not placed in the archive directory and are only used during simulations to delete boxes from a completed pallet. Running these jobs manually may be necessary if a simulation is stopped before completion in order to hide the box models before running the next simulation.

Once you are satisfied that the cell simulation is running satisfactorily, the MotoPallet EG operations are complete and you are ready to load your jobs into the robot controller and perform a test run.

10.4.2 Loading Jobs and Performing Test Run

Download the job to your robot controller and run at slow speed to ensure safe operation. Manually program a master job to control the robot from the Place job locations to the Pick job locations, operate the gripper, search for the top of tier sheets, control conveyors, provide safety interlocks, etc.

**Conveyor Design Tip:**

When designing box stops on your conveyor, don’t allow any portion of the box (side flap, etc.) to extend beyond the stop. MotoPallet EG can only define the sides of the box by referencing the rectangle formed by the boxes four Axis6 points.
Appendix A

Asynchronous Place

A.1 Overview

Asynchronous Place is a function which allows you to palletize multiple boxes at one time. In MotoPallet EG, Asynchronous Place allows you to pick up to four (4) boxes in one pick and then place them on the pallet using a single or multiple place as determined by the pallet pattern. This pick and place sequence is repeated until all of the boxes are placed on the pallet. This function allows you to finish pallet patterns and still meet high cycle time requirements. Optimum pick and place sequences will be generated automatically by the software.

This function is implemented as a dll file called by MotoPallet EG. The dll files used are ‘PickPl1.dll’ for full optimization, and ‘PickPl2.dll’ for partial optimization. The algorithm looks at each pallet layer (number of boxes, box position, and orientation), the tool data (maximum number of boxes for a single pick), and determines the optimum pick and place sequence required to build the desired pallet in the minimum time.

Most patterns will require some odd number of picks and places to finish.

For example, if the pallet patterns shown below were built by picking four boxes using the gripper configuration shown, it would take three picks of four boxes, two placements of four boxes, and two placements of two boxes each to complete the pattern.

![Gripper Configuration](image)

![Pallet Pattern](image)
A.1.1 Features

Asynchronous Place features include:

- ** Vectoring**, the ability to place boxes on the pallet using a safe approach angle whenever possible. A user-defined numerical value or the default can be used.
- ** Full optimization option**, which is used to minimize cycle time (number of picks) for pallet layers with loosely packed boxes. This will reduce vectoring. This option should be used with extreme caution and is recommended only for advanced users with adequate experience, as reduced vectoring may result in box clipping during box placement.
- ** Simplified optimization option** - This option is used when handling more than 4 boxes.
- ** Best or Partial optimization option**, the default, is used 95 percent of the time. This places boxes in a somewhat ordered fashion and results in maximum vectoring, which is highly desirable for tightly packed boxes on the pallet layer. A number of different strategies may be used for line grippers, and this option chooses the best to maximize vectoring and minimize cycle time.
- ** Ordered option (available only for line grippers)**, which is used when you want to control the sequence order of the boxes placed on the pallet. The boxes are placed in the same order sequence as the boxes are input in the layer editor.
- ** Gripper configurations**, which use either linear type or squared type.

![Linear and Square Grippers](image)

- **Maintain orientation option**, which is used to ‘true’ orient the box as desired. This results in four box orientations during box placement – 0°, 90°, 180°, 270°, as opposed to the default, which uses only a 0° and 90° angle for box placement. This option is available only with linear-type grippers. Use this option only if needed as it may result in slower cycle times.

A.1.2 Limitations

- Asynchronous place function can only be used with vacuum grippers.
- Boxes held by the gripper must be snug (touching) against each other.
- Only one pick is allowed for each pick-place sequence (box layout for pick-up should match box layout as held by the gripper).
- Four is the maximum number of boxes the gripper is allowed to pick up.
- Vacuum cup locations are symmetrical in both axes about the tool center point (TCP). Geometrically, the TCP coincides with the center of the set for a four-box pickup.
- For square grippers, as the ordered option is not available and fewer procedures are used, full vectoring on all box placements is not always possible.
- The “Maintain Orientation” option is not available with square grippers.
Appendix B

B-Variables

<table>
<thead>
<tr>
<th>All Pallets</th>
<th>B001</th>
<th>Duration of current pick/place operation (1=single pick/place, 2=pick/place complete layer, 3=pick/place complete pallet)</th>
</tr>
</thead>
<tbody>
<tr>
<td>B002</td>
<td>Place on Pallet #1 to 8</td>
<td></td>
</tr>
<tr>
<td>B003</td>
<td>Pick from Conveyer #1 to 8</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Pallet 1</th>
<th>B004</th>
<th>Current Layer pallet #1</th>
</tr>
</thead>
<tbody>
<tr>
<td>B005</td>
<td>Current Pick</td>
<td></td>
</tr>
<tr>
<td>B006</td>
<td>Current Box(es) have been placed – Cleared at beginning of set down sequence. Set to 1 after all boxes on the gripper have been placed</td>
<td></td>
</tr>
<tr>
<td>B007</td>
<td>Total layers of products – Note: Slipsheets do not count as layers. Must be between 1 and 25</td>
<td></td>
</tr>
<tr>
<td>B008</td>
<td>Number of Picks per layer – Note that this variable is updated each time a new layer is begun.</td>
<td></td>
</tr>
<tr>
<td>B009</td>
<td>Pallet Complete – Set in Main job and in Xinchx.jbi where (X) is the pallet Number. 1 indicates that the pallet is completely loaded</td>
<td></td>
</tr>
<tr>
<td>B010</td>
<td>Pickup operation has been completed when value = 1, 0 indicates pickup has not been completed</td>
<td></td>
</tr>
<tr>
<td>B011</td>
<td>1=Zone 1 of Gripper must be turned on to pickup the desired box, 0=turn off</td>
<td></td>
</tr>
<tr>
<td>B012</td>
<td>1=Zone 2 of Gripper must be turned on to pickup the desired box, 0=turn off</td>
<td></td>
</tr>
<tr>
<td>B013</td>
<td>1=Zone 3 of Gripper must be turned on to pickup the desired box, 0=turn off</td>
<td></td>
</tr>
<tr>
<td>B014</td>
<td>1=Zone 4 of Gripper must be turned on to pickup the desired box, 0=turn off</td>
<td></td>
</tr>
<tr>
<td>B015</td>
<td>Optional I/O control of Tier sheet Layer 0 (on the Pallet)</td>
<td></td>
</tr>
<tr>
<td>B016</td>
<td>Optional I/O control of Tier sheets on all Layers except Layer 0</td>
<td></td>
</tr>
<tr>
<td>D001</td>
<td>Height of the current pallet layer</td>
<td></td>
</tr>
<tr>
<td>B017</td>
<td>Current layer Pallet #2</td>
<td></td>
</tr>
<tr>
<td>------</td>
<td>------------------------</td>
<td></td>
</tr>
<tr>
<td>B018</td>
<td>Current Pick</td>
<td></td>
</tr>
<tr>
<td>B019</td>
<td>Current Box(es) have been placed – Cleared at the beginning of setdown sequence. Set to 1 after all boxes on the gripper have been placed</td>
<td></td>
</tr>
<tr>
<td>B020</td>
<td>Total layers of products – Note: Slipsheets do not count as layers! Must be between 1 and 25</td>
<td></td>
</tr>
<tr>
<td>B021</td>
<td>Number of Picks per layer – Note that this variable is updated each time a new layer is begun</td>
<td></td>
</tr>
<tr>
<td>B022</td>
<td>Pallet Complete – Set in Main job and in Xincbx.jbi where (X) is the pallet Number. 1 indicates that the pallet is completely loaded</td>
<td></td>
</tr>
<tr>
<td>B023</td>
<td>Pickup operation has been completed when value = 1, 0 indicates pickup has not been completed</td>
<td></td>
</tr>
<tr>
<td>B024</td>
<td>1=Zone 1 of Gripper must be turned on to pickup the desired box, 0=turn off</td>
<td></td>
</tr>
<tr>
<td>B025</td>
<td>1=Zone 2 of Gripper must be turned on to pickup the desired box, 0=turn off</td>
<td></td>
</tr>
<tr>
<td>B026</td>
<td>1=Zone 3 of Gripper must be turned on to pickup the desired box, 0=turn off</td>
<td></td>
</tr>
<tr>
<td>B027</td>
<td>1=Zone 4 of Gripper must be turned on to pickup the desired box, 0=turn off</td>
<td></td>
</tr>
<tr>
<td>B028</td>
<td>Optional I/O control of Tier sheet Layer 0 (on the Pallet)</td>
<td></td>
</tr>
<tr>
<td>B029</td>
<td>Optional I/O control of Tier sheets on all Layers except Layer 0</td>
<td></td>
</tr>
<tr>
<td>D002</td>
<td>Height of the current pallet layer</td>
<td></td>
</tr>
<tr>
<td>Pallet 3</td>
<td>B030</td>
<td>Current layer Pallet #3</td>
</tr>
<tr>
<td>---------</td>
<td>------</td>
<td>------------------------</td>
</tr>
<tr>
<td></td>
<td>B031</td>
<td>Current Pick</td>
</tr>
<tr>
<td></td>
<td>B032</td>
<td>Current Box(es) have been placed – Cleared at top of setdown sequence. Set to 1 after all boxes on the gripper have been placed</td>
</tr>
<tr>
<td></td>
<td>B033</td>
<td>Total layers of products – Note: Slipsheets do not count as layers! Must be between 1 and 25</td>
</tr>
<tr>
<td></td>
<td>B034</td>
<td>Number of Picks per layer – Note that this variable is updated each time a new layer is reached</td>
</tr>
<tr>
<td></td>
<td>B035</td>
<td>Pallet Complete – Set in Main job and in Xincbx,jbi where (X) is the pallet Number. 1 indicates that the pallet is completely loaded</td>
</tr>
<tr>
<td></td>
<td>B036</td>
<td>Pickup operation has been completed when value = 1, 0 indicates pickup has not been completed</td>
</tr>
<tr>
<td></td>
<td>B037</td>
<td>1 = Zone 1 of Gripper must be turned on to pickup the desired box</td>
</tr>
<tr>
<td></td>
<td>B038</td>
<td>1 = Zone 1 of Gripper must be turned on to pickup the desired box</td>
</tr>
<tr>
<td></td>
<td>B039</td>
<td>1 = Zone 3 of Gripper must be turned on to pickup the desired box</td>
</tr>
<tr>
<td></td>
<td>B040</td>
<td>1 = Zone 4 of Gripper must be turned on to pickup the desired box</td>
</tr>
<tr>
<td></td>
<td>B041</td>
<td>Optional I/O control of Tier sheet Layer 0 (on the Pallet)</td>
</tr>
<tr>
<td></td>
<td>B042</td>
<td>Optional I/O control of Tier sheets on all Layers except Layer 0</td>
</tr>
<tr>
<td></td>
<td>D003</td>
<td>Height of the current pallet layer</td>
</tr>
</tbody>
</table>
**Expanding Global Variables in the XRC Controller**

If you are using more than 2 pallets, you will need to expand the global variable registers in your controller. The default limit is 39 B-variables. Only a Motoman factory technician can expand the amount of global byte-type arithmetic variables in the controller:

*Note: If the controller is used for intensive job operations and communications among other devices, you may want to consider expanding the job memory capacity by adding an MMM02 Memory Module. Call Motoman Service if you need help determining exactly how much additional memory you need.*

<table>
<thead>
<tr>
<th>Pallet 4</th>
<th>B043</th>
<th>Current layer Pallet #4</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>B044</td>
<td>Current Pick</td>
</tr>
<tr>
<td></td>
<td>B045</td>
<td>Current Box(es) have been placed – Cleared at top of setdown sequence. Set to 1 after all boxes on the gripper have been placed</td>
</tr>
<tr>
<td></td>
<td>B046</td>
<td>Total layers of products – Note: Slipsheets do not count as layers! Must be between 1 and 25</td>
</tr>
<tr>
<td></td>
<td>B047</td>
<td>Number of Picks per layer – Note that this variable is updated each time a new layer is reached</td>
</tr>
<tr>
<td></td>
<td>B048</td>
<td>Pallet Complete – Set in Main job and in Xincbx.jbi where (X) is the pallet Number. 1 indicates that the pallet is completely loaded</td>
</tr>
<tr>
<td></td>
<td>B049</td>
<td>Pickup operation has been completed when value = 1, 0 indicates pickup has not been completed</td>
</tr>
<tr>
<td></td>
<td>B050</td>
<td>1 = Zone 1 of Gripper must be turned on to pickup the desired box</td>
</tr>
<tr>
<td></td>
<td>B051</td>
<td>1 = Zone 2 of Gripper must be turned on to pickup the desired box</td>
</tr>
<tr>
<td></td>
<td>B052</td>
<td>1 = Zone 3 of Gripper must be turned on to pickup the desired box</td>
</tr>
<tr>
<td></td>
<td>B053</td>
<td>1 = Zone 4 of Gripper must be turned on to pickup the desired box</td>
</tr>
<tr>
<td></td>
<td>B054</td>
<td>Optional I/O control of Tier sheet Layer 0 (on the Pallet)</td>
</tr>
<tr>
<td></td>
<td>B055</td>
<td>Optional I/O control of Tier sheets on all Layers except Layer 0</td>
</tr>
<tr>
<td></td>
<td>D004</td>
<td>Height of the current pallet layer</td>
</tr>
</tbody>
</table>

*Note: Pallets #5 to 8 repeat the same pattern in groups of 13.*
Appendix C

Troubleshooting

Error Message

“Error in conversion of Inf to JBI 1P6L1.INF”

Meaning

MotoSim can’t create a job for the first box place on the sixth layer of pallet 1.

Occurs when you click Create job if you attempted to move the robot outside of its maximum reach envelope during a box place. A separate error message will occur for each box outside the reach envelope.

Corrective Action

1. (MotoSimEG) Select Robot > Reach View > Reach View... . The Reach Area window appears.
2. Select Tool Mode and 2D display and click the [Execute] button. Click [OK].
3. Step through the 1P6L1.jbi job and look for the MOV instruction where all joint parameters are zero and the robot suddenly moves to the Home position. MotoSim EG sets all joint parameters to zero when the specified point is outside the reach envelope, or close enough to trip soft limits.

Note: When creating JBIs using the “Pallet” option, the particular box place which caused the problem is not indicated in the job name (1sdwn.jbi). In this case, scan the Cxxx Position variables at the beginning of the 1sdwn.jbi job to determine the location of the problem.

4. To correct the problem, move the robot or pallet so that the entire pallet build is within the robot’s reach envelope. Watch the reach view to determine the direction and amount the robot is attempting to exceed the envelope.
5. In cases where box height is large, one possible solution is to manually override the box place sequence so that the first boxes placed on a layer are farthest from the robot and subsequent boxes are placed closer to the robot. This permits lowering the Z-offset of the approach position.
**Error Message**

“Asynch Warning=Pallet1, Layer 1 Warning(s) Set-Boxes 1,3 interferes with Set-boxes 2, Pallet1, Layer1 Warning(s) Boxes with no vector-2”

**Meaning**

Pallet 1, Layer 1 has boxes that overlap, specifically, box 2 is placed straight down (no vectoring) to avoid colliding with boxes 1 and 3. There are two causes for not having vectoring on a box place:

- The box placement sequence attempted to place a box into a four-sided hole.
- Final box positions overlap in the layer.

Occurs when you click OK in the Cell View dialog, and a box place has no sideways motion (vectoring). There will be one warning for each layer that contains overlapping boxes. The same warning will list all boxes that overlap in the same layer.

**Corrective Action**

1. Observe a simulation of the job. If you see that box 2 placed into a four-sided hole on layer 1, pallet 1, you must change the strategy for selecting the box placement sequence. When adding a build to a cell in the Cell View dialog, click the “Best” option. If this results in a place to a four-sided hole, then manual override is required. Modify the box input order for the layer and click the ordered option in the Cell View dialog.

2. If there is no place into a four-sided hole, then you must look at the coordinates of the boxes listed in the warning. There are two references which supply this information. The first is the layer editor, which displays the box coordinates of the selected box. The second is the Asynchxx.asi files for each layer (xx=layer number). The Asynchxx.asi file contains the actual values MotoPallet EG uses, and lists both the box dimensions and the box coordinates of the corner closest to the pallet user frame.

3. There are two ways to edit the location of a box. The first is to use the layer editor to drag and drop boxes in the desired location. The second is to use a text editor to modify the *.pos file for the layer, then check the layer with the layer editor to confirm proper box placement.

**Error Message**

“Asynch Warning=Pallet 1, Layer1 Warning(s) Boxes with only X vector=6”

**Meaning**

Box 6 only has side motion in the X-direction of the attachment point coordinate system.

Occurs when you click OK in the Cell View dialog if you attempt to add a build with a layer and MotoPallet EG has chosen a box place sequence that includes placing a box into a slot or 3-sided hole.

**Corrective Action**

1. Modify the box place sequence so that box 6 is not placed between two other boxes.

2. There are two ways to modify the box place sequence. First, click the “Best” option when adding a build to a cell in the Cell View dialog. MotoPallet EG may automatically find a sequence without the problem. Second, Create your own solution using manual override if MotoPallet EG cannot automatically find a solution. Choose your sequence and modify your box input sequence for the layer as described in Section 4, Create Layer Patterns.
Appendix D

User Frame Fixture Drawings
Dimensions vary with application. Bolt hole pattern must allow mounting to the underside of gripper.
Typical Robot Pointer Used in Conveyor Belt

KEEP POINT SHARP
NOTES
Appendix E

Using MotoPallet EG with a Tool of 5 or More Boxes

The following section provides information for using MotoPallet EG with gripper tools that can handle 5 or more boxes.

E.1 Tool Definition in the “ToolData” Database Table

MotoPallet EG can handle up to 32 individual boxes using the vacuum and ‘Unigripper’ style tools. When defining gripper tools capable of handling 5 or more boxes, cup definition can be simplified by defining only one set of cups, (either 3 or 4 cups), that defines one box pickup. This one box definition defines the orientation for the rest of the cups on the gripper. All other cups are assumed to be in the same orientation.

E.2 Asynchronous Pick & Place

When using a 5 box or greater tool, the only choice for the Asynchronous Type selection is ‘Simplified’. This algorithm works from the farthest position away from the robot to the closest position. Keep in mind that not all pallet patterns can be used with the Simplified approach. The assumption is that when a tool of 5 or more boxes is used, it is generally going to be a ‘row’ oriented type of palletizing operation. Pallet patterns with a lot of non-linear box placements may not be placed properly. You should always simulate the results when setting up a new pallet pattern to verify that the results are acceptable.
E.3 Gripper I/O

There are four B-variables per build station that are allocated to gripper I/O. For example, on build station one, B-variables B011, B012, B013, and B014 are used. In a standard gripper with 4 boxes or less, each variable is assigned a value of 1 or 0 to signify the state of the I/O needed to actuate and release the gripper vacuum. One (1) being the ‘Vacuum On’ state and zero (0) representing the ‘Vacuum Off’ state. Zone 1 is controlled by B011, Zone 2 is controlled by B012 and so on.

When using a tool greater than 4 boxes, the B variables are utilized differently. For these grippers, each bit represents a gripper zone in a binary pattern.

For example, on build station one, variable B011 represents grippers 1-8. So, to energize gripper 4, the fourth bit would need to be set to a 1 giving B011 a value of ‘8’ ($2^4$th power). If grippers 1-3 need to be energized, the value of B011 would be 7 ($2^1$rst + $2^2$nd + $2^3$rd).

Following this logic, variable B012 would represent grippers 9-16, B013 would represent grippers 17-24, and B014 would represent grippers 25-32.
Glossary

*.pos files
Files that contain the position information for the boxes.

Asynchronous
Not at the same time.

Attachment Point
An Axis6 point on the box (or tier sheet) model where the TCP is positioned while carrying a box (or tier sheet) model.

Axis6 Points
Snap to points located at important locations throughout the cell.

B-variables
These variables store the number of boxes, pallets, and boxes.

Best Solution
This option passes each layer pattern through ten or more strategies that weigh acceptance criteria such as: number of picks, number of places, number of places with single vectoring, and number of places with no vectoring.

Cape Pack 99
Pallet layout software used to generate pallet diagrams for manually loaded pallets.

Cycle Time
The time required to complete a sequence of steps.

D-Variable
These variables store the height of the current pallet.

Departure Point
In a pick and place operation, this point allows the robot to move at full speed without hitting an obstacle.

Duration
This describes whether a conveyor is used to supply product one box at a time, one layer at a time, or until an entire pallet is built.
**Embedded Mode**
This mode allows MotoSim to run within the MotoPallet window so you can make adjustments to your cell and view cell layout while simultaneously accessing MotoPallet commands.

**Fork Gripper**
A tool that picks up a box by sliding underneath it.

**Full Mode**
This mode minimizes the number of picks at the cost of maximizing the number of places with single or no vectoring.

**Gripper**
A tool attached on the end of the robot arm and used to pick up the product.

**Hardware Key**
This key connects to parallel port of your computer and determines which MOTOMAN software you will be able to run.

**Home Position**
Position of robot where all joint parameters are zero.

**I/O**
Inputs to or outputs from the robot controller which provide status information for decision making in robot jobs.

**INFORM II**
The robot programming language controller.

**JBI**
Files that contain the job instructions.

**Job**
A set of robot instructions in the INFORM II programming language.

**Layer Height**
The height of the boxes that make up a layer.

**Layer Pad**
A sheet, usually cardboard, that is placed between layers on a pallet to give it more stability.

**Layer Pattern**
The position order of box coordinates for a layer, specified in either the output file from Cape Pack 99 or the order in which the boxes were added in MotoPallet.

**MRC**
Robot Controller

**Named Motion Sequence**
A series of steps that contain frequently-used motions.

**No-vectored Job**
A job that moves the robot up and down, but not side to side.

**Off-line**
The controller is not connected to the robot.
OLE Mode
This mode is a production mode designed to use after you have created and set up the cell.

Ordered
This option is a manual override which allows you to use the layer editor to edit the layer pattern position order.

Outfeed Pallet Conveyors
These are conveyors that carry the pallets to and from the loading point.

Paldbnew.mdb
A Microsoft Access database that is used to store most of the information for MotoPallet.

Pallet Build
Various combinations of pallet layers used to build your pallet.

Pallet Pattern
The position of boxes that make up a pallet layer.

Pick
The act of taking an item off of the conveyor.

Place
The act of placing an item onto the pallet.

Reach Analysis
Determines whether or not the robot can place the gripper at a point in space.

Side Gripper
A tool that picks up boxes with two arms, one on each side.

Single-vectored Job
A job that moves the robot sideways in one direction of the gripper coordinate system.

SKU number
A unique name to keep track of boxes.

Slip Sheet
A sheet, usually cardboard, that is placed between layers on a pallet to give it more stability.

TCP
The gripper's Tool Control Point (X, Y, and Z offset from T-axis flange measured in millimeters).

Tier Sheet
A sheet, usually cardboard, that is placed between layers on a pallet to give it more stability.

User Frames
A coordinate system (with known relationship to the robot coordinate system) used for programming robot jobs related to certain locations.

Vectoring
Side motion on the pallet during a box place in order to minimize collisions with other boxes.

Via Points
Intermediate points between pick and place locations used to avoid box interference when the robot returns to the pick location.
NOTES
Index

Symbols
.POS Files , 20

Numerics
1incbx,jbi , 100
1npal,jbi , 100
1sdwn,jbi , 100
1slipp0,jbi , 100
1upp,jbi , 100
3D Drag and Drop Editor , 82

A
ANSI/RIA , 7
ASO File , 96
Asynch11.asi , 95
Asynch11.asi.oui , 96
Asynch11.asi.oui2 , 96
Asynch11.aso , 96
Attachment Point , 59
Automatically Generated Jobs , 95

B
Box
Definition , 78
Orientation , 62
Pickup Motion , 66
Setdown Motion , 67
Build Jobs , 98

C
Cape Pack 99 Data , 78
Cell
Build , 92
Setup , 41
Wizard , 24
CellBuild
Options , 108
Conveyor
Box Placement , 45
Pallet Combinations , 42
Pallet Sequencing , 43
Tool Pickup Orientation , 48
Create a Cell , 24
Creating a Cell , 24

D
Database Files , 20

E
Example0.jbi , 100
Example1.jbi , 101
Example2.jbi , 102
Example3.jbi , 104
Existing Gripper , 54

F
Fork Gripper
TCP , 52
Fork Grippers , 49
Fork/Side Attachment Point , 53

G
General Safeguarding Tips , 8
Gripper
Approach Orientation , 62
Components , 54
Model Files , 55
Position , 55
Specification , 62
Tool Center Point , 52
Tools , 49

H
Hardware Key , 16

I
Installation , 13
Safety , 9
Interlocking Layers , 86
Introduction , 1
IO Controlled , 43
Index

L
Layer Pattern
   Definition , 81
   Position Order , 86
LookAheadComponent.dll , 21

M
Maintenance Safety , 10
Mechanical Safety Devices , 9
Modify
   Cell , 27
   Tool Data , 30
Motion Sequences , 66

N
Named Motion Sequences , 66
New Gripper Setup , 57
Numbered Job Format , 105

O
Operating Structure , 19
Operation Safety , 10
Orientation
   Jobs , 68
Overview , 3

P
Pallet
   Builds , 87
   Definition , 79
   Patterns , 77
Pickup Orientation , 48
PLC Cell Controller , 18
Position Models , 27
Positioning Boxes , 85
Process , 17
Programming
   Operation, and Maintenance Safety , 10
   Safety , 10

R
Reference to Other Documentation , 4
Robot
   Jobs , 91
   Settings , 65
Robotic Industries Association , 7
Round Robin / Custom , 43

S
Safeguarding Tips , 8
Safety , 7
   Devices , 9
Service , 5
Setup Model Property , 24
Side
   Gripper TCP , 52
   Grippers , 49
Simulation Cell , 23
Specifications , 3
Suction Gripper
   Attachment Point , 54
   TCP , 52
Suction Grippers , 50
System Requirements , 4

T
Tiersheet
   Pickup Motion , 67
   Setdown Motion , 68
Tool
   Attachment Point , 53
   Gripper , 56
   Wizard.dll , 21

U
UniGripper
   Attachment Point , 54
Unigripper
   TCP , 52
Uni-Grippers , 50
User Frames , 31, , 46
   (User Coordinates) , 110