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SECTION 1

INTRODUCTION
1.1

About this Document
The Motoman File Management System (FMS) Manual provides information
about advanced file management and version control using the Motoman FMS
application. This includes detailed instructions for using the FMS Connector and
FMS Admin applications. A glossary of terms used throughout the document, and
application is also included.
Please read this manual for safety precautions, installation instructions, and other
important information before using Motoman FMS.
This manual is intended as an introduction and overview for personnel who are
familiar with the operation of their Motoman robot model and Microsoft®
Windows®/PC usage.
This manual contains the following sections:

SECTION 1 – INTRODUCTION
General information about this manual, a list of reference documents, and
customer service information.

SECTION 2 – SAFETY
Provides information for the safe use and operation of Motoman products.

SECTION 3 – FILE MANAGEMENT SYSTEM MANUAL
This manual is designed to supply advanced file management and version control.
It provides several higher-level functions such as ensuring data and program
integrity, along with tracking program “check-ins” and “checkouts” by user and
time. The first section of the manual will give some general information about the
File Management System application. The second section will help in getting
started with the application. In the third section, specific details will be discussed
regarding the usage of the FMS application. In section 4 and 5, details regarding
the usage of the FMS Connector and the FMS Admin applications will be
addressed. Chapter 6 lists technical support information, and at the back of the
manual, you will find FMS Scheduler installation instructions and a glossary of
terms used throughout the documentation and application.

1.2

Reference to Other Documentation
For additional information refer to the following:
• Motoman manipulator manual that was shipped with your system

1.3

Customer Service Information
If you are in need of technical assistance, contact the Motoman service staff at
(937) 847-3200. Please have the following information ready before you call:
• Robot Type (UP6, UP130, UP165, etc.)
• Application Type (welding, handling, etc.)
• Robot Serial Number (located on the back side of the robot arm)
• Robot Sales Order Number (located on back side of XRC controller)

MOTOMAN

1-1

File Management System Manual

INTRODUCTION

NOTES

File Management System Manual

1-2

MOTOMAN

SECTION 2

SAFETY
2.1

Introduction
.

It is the purchaser's responsibility to ensure that all local, county,
state, and national codes, regulations, rules, or laws relating to
safety and safe operating conditions for each installation are met
and followed.
We suggest that you obtain and review a copy of the ANSI/RIA National Safety
Standard for Industrial Robots and Robot Systems. This information can be
obtained from the Robotic Industries Association by requesting ANSI/RIA
R15.06. The address is as follows:
Robotic Industries Association
900 Victors Way
P.O. Box 3724
Ann Arbor, Michigan 48106
TEL: (734) 994-6088
FAX: (734) 994-3338
Ultimately, the best safeguard is trained personnel. The user is responsible for
providing personnel who are adequately trained to operate, program, and maintain
the robot cell. The robot must not be operated by personnel who have not been
trained!
We recommend that all personnel who intend to operate, program, repair, or use
the robot system be trained in an approved Motoman training course and become
familiar with the proper operation of the system.
This safety section addresses the following:
• Standard Conventions (Section 2.2)
• General Safeguarding Tips (Section 2.3)
• Mechanical Safety Devices (Section 2.4)
• Installation Safety (Section 2.5)
• Programming Safety (Section 2.6)
• Operation Safety (Section 2.7)
• Maintenance Safety (Section 2.8)
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2.2

Standard Conventions
This manual includes information essential to the safety of personnel and
equipment. As you read through this manual, be alert to the four signal words:
• DANGER
• WARNING
• CAUTION
• NOTE
Pay particular attention to the information provided under these headings which
are defined below (in descending order of severity).

DANGER!
Information appearing under the DANGER caption concerns the
protection of personnel from the immediate and imminent hazards
that, if not avoided, will result in immediate, serious personal injury
or loss of life in addition to equipment damage.

WARNING!
Information appearing under the WARNING caption concerns the
protection of personnel and equipment from potential hazards that
can result in personal injury or loss of life in addition to equipment
damage.

CAUTION!
Information appearing under the CAUTION caption concerns the
protection of personnel and equipment, software, and data from
hazards that can result in minor personal injury or equipment
damage.
NOTE:

Information appearing in a NOTE caption provides additional information which is helpful in
understanding the item being explained.
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2.3

General Safeguarding Tips
All operators, programmers, plant and tooling engineers, maintenance personnel,
supervisors, and anyone working near the robot must become familiar with the
operation of this equipment. All personnel involved with the operation of the
equipment must understand potential dangers of operation. General safeguarding
tips are as follows:
• Improper operation can result in personal injury and/or damage to the
equipment. Only trained personnel familiar with the operation of this robot,
the operator's manuals, the system equipment, and options and accessories
should be permitted to operate this robot system.
• Do not enter the robot cell while it is in automatic operation. Programmers
must have the teach pendant when they enter the robot cell.
• Improper connections can damage the robot. All connections must be made
within the standard voltage and current ratings of the robot I/O (Inputs and
Outputs).
• The robot must be placed in Emergency Stop (E-STOP) mode whenever it is
not in use.
• In accordance with ANSI/RIA R15.06, section 6.13.4 and 6.13.5, use
lockout/tagout procedures during equipment maintenance. Refer also to
Section 1910.147 (29CFR, Part 1910), Occupational Safety and Health
Standards for General Industry (OSHA).

2.4

Mechanical Safety Devices
The safe operation of the robot, positioner, auxiliary equipment, and system is
ultimately the user's responsibility. The conditions under which the equipment
will be operated safely should be reviewed by the user. The user must be aware of
the various national codes, ANSI/RIA R15.06 safety standards, and other local
codes that may pertain to the installation and use of industrial equipment.
Additional safety measures for personnel and equipment may be required
depending on system installation, operation, and/or location. The following safety
measures are available:
• Safety fences and barriers
• Light curtains
• Door interlocks
• Safety mats
• Floor markings
• Warning lights
Check all safety equipment frequently for proper operation. Repair or replace any
non-functioning safety equipment immediately.
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2.5

Installation Safety
Safe installation is essential for protection of people and equipment. The
following suggestions are intended to supplement, but not replace, existing federal,
local, and state laws and regulations. Additional safety measures for personnel and
equipment may be required depending on system installation, operation, and/or
location. Installation tips are as follows:
• Be sure that only qualified personnel familiar with national codes, local
codes, and ANSI/RIA R15.06 safety standards are permitted to install the
equipment.
• Identify the work envelope of each robot with floor markings, signs, and
barriers.
• Position all controllers outside the robot work envelope.
• Whenever possible, install safety fences to protect against unauthorized entry
into the work envelope.
• Eliminate areas where personnel might get trapped between a moving robot
and other equipment (pinch points).
• Provide sufficient room inside the workcell to permit safe teaching and
maintenance procedures.

2.6

Programming Safety
All operators, programmers, plant and tooling engineers, maintenance personnel,
supervisors, and anyone working near the robot must become familiar with the
operation of this equipment. All personnel involved with the operation of the
equipment must understand potential dangers of operation. Programming tips are
as follows:
• Any modifications of the controller PLC can cause severe personal injury or
death, as well as damage to the robot! Do not make any modifications to the
PLC. Making any changes without the written permission of Motoman will
VOID YOUR WARRANTY!
• Some operations require standard passwords and some require special
passwords. Special passwords are for Motoman use only. YOUR
WARRANTY WILL BE VOID if you use these special passwords.
• Back up all programs and jobs onto a floppy disk whenever program changes
are made. To avoid loss of information, programs, or jobs, a backup must
always be made before any service procedures are done and before any
changes are made to options, accessories, or equipment.
• The concurrent I/O (Input and Output) function allows the customer to
modify the internal ladder inputs and outputs for maximum robot
performance. Great care must be taken when making these modifications.
Double-check all modifications under every mode of robot operation to
ensure that you have not created hazards or dangerous situations that may
damage the robot or other parts of the system.
• Improper operation can result in personal injury and/or damage to the
equipment. Only trained personnel familiar with the operation, manuals,
electrical design, and equipment interconnections of this robot should be
permitted to operate the system.
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•
•

2.7

Inspect the robot and work envelope to be sure no potentially hazardous
conditions exist. Be sure the area is clean and free of water, oil, debris, etc.
Be sure that all safeguards are in place.
Check the E-STOP button on the teach pendant for proper operation before
programming.
Carry the teach pendant with you when you enter the workcell.
Be sure that only the person holding the teach pendant enters the workcell.
Test any new or modified program at low speed for at least one full cycle.

Operation Safety
All operators, programmers, plant and tooling engineers, maintenance personnel,
supervisors, and anyone working near the robot must become familiar with the
operation of this equipment. All personnel involved with the operation of the
equipment must understand potential dangers of operation. Operation tips are as
follows:
• Be sure that only trained personnel familiar with the operation of this robot,
the operator's manuals, the system equipment, and options and accessories
are permitted to operate this robot system.
• Check all safety equipment for proper operation. Repair or replace any nonfunctioning safety equipment immediately.
• Inspect the robot and work envelope to ensure no potentially hazardous
conditions exist. Be sure the area is clean and free of water, oil, debris, etc.
• Ensure that all safeguards are in place.
• Improper operation can result in personal injury and/or damage to the
equipment. Only trained personnel familiar with the operation, manuals,
electrical design, and equipment interconnections of this robot should be
permitted to operate the system.
• Do not enter the robot cell while it is in automatic operation. Programmers
must have the teach pendant when they enter the cell.
• The robot must be placed in Emergency Stop (E-STOP) mode whenever it is
not in use.
• This equipment has multiple sources of electrical supply. Electrical
interconnections are made between the controller, external servo box, and
other equipment. Disconnect and lockout/tagout all electrical circuits before
making any modifications or connections.
• All modifications made to the controller will change the way the robot
operates and can cause severe personal injury or death, as well as damage the
robot. This includes controller parameters, ladder, and I/O (Input and Output)
modifications. Check and test all changes at slow speed.

MOTOMAN

2-5

File Management System Manual

SAFETY

2.8

Maintenance Safety
All operators, programmers, plant and tooling engineers, maintenance personnel,
supervisors, and anyone working near the robot must become familiar with the
operation of this equipment. All personnel involved with the operation of the
equipment must understand potential dangers of operation. Maintenance tips are
as follows:
• Do not perform any maintenance procedures before reading and
understanding the proper procedures in the appropriate manual.
• Check all safety equipment for proper operation. Repair or replace any nonfunctioning safety equipment immediately.
• Improper operation can result in personal injury and/or damage to the
equipment. Only trained personnel familiar with the operation, manuals,
electrical design, and equipment interconnections of this robot should be
permitted to operate the system.
• Back up all your programs and jobs onto a floppy disk whenever program
changes are made. A backup must always be made before any servicing or
changes are made to options, accessories, or equipment to avoid loss of
information, programs, or jobs.
• Do not enter the robot cell while it is in automatic operation. Programmers
must have the teach pendant when they enter the cell.
• The robot must be placed in Emergency Stop (E-STOP) mode whenever it is
not in use.
• Be sure all safeguards are in place.
• Use proper replacement parts.
• This equipment has multiple sources of electrical supply. Electrical
interconnections are made between the controller, external servo box, and
other equipment. Disconnect and lockout/tagout all electrical circuits before
making any modifications or connections.
• All modifications made to the controller will change the way the robot
operates and can cause severe personal injury or death, as well as damage the
robot. This includes controller parameters, ladder, and I/O (Input and
Output) modifications. Check and test all changes at slow speed.
• Improper connections can damage the robot. All connections must be made
within the standard voltage and current ratings of the robot I/O (Inputs and
Outputs).
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Chapter One - Overview
Overview
Welcome to the File Management System application manual. This guide will help you become familiar with
the usage of the File Management System and provide you with all the information you will need to use this
application with no difficulty.
File Management System (also called FMS) is an application that is designed to supply advanced file
management and version control. It provides several higher-level functions such as ensuring data and
program integrity, along with tracking program "check-ins" and "check-outs" by user and time.
Version control prevents loss of information or loss of entire files. It is a structured way to track and store
changes made to a file. When a user chooses to make modifications, the user is supplied with a copy of the
file. The application then saves the modified file as a new version. This process of file storage is constant
and consistent. It provides space efficiency by only storing the modifications made to the original file. It
provides a very reliable means of data backup and ensures data integrity. But most of all, it provides a forum
for files to be shared between multiple users.
The first section of this manual will give you some general information about the File Management System
application.
The second section will help you get started with the application. This includes:




System requirements
Installation process
Starting the File Management System application

The third section will discuss specific details regarding the usage of the FMS application. This leads into the
fourth section, which will discuss specific details regarding the usage of the FMS Connector application.
Finally, the fifth section will discuss specific details regarding the usage of the FMS Admin application. At the
back of this manual, you will find a glossary of terms used throughout the documentation and application.
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Introduction
FMS is a client application designed to work with any type of Programmable Device Server software. FMS
has been designed to greatly improve source code control & management for manufacturers, and to function
within the i OpenFactory line of products from Radix Controls.
The concept of open architecture software for manufacturing devices, & device independent communication,
are the building blocks of i OpenFactory. The low level connections to device controllers that are enabled by
their respective server applications, are the cornerstone of open architecture systems for industrial devices, &,
further, for manufacturing systems. Seamless access to operating information, the ability to upload and
download programs over a plant network and program version control are functionalities that are made
possible by the connections established by the application on the server.

i OpenFactory incorporates a cost effective, small profile and durable embedded computer with software tools
for device connectivity & web access. The basic building blocks of i OpenFactory are:
i OpenDevice small profile & robust embedded computer
i OpenWeb web services
Software tools for device connectivity, & other value-added functionalities
The embedded computer & associated device communication software, or i OpenDevice, utilize Microsoft
Windows CE 3.0 as the operating system.
An example of a typical client/server/robot controller configuration is shown on the following page:
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iOpenFactory Server
i Open Factory Clients

Rockwell RSViews
Application using OPC
interface to
iOpenDevice API

Custom VB Application
using FMS API

Maintenance PC
using FMS

Supervisor PC
using FMS

Ethernet

Bay Networks

3 C om

Robot
Controller

PLC's

3 C om

iOpenDevice
iOpenDevice

3 C om

3Co m

PLC's
Robot
Controller

3Co m

For more information on the i OpenFactory software line, please visit our web site at
http://www.iOpenThinker.com or call 1-877-467-2349 to order a free trial version of any of our software
products.
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Chapter Two - Getting Started
System Requirements
File Management System has been designed to provide source code control & program management
capabilities. It has been specifically designed for Microsoft’s Windows family of operating systems. The
hardware & operating software requirements are standard for it’s class of applications.
The basic system requirements for File Management System are:
• Pentium based computer
• Minimum graphical resolution of 800 x 600
• 64MB RAM (the minimum requirement for a single robot connect; may increase depending on the
number of connections created)
• Network Card (for Ethernet connection to robot controller)
• Windows 98*, Windows NT 4.0 Service pack 6 or Windows 2000
• Microsoft Visual Source Safe 6.0
* Only for ABB Support

Installation
The File Management System application's installation files are located on the CD. You will need to be
running one of the operating system indicated in the System Requirements section in order to successfully
install the application.
Insert the CD ROM into the appropriate drive on the computer. The installation procedure should begin
automatically. If the installation does not start automatically, please select Start and then Run. Click on the
Browse button and locate the SETUP.EXE file. Double-click on SETUP.EXE. The installation procedure
should start. Please follow the instructions provided.
The installation sequence will proceed as described in the next section.

Installation Sequence
Once the installation has been successfully completed, the application will be added to your Start menu under
the Programs tab with the heading iOpen Factory File Management System. You now have all the files
necessary to run the File Management System application and can proceed to start your application.

File Management System Manual

Page 9

MOTOMAN

Starting the File Management System Application
There is a very simple process to begin using File Management System:
•
•
•
•
•

Click the Start button on the Windows desktop
Move up to iOpen Factory
Move over to File Management System
Once you've selected the application from the menu, the application's login dialog box for File
Management System will open
Enter your User Name and Password and Click OK to open the main application dialog box
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Chapter Three - Using FMS

FMS Overview
The next few sections will expose you to the actual usage of the FMS application. You will be supplied with
all the necessary information required to use this application with no difficulty. You will be provided with
details on topics such as:





Description of the layout of the FMS main application window
Graphical representations used in the application
Complete functionality to using Groups, Devices, Products and File Management
Complete functionality to creating Batches and Tasks

Each of these will be discussed in more detail.
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Description of FMS Main Application Window
When your application starts, the FMS main application window will open. The user interface of the
application has been designed using general guidelines for user interface layout in the Windows environment.
For example, selecting the X will close your application, and holding down the ALT key at the same time as
the letter underlined in the menu items will open the menu.
The main application window is divided into five frames. The left-hand side frame, labeled number one in the
example shown below, contains your tree view, showing the hierarchy of the products, folders and devices.
The plus sign next to the folder or device means there are more folders that are not displayed. To expand
the tree, you can click on the plus sign to view the folders not shown. The minus sign indicates that the
tree is completely expanded and all the folders are displayed. To collapse the tree, you can click on the
minus sign to shrink the tree view down.
The right-hand side frame, labeled number two in example shown below, lists all the files stored in a given
folder along with the date and time (of the last modification), user (name of the user who has the file checked
out) and location information (which directory the file is currently being used). If you want to refresh the file
listing, select Refresh from the View menu. You can also use the Select All option in the View menu to
select all the files displayed (i.e. if you would like to check out all the files displayed).

The frame just below, labeled number three, displays the Event Log. It displays all events that occur for all
users of the FMS application, even if they are on different machines. It will also display all events that occur
in the FMS Connector or that are scheduled in the FMS Scheduler. The events can be filtered by User name,
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or by selecting a starting and ending date. If you wish to hide the filter bar, simply right-click on the Event Log
bar and select the menu item that appears to Hide Filter Bar, or select Event Log from the Tools menu and
then select Hide Filter Bar. To add the Filter Bar, simply right-click in the Event Log frame, and select the
item that appears to Show Filter Bar, or select Event Log from the Tools menu and then select Show Filter
Bar.
The frame labeled number four, displays the FMS Scheduler. It displays every Batch and Task that has
been created, along with the details and location of the files, devices and actions performed for each. The
plus sign is available on the left-hand side of the Batch name, to indicate that there are Tasks that are not
displayed. To expand the view to show all the Tasks in a particular Batch, click on the plus sign . The
minus sign indicates that there are no Tasks under the selected Batch, or that it is completely expanded
and all the Tasks are displayed. To collapse the view to show only the Batch information, you can click on the
minus sign .
The bottom frame, labeled number five, displays your status messages, which will show the actions being
performed and if it was successful, or not. This is also where any error messages will appear. Underneath
this frame, at the bottom of the dialog box, displays the Status bar. From left to right, it will show the current
location of the user, the Working Folder if one has been selected, the current date and current time. To clear
the entries, select Clear Status Window from the View menu.

NOTE: To refresh the file listing and tree view in main application window, select Refresh All from the View
menu.
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The View menu provides the user with the option to display or remove items from the main application
window. Each item is described below:
- Toolbar – displays the row of icons underneath the menu items. By default, this will be displayed,
unless you choose to remove it.
- Status bar – displays the message area along the bottom of the dialog box. It displays the users
current location, the selected Working Folder, and the current date and time. By default, this will be
displayed, unless you choose to remove it.
- Status window – displays the status messages of the application. By default, this will be displayed,
unless you choose to remove it.
- Event Log – displays event messages for all users of the application
- Scheduler – displays the Scheduler information on the Tasks and Batches
To add or remove an item from the main application window, simply select it from the View menu.

FMS Icons
FMS follows a distinct format of organizing the folders, devices and files. The application also uses a variety
of graphical representations to show the differences between the folders and devices. Using the diagram
below, you will learn about the guidelines FMS follows to enforce consistency throughout the entire
application, and understand the graphical representations used to represent each component. Once you
learn the structure FMS uses, the application will become very easy to use.

First, we start with the Root
This graphic is used to indicate the top or beginning of your tree view. The Root is supplied automatically and
can never be removed.

From the Root, you can either create a Group or a Device.
A Group is a folder used to organize multiple Devices and their corresponding files. It is similar to a directory
that you use mainly to keep together related Devices. For example, a Group could be defined for multiple
Devices working in the same area of the plant. The two graphics below are used to represent a Group. The
open folder indicates that the Group is currently selected.
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From a Group, you create another Group or a Device.
A Device represents a robot controller or another type of industrial device. A connection to the controller is
needed so the files are kept organized and stored in relation to its corresponding Device. An example of a
graphic representing a Device or robot controller is shown below.

From a Device, you create Products.
Each Device uses several individual files. To keep these files organized, Products are used to logically group
them in any way that is meaningful to the user. For example, if the Device is used for several products, you
can create a folder for each individual product. When a Product is created, the application will automatically
add all the necessary subfolders for you. The graphic used to represent a Product is shown below.

From a Product, your subfolders are created.
The following six graphics represents subfolders. Subfolders contain your files and store them by their type or
file extension. This will be explained in more detail in the File Management section of this chapter. The open
folder indicates that the subfolder is currently selected.

The red folder is used to represent the Master subfolders. These subfolders contain Master files which are
the only files that can be sent to a Device.

The yellow folder is used to represent the Support subfolder. The Support subfolder is setup to store any files
that are not directly related to the configuration or operation of the Device. This folder is also used to store file
types that fall outside of classification. For more information on the classification, refer to the FMS Admin
section.

A subfolder will store your files
This graphic is used to represent a file. This applies to any type of file regardless of their extension.

The graphic shown below represents a file that was made into a Master file. For more information, please
refer to the Make Masters File section of this manual.

This graphic is used to represent a “checked out” file, or a file that is currently being altered by a user of the
application. For more information, please refer to the Check Out File(s) section of this manual.

File Management System Manual

Page 15

MOTOMAN

In this example, a Group called "Group1", two Devices called "Robot1" and "Robot2" and a Product called
"Product1" along with all the subfolders, were created to form this tree view example.

Changing FMS Application Settings
The Options selection from the Tools menu will open the Options dialog box, which contains three tabs:
General, Programs, and Email.
The General tab contains the path to the SrcSafe.ini file, and the SQL Database Server. If you are unsure
of the locations, a Browse button is available to allow you to search for the proper location.

The Programs tab contains the applications you wish to use to edit, view, or print files.
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The Email tab contains the Mail Server, Server Port, and Email Address of the account to be used to send
the mail. Email will be sent when a file received from the device is different than the file stored in the FMS
database to the email addresses specified for this device. A Username and Password may also need to be
supplied if required by the SMTP server.

Enter the information required, and click OK to store the modifications and exit the Options dialog box. Click
Cancel to exit the operation.
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Groups
To keep your Devices and their corresponding files organized, you can use Group folders. Groups can be
defined in any way meaningful to the user(s). A Group is a folder, similar to a directory that you use mainly to
keep together related Devices. For example, a Group could be defined for multiple Devices working in the
same area of the plant. You have complete control to add, delete, or rename the Group with no difficulty.

In the example above, a Group called "Group1" was created.

Add a Group
There are a few different ways to create a new Group.




Click the Root directory
On the File menu, click Add
Click Group



Right-click on the Root, and click Add Group



Click the Root



Click on Add Group icon in toolbar

OR
OR

File Management System Manual

Page 18

MOTOMAN

The Add New Group dialog box will open.



Enter the name of the new Group in space provided, and click OK.
Clicking Cancel will exit the operation

Delete Group
It is a very quick and simple process to remove a Group from your application. A few clicks of your mouse,
and the icon representing that Group on the tree view will disappear.
WARNING: Once you delete a Group, the Group and all its contents will be removed.



Click the Group from the tree view
On the File menu, click Delete



Right-click on the Group, and click Delete



Click the Group



Click on Delete icon in toolbar

OR
OR

The system will display a message box verifying the removal of the Group. The message box gives the
user the option to delete an item permanently. Simply click the Destroy permanently checkbox.
WARNING: Once you select the Destroy permanently option and click OK, there is no reversal for the
deletion process and all traces of the Group and its contents are destroyed.



If the proper Group is selected and should be removed, click OK
Clicking Cancel will exit the operation
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Rename Group
At some point in time, you may need to change the name of an existing Group.



Click the Group from the tree view
On the File menu, click Rename



Right-click on the Group, and click Rename

OR

The Rename Group dialog box will open



Enter the new name for the Group in space provided, and click OK.
Clicking Cancel will exit the operation
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Devices
A Device represents a robot controller or another type of industrial device. A connection to the controller is
needed so the files are kept organized and stored in relation to its corresponding Device.
NOTE: Only files from the Masters folder can be sent to the device. For more information about Master files,
refer to the File Management section.
FMS gives you the freedom to perform various operations relating to a given industrial Device. These
include:





Adding, deleting, or renaming your Devices
Editing the connection properties
Viewing the current status of the Device
Moving or removing files on the Device

In the example above, a Device called "Robot1” representing a Motoman XRC robot controller was created.
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Add Device
There are a few different ways to create a new Device.




Click either the Root or a Group to which you want to add a Device
On the File menu, click Add
Click Device



Right-click on the Root or Group, and click Add Device



Click either the Root or a Group



Click on Add Device icon

OR
OR

The Add New Device dialog box will open.



Enter the name of the new Device in space provided, and click OK.
Clicking Cancel will exit the operation
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A second dialog box will open with your new Device name, requesting connection properties to be
entered.
 Select a Device Type from the list provided
 Enter the Connect String. For DCOM servers, specify the remote machine. Press the Browse
button to search through a listing of all the available machines. For FTP or HTTP, specify the server
path.
 When the Device Name is selected, the FMS application connects to the server to retrieve a list of
devices, which will be displayed in the combo box. Make a selection from the devices available. If
you press Refresh, this will also connect to the server to update the list
 When using FTP, you will be prompted to enter the Username and Password of the person logging
into the FTP server.
 Enter the email address(es) of who should be notified by email when modifications to any file occurs.
The email message will contain the comment that was added to the file. Separate each address
using a semicolon or comma.
 The Decompiler Configuration will automatically be entered with default information. This
information should be modified to reflect the current device’s settings. (NOTE: This applies only for
devices that use a decompiler.)




Click OK when finished
Clicking Cancel will exit the operation

File Management System Manual

Page 23

MOTOMAN

Delete Device
It is a very quick and simple to remove a Device from your application. A few clicks of your mouse, and the
icon representing that Device on the tree view will disappear.
WARNING: Once you delete a Device, the Device and all its contents will be removed.



Click the Device from the tree view.
On the File menu, click Delete



Right-click on the Device, and click Delete



Click the Device



Click on Delete icon in the toolbar

OR
OR

The system will display a message box verifying the removal of the Device. The message box gives the
user the option to delete an item permanently. Simply click the Destroy permanently checkbox.
WARNING: Once you select the Destroy permanently option and click OK, there is no reversal for the
deletion process and all traces of the Device and its contents are destroyed.



If the proper Device is selected and should be removed, click OK
Clicking Cancel will exit the operation
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Rename Device
You may need to change the name of an existing Device.



Click the Device from the tree view.
From File menu, click Rename



Right-click on the Device, and click Rename

OR

The Rename Device dialog box will open.



Enter the new name for the Device in space provided, and click OK.
Clicking Cancel will exit the operation

Device Properties
You may be required to edit the Device Properties to make changes to the connection settings.



Click the Device from the tree view
From View menu, click Properties



Right-click on the Device, and click Properties

OR
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The Properties dialog box will open.





The settings that are currently stored will be shown
Alter the Connect String, Device Name, Username, Password, Email and Decompiler
Configuration as necessary. Use the Browse button to search through a listing of all the available
machines (see the Add Device section for more information about these settings.)
Once completed, click OK.
Click Cancel to exit the operation
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View Device Status
If your application is supporting multiple Devices, you may want to retrieve the status information for one
particular Device.



Click the Device from the tree view
From View menu, click Status \ Files



Right-click on the Device, and click Status \ Files

OR

The Status dialog box will open. It will show all the attributes for the Device selected so you can view
what is operational.
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List Files on Device
You can view a listing of all the files on a particular Device.



Click the Device from the tree view
From View menu, click Status \ Files



Right-click on the Device, and click Status \ Files

OR

The Status dialog box will open.



Click on Files tab, and all files for that Device will be displayed in the dialog box
Click OK when finished
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Delete File(s) From Device
If you have files on a Device you are no longer using, you are able to remove them very easily.



Click the Device from the tree view
From View menu, click Status \ Files



Right-click on the Device, and click Status \ Files

OR

The Status dialog box will open.


Click on Files tab

NOTE: Make sure to check if the device you are using needs to be in stand-by mode before deletions
can be made. Some devices cannot be operational while removing files.



Click files you wish to delete and click on the Delete From Robot button
Click OK when finished
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Transfer From Device
You are able to transfer files from a particular Device. A listing of files for the chosen Device will open in a
dialog box. Simply select a Product folder to receive the files from the Device.
NOTE: When transferring files, your files will be separated into the different subfolders by their file types. For
more information on the file specifications, refer to Add Files and Import Files sections.



Click the Product
From Transfer menu, click From Device



Right-click on Product, and click From Device



Click the Product



Click the Transfer From Device icon in the toolbar

OR
OR

The Status dialog box will open.


Click on Files tab

NOTE: Make sure to check if the device you are using needs to be in stand-by mode before transfers
can be made. Some devices cannot be operational while transferring files.




Click the file(s)
Click Request From Robot
Click OK when finished
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If you click the Advanced button of the Files tab of the Status dialog, you can request files that may not be
shown in the dialog box listing, if you know the specific filename. Just type the filename and click OK, and it
will transfer the file to the proper subfolder under the Product you had selected before the procedure began.
Clicking Cancel will exit the operation.

FTP Devices
For FTP Devices, a different dialog box will open when Transfer From Device is selected.



Click the Product
From Transfer menu, click From Device



Right-click on Product, and click From Device



Click the Product



Click the Transfer From Device icon in the toolbar

OR
OR
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The FTP Device - Receive dialog box will open.




Click the file(s)
Click Get File
Click OK when finished

Transfer To Device
You may want to send a file to a Device. When transferring files to a Device, you are only allowed to transfer
files from the Masters subfolder.
To convert your file to a Master file, refer to Make Master Files section of this manual.
NOTE: Make sure to check if the device you are using needs to be in stand-by mode before transfers can be
made. Some devices cannot be operational while transferring files.



Click the file
On the Transfer menu, click To Device



Right-click on the file, and click To Device



Click the file



Click the Transfer To Device icon in the toolbar

OR
OR

This will get the latest version of the file in the Masters folder and send it to the robot

FTP Devices
For FTP Devices, a different dialog box will open when Transfer To Device is selected. When transferring
files to a Device, you are only allowed to transfer files from the Masters subfolder.
To convert your file to a Master file, refer to Make Master Files section of this manual.



Click the file
On the Transfer menu, click To Device



Right-click on the file, and click To Device



Click the file



Click the Transfer To Device icon in the toolbar

OR
OR
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This will display the FTP Device Send dialog box to select the FTP path to send the file. Use the Browse
button to locate the desired FTP folder and click OK. This will get the latest version of the file in the Masters
folder and send it to the robot.
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Products
Each Device uses several individual files. To keep these files organized, Products are used to logically
arrange them in any way that is meaningful to the user. For example, if the Device is working on several
projects, you can create a Products folder for each individual project. When a Product is created, FMS gives
you complete control to add, delete, and rename Products with complete ease.

In the example above, a Product called "Product1" was created.

Add Products
When adding a new Product, the application will automatically create subfolders to separate your individual
files by their type.




Click the Device from the tree view
On the File menu, click Add
Click Product



Right-click on the Device, click Add Product



Click the Device



Click on the Add Product icon

OR
OR
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The Add New Product dialog box will open.



Enter the name of the new Product in space provided, and click OK. Your newly created Product will
appear in the tree view.
Clicking Cancel will exit the operation

Delete Product
It is very quick and simple process to remove a Product from your application. A few clicks of your mouse
and the icon representing that Product on the tree view will disappear.
WARNING: Once you delete a Product, the Product and all its contents will be removed.



Click the Product from the tree view.
On the File menu, click Delete



Right-click on the Product, click Delete



Click the Product



Click on the Delete icon

OR
OR

The system will display a message box verifying the removal of the Product. The message box gives the
user the option to delete an item permanently. Simply click the Destroy permanently checkbox.
WARNING: Once you've selected the Destroy permanently option and click OK, there is no reversal for
the deletion process and all traces of the Product and its contents are destroyed.



If the proper Product is selected and should be removed, click OK
Clicking Cancel will exit the operation
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Rename Product
You may need to change the name of an existing Product.



Click the Product from the tree view
On the File menu, click Rename



Right-click on the Product, click Rename

OR

The Rename Product dialog box will open.



Enter the new name for the Product in space provided, and click OK.
Clicking Cancel will exit the operation
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File Management
File Management is the center to the functionality of this application. FMS provides a very structured way to
arrange and control the files it stores by using version tracking.
Version tracking is a method of following and recording a file's development. Each time modifications are
made to the file, a new version of the file is created. However, when FMS creates a new version, it only
stores the changes made from the previous version, not the whole file.
FMS controls the "checking in" and "checking out" of files. This procedure resembles the process of taking
out a book from the library, and returning it when you are finished with the book. To edit a file that is stored in
FMS, you must "check out" the file, meaning move it out of FMS into a Working Folder. This provides you
with a copy of the file, and places it in the Working Folder (the selected directory) chosen by the user. This
prevents other users from attempting to edit the file at the same time. The user is supplied with only a copy of
a file to prevent deletion of information or the file itself.
Once all modifications to the file are completed, you are ready to "check in" the file. This allows for a new
version to be created and the modifications to be logged. During this process, FMS also allows the user to
add comments so other users can view the comments about the adjustments made for reference at a later
time. This monitoring of files is beneficial when there are so many users sharing access to the same files.
The structure of the subfolders for file storage is very simple. Files are stored and separated by their file
types (their extensions or complete filename). There is a subfolder named "Masters". This subfolder stores
files that have been made into Master files. Master files are the only type of files that can be sent to Devices.
This structure will keep the format consistent and file searching to a minimum. This restriction will be
explained in more detail in the Add Files and Import Files sections.
FMS allows you to perform various tasks dealing with individual files, which will be discussed in more detail in
this section. The topics will include the following:











Adding, importing, deleting and renaming files
Viewing and printing individual files
Checking In and out files
Undo checked out files
Obtaining latest version of file
Listing all checked out files
Making Master files
Viewing comments on a file
Viewing or Comparing versions of a file
Setting a Working Folder
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Add File(s)
When adding files to a subfolder, all your files will be separated by their file types (determined by their
extensions or complete filename). Each subfolder has a specific file type that it allows to be added. Each
device can be configured to accept certain extensions or filenames for an individual folder through the FMS
Admin application. For more information, refer to Chapter six – Using FMS Admin.




Click the Subfolder to which you want to add files
From File menu, click Add
Click File



Right-click on the Subfolder, and click Add File



Click the Subfolder



Click the Add File icon

OR
OR

A dialog box will open that will allow you to browse for a file. You will only be allowed to search for files of
a specific type. The type will depend on the subfolder that was chosen.



Click Open when file is selected, and the file will be added to the subfolder
Clicking Cancel will exit the operation
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Import File(s)
You may want to import files for a Product. When importing files you can add files of any type, and the files
will automatically be placed in the appropriate subfolder for the selected Product. However, each device can
be configured to accept certain extensions for an individual folder through the FMS Admin application. For
more information, refer to Chapter six – Using FMS Admin.



Click the Product into which you want to import files
From File menu, click Import



Right-click on the Product, and click Import Files

OR

A dialog box will open that will allow you to browse for the file.




Click Open when file is selected
The new file will be added to the appropriate subfolder according to its extension or complete
filename
Clicking Cancel will exit the operation
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Delete File(s)
It is a very simple process to delete a file.
NOTE: As long as you don't check off the Destroy permanently checkbox in the Delete dialog box, the file
can be recovered when you create a new file with the same name. The application will recover the previously
deleted file and all its versions. The new file created will become the most recent version.



Click the file you wish to remove.
On the File menu, click Delete



Right-click on the file, and click Delete



Click the file



Click on Delete icon in the Toolbar

OR
OR

The system will display a message box verifying removal of the file. The message box gives the user the
option to delete an item permanently. Simply click the Destroy permanently checkbox.
WARNING: Once you've selected the Destroy permanently option and click OK, there is no reversal for
the deletion process and all traces of the file are destroyed.



If proper file is selected and should be removed, click OK
Clicking Cancel will exit the operation
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Rename File
You may need to change the name of an existing file.



Click the file which name you wish to change
On the File menu, click Rename



Right-click on the file, and click Rename

OR

The Rename File dialog box will open.



Enter the new name for the file in space provided, and click OK.
Clicking Cancel will exit the operation

View File
Viewing file contents can be done a few different ways. This is one of the few operations that does not
require a Working Folder, and can be done without checking out a file. However, since this provides you with
a read-only copy of the file, you are unable to perform any modifications.
NOTE: If you have checked out the file before you select the View File option, the file will be editable.



Click the file you wish to view
On the View menu, click File



Right-click on the file, and click View File



Double-click on File



Click the file



Click on View File icon

OR
OR
OR
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OR


With the Versions dialog box open as shown below, right-click on version, and click View Version



With the Checkouts dialog box open as shown below, right-click on file, and click View File

OR

Print File(s)
If you require a printed copy of a file, start by selecting the file you want to print.



Click the file you wish to print
From File menu, click Print



Right-click on the file, and click Print

OR
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Check Out File(s)
To edit the contents of a file, you need to check the file out. The application supplies you with a copy of the
latest version of the file and places it in the Working Folder you've specified. The copy supplied in your
Working Folder is marked as a read and write file for the user to make modifications. Other users will only be
able to view the latest version of the file. Any changes made to the file after it was checked out will not be
reflected until the file is checked back in.
NOTE: The application will automatically put the file in the Set Working Folder you have specified. If you
haven't specified a directory, it will give you the opportunity to choose one.



Click the file
From Change Control, click Check Out



Right-click on the file, and click Check Out



Click the file



Click Check Out icon

OR
OR

The file you've checked-out will appear as file "AAA1.JBI" above, with a red checkmark in the middle and
red outline on the document icon.
It will display the date, time, which user has the file checked out and the location of the file.

Check In File(s)
Files that are currently stored in FMS are read only versions of the file and can only be viewed. In order to
make changes to a file, you have to check out the file. Once you've completed the modifications, you are
ready to check in the file to FMS so the file is accessible for other users.
When checking in files, FMS records the changes made, creates a new version of the document.



Click the file
From Change Control, click Check In



Right-click on the file, and click Check In



Click the file



Click the Check In icon on the toolbar

OR
OR
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OR


With the Checkouts dialog box open as shown below, you can right-click on file and click Check In
File

File Management System Manual

Page 44

MOTOMAN

Undo Check Out File(s)
If you realized that you checked out a file and did not need to check it out or, you made changes you do not
wish to keep, you can undo your check out of the file. This simply reverses the check out, marks the copy as
read only and puts the file back without recording any changes.
WARNING: If a user makes changes to a file, and uses the Undo Check Out, you will lose all the changes
you have made to the file. If you want to record the changes you made, you should use Check In.



Click the file
From Change Control, click Undo Check Out



Right-click on the file, and click Undo Check Out



Click the file



Click the Undo Check Out icon on the toolbar



From the Checkouts dialog box, right-click on the file and click Undo Check Out as shown below

OR
OR

OR
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Get Latest Version
Users can retrieve the most recently checked in version of a file that will contain the most recent changes.
Select the file and follow the simple instructions below.
NOTE: This option retrieves the latest version of the selected file as read-only. You will have to check out
the file to make modifications



Click the file
From Change Control, click Get Latest Version



Right-click on file, and click Get Latest Version



Click the file



Click on Get Latest Version icon in the toolbar

OR
OR
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List Check-Outs
If a file you need is checked out, you may want to view a listing of all the checked out files to find out which
user is currently using the file you want.



Select the location in which the search will begin from the tree view
From View menu, click Checked Out Files

You can either click Current User to view files you have checked out or All Users to view all the files
checked out by any user.
By default, "Start at Current Folder" is checked off. This setting will locate the files checked out starting from
the folder you are currently using, including any subfolders.
By default, "Show progress box" will be checked off. This setting will display a progress bar that advances as
the application is locating the checked out files. An example is shown below.

If you wish to disable either of these settings, simply click the setting you wish to change and the check mark
should be removed.
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A dialog box will then open with all the checked out files listed for you.
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Make Masters File
You may want to convert a file to a Master file. When a file becomes a Master, the file is stored in the red
"Masters" subfolders and makes the file available to send to a Device.



Click the file you wish to make a Master
From Change Control, click Make Master



Right-click on the file, and click Make Master



Click the file



Click on Make Master icon in the toolbar



From the Versions dialog box, right-click on version of file, and click Make Master

OR
OR

OR
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View Comment
When checking in files, users have the opportunity to add comments. You may want to document the
changes that were made to the file. Users can view comments that were added to a file very easily.



Click the file for which you wish to view comments
From Change Control, click View Comment



Right-click on the file, and click View Comment



Click the file



Click on the View Comment icon in the toolbar



From the Versions dialog box, click the version, right-click on the version and click View Comment

OR
OR

OR

The Comment dialog box will open and show the comment that was entered for the file chosen
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View Versions
Each time a file is checked out and modifications have been made to a particular file, the application makes a
new version. By selecting the file, you can view a listing of all the versions for that file.



Click the file
From Change Control, click View Versions



Right-click on the file, and click View Versions



Click the file



Click on the View Versions icon in the toolbar

OR
OR

The Versions dialog box will open and display the version numbers, the date and time the version was
created and, the User Name of the person that made the modifications and the comments that were added.

Compare Versions
When viewing a document it may not be obvious the changes that were made to a file. The changes may not
have been documented leaving the user unsure of the modifications. If you would like to find the differences
between two versions of the same file, you are able to compare the differences. The first step is to open the
Versions dialog box.



Click the file
From Change Control, click View Versions



Right-click on the file, and click View Versions



Click the file



Click on the View Versions icon in the toolbar

OR
OR
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The Versions dialog box will open.





Click one version of the file you wish to compare
While depressing the CTRL key, click the other version you wish to compare
Both of the versions should now be selected as shown in the example above
Right click, and click Show Differences

NOTE: The Show Differences feature will only be enabled if two files are selected. If only one or more than
two files are selected, this option will be disabled.

A dialog box will open split in two, with each version on one side. Along the bottom of the dialog box in the
status bar, displays the colors used to represent the differences and their meaning.
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Set Working Folder
The Working Folder is the specified folder or directory on a user's computer used to store files when they are
checked out or to retrieve the latest version. This folder is also chosen so the application knows the locations
of the files after modifications have been made and you are ready to check them in. When the Working
Folder is chosen, the application will create a set of subfolders in that directory, similar to the application
subfolders, to use with each type of file. The Working Folder is remembered by the application as the default
directory and will be used unless a different directory is selected.
NOTE: A Working Folder can be set or changed at any time


From File menu, click Set Working Folder



Right-click anywhere in the tree view, and click Set Working Folder



Click the Set Working Folder icon

OR
OR

A dialog box will open allowing you to browse for the directory to choose your Working Folder.



Click the location, and click OK
Clicking Cancel will exit the operation
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Scheduler
The Scheduler is used to schedule tasks to be executed at a scheduled time. When creating a new Batch or
Task, a Scheduled Wizard will open to help guide you through the creation process. The Tools menu
contains the Scheduler functionality, which consists of the Refresh option, which will update the Scheduler
information.
NOTE: All events that occur in the Scheduler will appear in the Event Log portion of the FMS main
application window

Batch
A Batch is mainly a set of Tasks. When a Batch executes, all the Tasks contained in that particular Batch will
be performed. If you right-click on a Batch, a menu will open allowing you to perform a variety of actions,
such as adding, editing and deleting Batches. All the same actions are also available in the Tools menu.

Create New Batch

To create a new Batch, from the Tools menu, select Scheduler, and then Add Batch. Or, you can right-click
on an existing Batch and select Create New Batch from the menu. The Scheduled Batch Wizard will then
launch to help you create the new Batch.
When the Scheduled Batch Wizard begins, it gives a brief description about the wizard, Batches, and Tasks.
Click the Next button to continue. Click the Cancel button to exit the operation.
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The wizard will continue by asking you to enter a name for the Batch, and selecting a time interval
determining how often the Task will be performed. Choose from Hourly, Daily, Weekly, Monthly, or
performing the Task One time only. Click the Back button to return to the previous dialog box. Click the
Next button to continue. Click the Cancel button to exit the operation.
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Hourly
If you selected Hourly as your time interval, you will be asked to select the time interval for the Batch to
execute. Use the arrows provided next to the text entry area to scroll up or down to select a value.

Once you have finished, a dialog box will display a summary of the information that you entered. Click the
Back button to return to the previous dialog box. Click Finish to add the newly created Batch. Click Cancel
to exit the operation.
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Daily
If you selected Daily as your time interval, you will be asked to select the start time for the Batch to execute,
and the start date the Batch will begin its schedule. Use the arrows provided next to the text entry area to
scroll up or down to select a time and date.

An example of the calendar that will appear to select the date is shown below. Use the arrows in the top lefthand or right-hand sides to select a different month if necessary.
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The next dialog box will prompt you to select how often you would like the Batch to perform. Make a selection
between Everyday, Weekdays only, or Every. If Every is selected, a number must be entered to specify
how many days it will be until the Batch will execute again. Click the Next button to continue. Click Back to
return to the previous dialog box. Click Cancel to exit the operation.

Once you have finished, a dialog box will display a summary of the information that you entered. Click the
Back button to return to the previous dialog box. Click Finish to add the newly created Batch. Click Cancel
to exit the operation.
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Monthly
If you selected Monthly as your time interval, you will be asked to select the start time for the Batch to
execute, and the start date the Batch will begin its schedule. Use the arrows provided next to the text entry
area to scroll up or down to select a time and date.

An example of the calendar that will appear to select the date is shown below. Use the arrows in the top lefthand or right-hand sides to select a different month if necessary.
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The next dialog box will prompt you to select how often you would like the Batch to perform. Make a selection
between a numeric day of the month, or select a specific day of the week. Click the Next button to continue.
Click the Back button to return to the previous dialog box. Click the Cancel button to exit the operation.

Once you are finished, a dialog box will display a summary of the information that you entered. Click the
Back button to return to the previous dialog box. Click the Finish button to add the newly created Batch.
Click the Cancel button to exit the operation.
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Weekly
If you selected Weekly as your time interval, you will be asked to select the start time for the Batch to
execute, and the start date the Batch will begin its schedule. Use the arrows provided next to the text entry
area to scroll up or down to select a time and date.

An example of the calendar that will appear to select the date is shown below. Use the arrows in the top lefthand or right-hand sides to select a different month if necessary.
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The next dialog box will prompt you to select how often you would like the Batch to perform. Select the
weekly time interval, and which day or days of the week. Click the Next button to continue. Click Back to
return to the previous dialog box. Click the Cancel button to exit the operation.

Once you are finished, a dialog box will display a summary of the information that you entered. Click the
Back button to return to the previous dialog box. Click the Finish button to add the newly created Batch.
Click the Cancel button to exit the operation.
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One Time Only
If you selected One Time Only as your time interval, you will be asked to select the start time of the Batch
and the date that it will begin. Click the Back button to return to the previous dialog box. Click the Next
button to continue. Click the Cancel button to exit the operation.

Once you are finished, a dialog box will display a summary of the information that you entered. Click the
Back button to return to the previous dialog box. Click the Finish button to add the new Batch. Click the
Cancel button to exit the operation.
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Edit Batch
At some point, you may need to alter the information for a Batch. To do this, simply right-click on the Batch
you wish to modify and select Edit Batch. Or, with the Batch highlighted, from the Tools menu, select
Scheduler, and then Edit Batch. You can also click twice on the Batch you want to modify. This will also
open it for editing. The same dialog boxes that were seen when the Batch was created will open. Simply
alter the information you want to modify from each dialog box, and click the Next button to precede, until you
reach the end of the process.

Delete Batch
To remove a Batch, begin by selecting the Batch from the listing. From the Tools menu, select Scheduler,
and then Delete Batch. You can also right-click and select Delete Batch from the menu. A dialog box will
to close the dialog box and
open confirming the removal of the Batch. Click OK to continue. Click the
cancel the operation.
NOTE: When a batch is removed, all tasks residing in the selected batch will also be removed.

Execute Batch Now
A batch can be set to execute before its scheduled time by right-clicking on the batch and selecting Execute
Batch Now from the menu.

File Management System Manual

Page 64

MOTOMAN

Task
A Task is created to perform a specific individual operation. Tasks can be created to:
Backup – Backup single or multiple files
Compare – Compare single or multiple files to the latest copy in FMS application, and generates a report with
the files that were compared and their differences
Compare and Backup – Combination of backup and compare operations
Changeover – Backup single or multiple files, and uploads new files to the Device selected

If you right-click on a Task, a menu will open allowing you to perform a variety of actions, such as creating,
editing and deleting Tasks.

Create New Task
To create a new Task, from the Tools menu, select Scheduler, and then Add Task. Or, you can right-click
on an existing Task and select Create New Task from the menu. The Scheduled Task Wizard will then
launch to help you create the new Task.
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When the Scheduled Task Wizard begins, it gives a brief description about the wizard. Click the Next button
to continue. Click the Cancel button to exit the operation.

The wizard will continue by asking you to enter a name for the Task and select an action that this Task will
perform. Click the Back button to return to the previous dialog box. Click the Next button to continue. Click
the Cancel button to exit the operation.
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Backup
If you selected Backup, you are asked to select the Device that will be assigned to this Task. Click the to
expand the tree view to see the complete listing of devices and folders. Click the Back button to return to the
previous dialog box. Click the Next button to continue. Click the Cancel button to exit the operation.

The next dialog box will request for you to select a folder to which the files will be backed up. Click the to
expand the tree view to see the complete listing of devices and folders. Click the Back button to return to the
previous dialog box. Click the Next button to continue. Click the Cancel button to exit the operation.
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To continue, select the files you would like to backup by typing in the name, or using the Browse button to
help you locate the files. If you have multiple files that you would like to backup, separate the filenames by
using a comma and a space. When using the Browse button, once you locate the files, you can select
multiple files in the same folder by simply selecting the first file, holding the CTRL key, and selecting the other
files. You can also backup all the files by clicking the Backup All Files checkbox. Click the Back button to
return to the previous dialog box. Click the Next button to continue. Click the Cancel button to exit the
operation.

The final dialog box will summarize all the information that was selected. Click the Back button to return to
the previous dialog box. Click the Finish button to create the new Task. Click the Cancel button to exit the
operation.
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Compare
If you selected Compare, you will be asked to select the Device that will be used with this Task. Click the
to expand the tree view to see the complete listing of devices and folders. Click the Back button to return to
the previous dialog box. Click the Next button to continue. Click the Cancel button to exit the application.

The next dialog box will request for you to select a folder that contains the files you want to compare. Click
the to expand the tree view to see the complete listing of devices and folders. Click the Back button to
return to the previous dialog box. Click the Next button to continue. Click the Cancel button to exit the
operation.
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To continue, select the files you would like to compare by typing in the name, or using the Browse button to
help you locate the files. If you have multiple files that you would like to compare, separate the filenames by
using a comma and a space. When using the Browse button, once you locate the files, you can select
multiple files in the same folder by simply selecting the first file, holding the CTRL key, and selecting the other
files. You can also compare all the files by clicking the Compare All Files checkbox. Click the Back button
to return to the previous dialog box. Click the Next button to continue. Click the Cancel button to exit the
operation.
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The next dialog box will ask you to specify the location where the comparison report will be saved. Use the
Browse button to search for the location if you are unsure. You can request for the report to be emailed
when the action is completed by clicking the Email report when action is completed checkbox, and
entering the email address. If you have multiple recipients that will be receiving the report, separate each
email address by a semicolon. Click the Back button to return to the previous dialog box. Click the Next
button to continue. Click the Cancel button to exit the operation.

The last dialog box will summarize all the information that was selected. Click the Back button to return to the
previous dialog box. Click the Finish button to create the new Task. Click the Cancel button to exit the
operation.
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Backup and Compare
If you selected Backup and Compare, you will be asked to select the Device that will be used with this Task.
Click the to expand the tree view to see the complete listing of devices and folders. Click the Back button
to return to the previous dialog box. Click the Next button to continue. Click the Cancel button to exit the
operation.

The next dialog box will request for you to select a folder to which the files will be backed up. Click the to
expand the tree view to see the complete listing of devices and folders. Click the Back button to return to the
previous dialog box. Click the Next button to continue. Click the Cancel button to exit the operation.
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The process will continue by requesting you to select a folder that contains the files you want to compare.
Click the to expand the tree view to see the complete listing of devices and folders. Click the Back button
to return to the previous dialog box. Click the Next button to continue. Click the Cancel button to exit the
operation.
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The next dialog box will request for you to select the files you would like to compare and backup, by typing in
the name, or using the Browse button to help you locate the files. If you have multiple files that you would
like to compare and backup, separate the filenames by using a comma and a space. When using the
Browse button, once you locate the files, you can select multiple files in the same folder by simply selecting
the first file, holding the CTRL key, and selecting the other files. You can compare and backup all the files by
clicking the Backup and Compare All Files checkbox. Click the Back button to return to the previous dialog
box. Click the Next button to continue. Click the Cancel button to exit the operation.
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To continue, specify the location where the comparison report should be saved. Use the Browse button to
search for the location if you are unsure. You can request for the report to be emailed when the action is
completed by clicking the Email report when action completed checkbox, and entering the email address.
If you have multiple recipients that will be receiving the report, separate each email address by a semicolon.
Click the Back button to return to the previous dialog box. Click the Next button to continue. Click the
Cancel button to exit the operation.

The last dialog box will summarize all the information that was selected. Click the Back button to return to the
previous dialog box. Click the Finish button to create the new Task. Click the Cancel button to exit the
operation.
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Changeover
If you selected Changeover, you will be asked to select the Device that will be assigned with this Task. Click
the to expand the tree view to see the complete listing of devices and folders. Click the Back button to
return to the previous dialog box. Click the Next button to continue. Click the Cancel button to exit the
operation.
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The next dialog box will request for you to select a folder to which the files will be backed up. Click the to
expand the tree view to see the complete listing of devices and folders. Click the Back button to return to the
previous dialog box. Click the Next button to continue. Click Cancel to exit the operation.

To proceed, you will be asked to select the folder that contains the files you would like to upload to the device.
Since you can only upload Master files to communicate with a device, the folder that is selected must be a
Master folder which is represented by a red subfolder icon. Click the to expand the tree view to see the
complete listing of devices and folders. Select the folder you want from the tree view, and click the Next
button to continue. Click the Back button to return to the previous dialog box. Click the Cancel button to exit
the operation.
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To continue, select the files you would like to backup by typing in the name, or using the Browse button to
help you locate the files. If you have multiple files that you would like to backup, separate the filenames by
using a comma and a space. When using the Browse button, once you locate the files, you can select
multiple files in the same folder by simply selecting the first file, holding the CTRL key, and selecting the other
files. You can backup all files by simply clicking the Backup All Files checkbox. Click the Back button to
return to the previous dialog box. Click the Next button to continue. Click the Cancel button to exit the
operation.

The next dialog box will ask you to select the files you would like to upload to the device. A listing of available
files will be displayed in the text area. Click the Back button to return to the previous dialog box. Click the
Next button to continue. Click the Cancel button to exit the operation.
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If the device used is FTP enabled, the previous dialog box will look slightly different as shown below. You will
be asked to supply a destination path.

Use the Browse button to search for the location if you are unsure. The FTP Send dialog box will open to
allow you to select the location.
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The last dialog box will summarize all the information that was selected. Click the Back button to return to the
previous dialog box. Click the Finish button to create the new Task. Click the Cancel button to exit the
operation.

Edit Task
You may be required to alter the information for a Task. With the Task highlighted, select the Tools menu,
Scheduler, and then Edit Task. You could also right-click on the Task you wish to modify and select Edit
Task from the menu. You can also click twice on the Task you want to modify. This will also open it for
editing. The same dialog boxes that were seen when the Task was created will open. Simply alter the
information you want to modify from each dialog box, and click the Next button to precede, until you reach the
end of the process.

Delete Task
To remove a Task, begin by selecting the Task from the listing. From the Tools menu, select Scheduler, and
then Delete Task from the menu. You can also right-click and select Delete Task. A dialog box will open
to close the dialog box and cancel the
confirming the removal of the Task. Click OK to continue. Click the
operation.
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Exiting the FMS Application
To exit the application, simply select Exit from the File menu, or press the
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Chapter Four - Using FMS Connector
FMS Connector Overview
FMS Connector connects to devices and waits for teach pendant initiated file transfer events. When FMS
Connector receives a file request, it retrieves the file from SourceSafe and sends it to the device. When FMS
Connector receives a file save event, it saves the file in SourceSafe. If the force backup option is selected,
FMS Connector will not respond to a file request unless there was a file save event in the previous five
minutes.
The next few sections will expose you to the actual usage of the FMS Connector application. You will be
supplied with all the necessary information required to use this application with no difficulty. You will be
provided with details on topics such as:
•
•

Description of the layout of the FMS Connector main application window
Complete functionality to using the FMS Connector application
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Starting the FMS Connector Application
There is a very simple process to begin using FMS Connector:
•
•
•
•
•

Click the Start button on the Windows desktop
Move up to iOpen Factory
Move over to FMS Connector
Once you've selected the application from the menu, the application's login dialog box for FMS
Connector will open
Enter your User Name and Password

If you wish to automatically login next time with the User Name and Password just entered, simply click the
Auto Login checkbox.
If you wish to automatically login next time using the User Name and Password of the person currently logged
onto the computer, simply click the User Interactive User checkbox.
NOTE: The Use Interactive User option will automatically use the person’s User Name that is currently
logged onto the computer. In order to use this option the person logged onto the computer must have access
to the FMS application, or an error message will appear.
Click the OK button to continue. Click the Cancel button to exit the operation.
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FMS Connector Application Settings
The Settings dialog box contains the Mail Server, Server Port, and Email Address of the account to be
used to send the mail. Email will be sent when a file received from the device is different than the file stored
in the FMS database to the email addresses specified for this device. A Username and Password may also
need to be supplied if required by the SMTP server.

Enter the information required, and click OK to store the modifications and exit the Options dialog box. Click
Cancel to exit the operation.
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Description of FMS Connector Main Application Window
The main application window displays the list of controllers that have been configured from the FMS
application.

Each controller is represented by a single row as shown in the example above. The following information is
presented for each configured controller:
Device Name – The name of the controller
Device Type – Type of controller
Remote Machine – Name of server that physically implements the connection to the controller
Status – The status of connection
If any errors occur, the messages will be shown in the status bar on the bottom. In the example shown
above, an error occurred because connection to the controller failed.
NOTE: All events that occur in the FMS Connector will appear in the Event Log portion of the FMS main
application window
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Add robot
To add a robot controller in the FMS Connector application, begin by selecting Add Robot from the File
menu. Select the robot controller from the tree view provided.
NOTE: In order to add a robot connection, it must be already created in the FMS application.
Click the OK button to continue. Click the Cancel button to exit the operation.

When the connection is added, the application automatically tries to connect to the added controller. If any
problems occur while trying to connect to the controller, a dialog box will appear asking if you wish to
continue. Click Yes to continue. Click No to exit the operation.
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NOTE: If you wish to reconnect to a robot at a later date, simply right-click on the robot controller and select
Reconnect to Robot from the menu provided, as shown in the example below.

Remove Robot
To remove a connection, simply select the robot connection from the tree view listing, and select Remove
Robot from the File menu. Or, you can select the connection and right-click and select the Remove Robot
from the menu provided.

A warning dialog box will open verifying that you wish to delete the selected robot controller. Click Yes to
continue. Click No to exit the operation.
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Change User
If you wish to change user that is currently logged in the application, simply select Change User from the File
menu. The Login dialog box will open, and enter the User Name and Password for the new user. Click OK
to continue. Click Cancel to exit the operation.

Settings
To change the settings for the application, select Settings from the File menu. Only one setting exists, which
forces the backup before transferring a file to the robot. If the force backup option is selected, FMS
Connector will not respond to a file request unless there was a file save event in the previous five minutes. If
you want to disable this setting, simply remove the checkmark from the checkbox. Click OK to continue.
Click Cancel to exit the operation.

Exiting the FMS Connector application
To exit the application, simply select Exit from the File menu.
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Chapter Five - Using FMS Admin

FMS Admin Overview
FMS Admin allows you to specify the structure you wish to use in the FMS application. Once you have
conformed the settings to your satisfaction, they will automatically be implemented for you.
The next few sections will expose you to the actual usage of the FMS Admin application. You will be supplied
with all the necessary information required to use this application with no difficulty. You will be provided with
details on topics such as:
•
•

Description of the layout of the FMS Admin main application window
Complete functionality to using the FMS Admin application
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Starting the FMS Admin Application
There is a very simple process to begin using FMS Admin:
•
•
•
•

Click the Start button on the Windows desktop
Move up to iOpen Factory
Move over to FMS Admin
Once you've selected the application from the menu, the application's login dialog box for FMS Admin
will open

The user will be required to enter two passwords. The first password is for the SourceSafe Admin user. The
second password is for the SQL Database sa user. Enter both passwords and press the OK button. Press
the Cancel button to exit the operation.
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Description of FMS Admin Dialog box
From the File menu in the application dialog box, the user can choose from: Options, Import/Export, or
Exit.
From the View menu in the application dialog box, the user can choose from two different views: Users or
Folders.
From the Maintenance menu in the application dialog box, the user can choose from: Event Log or
Scheduler.

Options
The Options dialog box contains some general application settings. Each selection will be shown with a
checkmark if enabled. To disable a selection, click the checkbox and the checkmark will be removed. The
following are the settings available:
Enable Remote Upload - allows files to be uploaded to the device from a FMS client
Enable Remote Delete - allows files to be deleted from a device using the FMS client
Scheduler Installed - allows the Scheduler component to be used

Click the OK button to store changes made and exit the Options dialog box. Click the Cancel button to exit
the operation.
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Import/Export
The Import selection will import a device type including folders, import files, and extensions from an XML file.
The Export selection will export the device type to an XML file. You will be asked to select the DeviceType to
export from the listing provided. Click the OK button to continue. Click the Cancel button to exit the
operation.

An example of an XML file is shown below.
- <DeviceType Name="ABB S3" ProgID="ABB.DeviceConnector.1"
DecompilerProgID="ABBDcomp.ABBProgram">
- <FolderTypes>
- <FolderType Name="BLKs">
- <Extensions>
<Extension Extension="blk" Description="ABB Block File" />
</Extensions>
- <ImportFiles>
<ImportFile File="*.BLK" />
</ImportFiles>
</FolderType>
- <FolderType Name="CFGs">
- <Extensions>
<Extension Extension="cfg" Description="ABB Configuration File"
/>
</Extensions>
- <ImportFiles>
<ImportFile File="*.CFG" />
</ImportFiles>
</FolderType>
- <FolderType Name="PRGs">
- <Extensions>
<Extension Extension="prg" Description="ABB Program File" />
</Extensions>
- <ImportFiles>
<ImportFile File="*.PRG" />
</ImportFiles>
</FolderType>
</FolderTypes>
</DeviceType>
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Users view
The Users view provides you with all the information concerning the users of the FMS application. The Users
are listed on the right-hand side, along with the permissions that have been assigned to each user. The tree
view is shown on the left-hand side. Permissions can be set for individual Folders, such as the Test Folder
shown in the example below. Since the rights for Users propagate down, the permissions that are assigned
to the Test Folder also apply to any Devices, Folders, or files beneath it in the tree view.
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Folders view
In Folders view, you are able to view all the Folder information. The Devices will be listed in the top portion of
the dialog box. When one Device is selected, its corresponding Folder Types will be displayed in the lower
left. Each Folder Type when selected will show its corresponding Extensions, Descriptions, and Import File
Types all listed to its right. In this example below, the Device XRC has seven Folder Types. The current
Folder Type selected is Batch CMOS, which has the Extension HEX and the Import File ALCMS1E.HEX
checked off. This means that any file with the HEX extension can be added to this Folder. However, the only
file that can be added using the Import command is the ALCMS1E.HEX file.

Refreshing the Current Screen
At any time, you can refresh your current screen by simply selecting Refresh from the View menu.
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Users View
Users Permissions
The access rights for users always propagate down. A user’s rights in the Root form a set of default rights for
that user. As shown in the example below, the permissions set for each individual user are shown for the
Root. These default rights apply to all projects in which you do not explicitly set assignments. When the
Apply only to Masters Folders checkbox is selected, the changes made to the permissions will be assigned
to Masters Folders. Since the Root is selected in the example below, the permissions will propogate down to
any Masters Folders beneath the Root, leaving permissions for all other folders unchanged.

NOTE: In order for Users to be able to invoke the Add/Rename/Delete or Destroy user rights for Groups,
Devices or Products, the User must be assigned the same rights at the Root level.
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Add User
By selecting Add User from the Users menu, or pressing Ctrl + A, you are able to add a new User to the
application. A dialog box will open requesting the new Users name and password. Simply enter the
requested information and press the OK button. Press the Cancel button to exit the operation.

The new User should be added to the listing. Now you can proceed to set the permissions for the newly
created User. Simply check off the permissions you wish the User to have using the checkboxes.
NOTE: In order for Users to be able to invoke the Add/Rename/Delete or Destroy user rights for Groups,
Devices or Products, the User must be assigned the same rights at the Root level.

Edit User
If you wish to edit a User's information, choose the User from the listing. Select Edit User from the Users
menu, or press Ctrl + E. This will automatically put you in edit mode, allowing you to change the User name.
Once your modifications have been made, simply press Enter to log the changes. Once this is complete, you
can proceed to changing the User's permissions. With the User selected, check off the permissions you wish
the User to have, or remove the checkmarks for permissions you wish to take away.
NOTE: In order for Users to be able to invoke the Add/Rename/Delete or Destroy user rights for Groups,
Devices or Products, the User must be assigned the same rights at the Root level.
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Delete User
You might need to remove a User from the listing. Choose the User from the listing shown. Select Delete
User from the User menu, or press Ctrl + D. A dialog box will open confirming the removal of the User
selected. Press the Yes button to remove the User. Press the No button to cancel the operation.

Change Password
Changing the Users password is a very simple process. Simply select the User from the listing shown, and
select Change Password from the User menu. A dialog box will appear prompting you to enter a new
password. Type the new password, and re-type it for verification.

If the two entries do not match, you will receive an error message. Click the OK button on the error message
dialog box, and it will bring you back to the Change Password dialog box to re-enter both. Press the OK
button when finished. Press Cancel to ignore any changes and exit the operation.
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Folders View
Device Types
The Device Types are the Devices that have been configured for use in the FMS application. In the following
few sections, you will be shown how to add, delete and modify information for Device Types in the FMS
Admin application.

Add Device Type
You can add an additional Device Type very easily. From the Folders menu, select Device Types, then
choose Add Device Type. The application will add a new place for the new Device, and automatically places
it in edit mode to be able to add the new name. Type in the new name of the Device Type and press Enter.
Once your Device is added to the listing, you are free to change the Server or Decompiler ProgID for the
Device.

Edit Device Type
To edit an existing Device Type, select the Device Type you wish to edit. From the Folders menu, select
Device Types, then choose Edit Device Type. The application will automatically put you in edit mode and
allow you to edit the name of the Device Type. Press Enter when finished.
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Delete Device Type
You can delete an existing Device from the listing. Simply select the Device Type you wish to remove. From
the Folders menu, select Device Types, then choose Delete Device Type. A dialog box will open
confirming the removal of the selected Device Type. Press Yes to remove the selected Device Type. Press
No to cancel the operation.

Changing the Server ProgID
You may need to change the Server ProgID for a specific Device Type, or add a Server ProgID for a newly
created Device Type. The Server ProgID is the Programmatic Identifier that the FMS application uses to
connect to the server for the selected Device Type. From the Folders menu, select Device Types, then
choose Change Server ProgID. A dialog box will open allowing you to modify the existing Server ProgID.
Make the modifications needed and press the OK button. Press Cancel to ignore any changes and exit the
operation.

File Management System Manual

Page 99

MOTOMAN

Changing the Decompiler ProgID
You may need to change the Decompiler ProgID for a specific Device Type, or add a Decompiler ProgID for a
newly created Device Type. The Decompiler ProgID is the Programmatic Identifier that the FMS application
uses to connect to the decompiler for the selected Device Type. From the Folders menu, select Device
Types, then choose Change Decompiler ProgID. A dialog box will open allowing you to modify the existing
Decompiler ProgID. Make the modifications needed and press the OK button. Press Cancel to ignore any
changes and exit the operation.

Change Icon
You are able to change the Icon for a particular Device. Select the Device from the listing. From the Folders
menu, select Device Types, then choose Change Icon. A dialog box will open showing the Icon, and the
Selected Icon that was originally chosen by the application. Both Icons have a Browse button that allows
you to search for a different Icon. If the Icon was never previously change, there will be no Icon displayed for
the Selected Icon. Press the Browse button and select the directory that contains the new Icon. The new
Icon should now appear in the Change Icon dialog box. Press OK when finished. Press Cancel to ignore
any changes and exit the operation.
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Folder Types
Each Device Type can have a number of Folders assigned. When each Device is selected, the application
will display the Folder Types for that particular Device. In the next few sections, you will be shown how to
add, delete, and modify the Folder Types in the FMS Admin application.

Add Folder Type
You may need to add a Folder Type to the listing for a particular Device. Select the Device from the listing.
From the Folders menu, select Folder Types, then choose Add Folder Type. The application will add a
new place for the new Folder Type, and automatically place it in edit mode so you are able to change the
name. Type in the new name of the Folder Type and press Enter. You are now free to adjust the
Extensions, Descriptions, and Import File Types of the new Folder Type.

NOTE: Once a new Folder Type is added, it will show when new Devices or Products are created. Any
existing Devices and Products will remain unchanged.

Edit Folder Type
To edit a Folder Type, select the Folder Type from the listing. From the Folders menu, select Folder Types,
then choose Edit Folder Type. The application will automatically place the name of the chosen Folder into
edit mode, so you can easily modify the name. Type in the new name and press the Enter key when
finished. At this point, you are free to adjust the Extensions, Descriptions and Import File Types for the
modified Folder.
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Delete Folder Type
You can remove an existing Folder Type. Simply select the Folder Type you wish to remove from the listing.
From the Folders menu, select Folder Types, then choose Delete Folder Type. A dialog box will open
confirming the removal of the Folder Type. Press Yes to continue, or press No to cancel the operation.

NOTE: Once a Folder Type is removed, it will not be available when new Devices or Products are created.
Any existing Devices and Products will remain unchanged.

Change Icon
You have the option to change the Icon for a particular Folder Type. From the Folder menu, select Folder
Types, and then choose Change Icon. A dialog box will open showing the Icon, and the Selected Icon that
was originally chosen by the application. Both Icons have a Browse button that allows you to search for a
different Icon. If the Icon was never previously changed, there will be no Icon displayed for the Selected
Icon. Press the Browse button and select the directory that contains the new Icon. The new Icon should
now appear in the Change Icon dialog box. Press OK when finished. Press Cancel to ignore any changes
and exit the operation.
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Extensions
Each Folder Type can have a number of Extensions assigned. These Extensions specify the only types of
files that can be added to the Folder Type. In the next few sections, you will be shown how to add, delete,
and modify Extensions in the FMS Admin application.

Add Extension
You may want to add a new Extension for a particular Folder Type. Select the Folder Type from the listing.
From the Folders menu, select Extension, then choose Add Extensions. The application will add a new
place for the new Extension, and automatically place it in edit mode to be able to change the name. Type in
the new name of the Extension and press Enter. You are now free to add a Description for the new
Extension.

Edit Extension
You may want to modify an existing Extension. Simply select the Extension from the listing shown. From the
Folders menu, select Extension, then choose Edit Extension. This will automatically place the selected
Extension in edit mode, so you can easily modify the name. Type in the name of the new Extension and
press Enter when finished.
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Delete Extension
To delete an existing Extension, select the Extension you wish to remove from the listing. From the Folders
menu, select Extension, and then choose Delete Extensions.
WARNING: Once an extension is removed, it is removed completely from the application. Therefore, it can
no longer be used by any folder or device in the application. This will affect all folders and devices.
A dialog box will open confirming the removal of the Extension selected. Press Yes to continue. Press No to
cancel the operation.

Change Description
You may wish to change the Description for a specific Extension, or add a Description for a newly created
Extension. Select the Extension from the listing. From the Folders menu, select Extensions, and then
choose Change Description.
A dialog box will open with the current Description for the selected Extension. Type in the new description,
and press the OK button. Press Cancel to ignore any changes and exit the operation.

File Management System Manual

Page 104

MOTOMAN

Import Files
When multiple files are added using the Import command, the Import File settings determine how the files are
classified, and into which Folder Type the files are stored. Each Folder Type can have multiple Import File
settings selected. The next few sections will show how to add, delete and modify the Import File Types in the
application.

Add Import File
You may need to add a specific file name or extension to the Import Files listing. Select the Folder Type to
which you wish to add this file name or extension. From the Folders menu, select Import Files, then choose
Add Import File. This will add a new place for the new Import File Type and automatically place it in edit
mode to be able to add the new name. Type in the new name for the Import File Type and press Enter. Your
new name will be added to the listing.
NOTE: You can use the wildcard (*) symbol to import all files of a certain type. For example, if you chose to
import *.jbi, this would import all files with this extension (.jbi).

Edit Import File
To edit an existing Import File type name, first select it from the Import File listing. From the Folders menu,
select Import File, then choose Edit Import File. This will automatically place the selected item in edit mode
to change the name. Type in the new name for the Import File Type and press Enter when finished.
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Delete Import File
To delete an existing Import File Type, select it from the listing provided. From the Folders menu, select
Import File, then choose Delete Import File.
WARNING: Once an Import File Type is removed, it is removed completely from the application. Therefore,
it can no longer be used by any folder or device in the application. This will affect all folders and devices.
A dialog box will open confirming the removal of the Import File selected. Press Yes to continue the deletion.
Press No to cancel the operation.

Event Log
The Event Log selection from the Maintenance menu will allow you to clear the event history before a
specified date. Select the date from the pull-down menu, and click the OK button to store the changes. Click
the Cancel button to exit the operation.

Scheduler
The Scheduler selection from the Maintenance menu will allow you to clear scheduler batches that have
executed but are not set to repeat. Click OK to select all these batches. Click Cancel to exit the operation.
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Exiting the Application
You can exit the FMS Admin application by selecting Exit from the File menu, or by simply pressing the X
button on the top right-hand corner of the dialog box.
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Chapter Six - Technical Support

Technical Support
If you require Technical Support at any time, you can call 1 877 GO RADIX or e-mail us at
techsupport@radixcontrols.com. We can also be reached through our Technical Support page on our
website www.RadixControls.com.
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Appendix A

FMS Scheduler Installation
The FMS Scheduler application executes the batches and tasks created in the FMS application. The FMS
Scheduler application executes independently of the FMS application.
The FMS Scheduler is intended to run as a service. To install the FMS Scheduler as a Service, run
FMSScheduler.exe /i. This will display the Settings dialog box as shown in the example below. Enter the
User Name, Password, SrcSafe.ini Path, and the Database Server. If you are unsure of the location,
Browse buttons are available for the SrcSafe.ini Path and Database Server, to allow you to search for the
proper locations. Enter the time in minutes for the application to check for batches to execute and how long
to timeout if a task fails. Enter the Mail Server, Server Port, and Email Address of the account to be used
to send the mail. Email will be sent when a file received from the device is different than the file stored in the
FMS database to the email addresses specified for this device. Email will also be sent for comparison reports
where an email address is specified. A Username and Password may also need to be supplied if required
by the SMTP server. Click the OK button when finished. Click the Cancel button to exit the Settings dialog
box.

After installing the FMS Scheduler as a service, it must be configured to run under a Windows account. Begin
by opening Services from the Control Panel (under Administrative Tools in Windows 2000 and Windows
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XP). Open the Properties for the FMS Scheduler Service. Set the Startup Type to Automatic to start the
service automatically every time the machine is started. Set the service to Log on as an account that has
access to the machines to which the FMS Scheduler will be connecting (The Local System Account should
only be used if the FMS Scheduler will not be connecting to devices on any other machines).

Windows NT

Windows 2000

Use the Scheduler component of the FMS client application to configure Batches and Tasks to be executed
by the FMS Scheduler. To uninstall the FMS Scheduler service run FMSScheduler.exe /u.
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Remote
Machine

Glossary of Terms

Machine that is not positioned locally.

Root

Batch

The beginning or start of your tree view.

A set of Tasks that execute together.

Task

Check In

An individual operation or action.

Returning a file for storage after modifications
have been made. All local copies of the file are
removed.

Working
Folder

Check Out
Acquiring a copy of the latest version of a file to
make modifications. The file will be put in your Set
Working Folder and the user is given read and
write privileges.

Specified folder or directory on a user's computer
that is used to place files when they are checked
out. When the user is ready to check in files, the
application already knows the location to remove
the file from and places it back into the application
for storage.

Device
A robot controller or other type of industrial device.

Device
Type
The model type of controller.

Group
A folder used to organize multiple Devices and
their corresponding files.

Master
A file that has been made into a Master file to be
used to communicate with a Device.

Product
A folder used to logically store a Device's
individual files.

Programma
ble Device
Server
Any software component that supports the
interface protocol defined by
ProgrammableDeviceServices.
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