Upon receipt of the product and prior to initial operation, read these instructions thoroughly, and retain for future reference.
MANDATORY

- This manual explains teaching, playback, editing operations of jobs and files, and operation management of the MedWeld 5000 Interface. Read this manual carefully and be sure to understand its contents before operation. General items related to safety are listed in instruction manuals supplied with the manipulator. To ensure correct and safe operation, carefully read the instructions on safety before reading this manual.

- General items related to safety are listed in Section 1: Safety, in the NX100 Instructions. To ensure correct and safe operation, carefully read the NX100 Instructions before reading this manual.

- For detailed instructions regarding additional equipment including the MedWeld 5000 weld control, NX100 controller, manipulator, or other components, refer to the specific equipment manuals included with your documentation package.

CAUTION

- Some drawings in this manual are shown with the protective covers or shields removed for clarity. Be sure all covers and shields are replaced before operating this product.

- The drawings and photos in this manual are representative examples and differences may exist between them and the delivered product.

- YASKAWA may modify this model without notice when necessary due to product improvements, modifications, or changes in specifications.

- If such modification is made, the manual number will also be revised.

- If your copy of the manual is damaged or lost, contact a YASKAWA representative to order a new copy. The representatives are listed on the back cover. Be sure to tell the representative the manual number listed on the front cover.

- YASKAWA is not responsible for incidents arising from unauthorized modification of its products. Unauthorized modification voids your product's warranty.

- Software described in this manual is supplied against licensee only, with permission to use or copy under the conditions stated in the license. No part of this manual may be copied or reproduced in any form without written consent of YASKAWA.
Notes for Safe Operation

Before using this product, read this manual and all the other related documents carefully to ensure knowledge about the product and safety, including all the cautions.

In this manual, the Notes for Safe Operation are classified as "WARNING", "CAUTION", "MANDATORY", or "PROHIBITED".

⚠️ WARNING
Indicates a potentially hazardous situation which, if not avoided, could result in death or serious injury to personnel.

⚠️ CAUTION
Indicates a potentially hazardous situation which, if not avoided, could result in minor or moderate injury to personnel and damage to equipment. It may also be used to alert against unsafe practices.

⚠️ MANDATORY
Always be sure to follow explicitly the items listed under this heading.

🚫 PROHIBITED
Must never be performed.

Even items described as "CAUTION" may result in a serious accident in some situations.

At any rate, be sure to follow these important items

NOTE To ensure safe and efficient operation at all times, be sure to follow all instructions, even if not designated as "CAUTION" and "WARNING".
Notation for Menus and Buttons

Descriptions of the programming pendant, buttons, and displays are shown as follows:

<table>
<thead>
<tr>
<th>Item</th>
<th>Manual Designation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu</td>
<td>The menus displayed on screen are denoted with { }, ex. {TOOL}.</td>
</tr>
<tr>
<td>Button</td>
<td>The buttons, check boxes, radio buttons displayed on screen are denoted with [ ]. ex. [Close]; [Sync] check box; [Fast] radio button.</td>
</tr>
</tbody>
</table>

Description of the Operation Procedure

In the explanation of the operation procedure, the expression "Select • • • " means the following operations:

- To move the cursor to the object item and left-click on it with the mouse.
- To pick out the object item by the tab key and press the Enter key.

(In case of selecting a menu, use arrow keys instead of the tab key to pick out the object item, then press the Enter key.)

Registered Trademark

In this manual, names of companies, corporations, or products are trademarks, registered trademarks, or brand names for each company or corporation. The indications of (R) and TM are omitted.
# MedWeld 5000 Interface

<table>
<thead>
<tr>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Introduction ..................................................................................................................</td>
</tr>
<tr>
<td>1.1 Overview ....................................................................................................................</td>
</tr>
<tr>
<td>1.1.1 Features .................................................................................................................</td>
</tr>
<tr>
<td>2 MedWeld 5000 Interface Quick Tour ..................................................................................</td>
</tr>
<tr>
<td>2.1 Monitor Tab .................................................................................................................</td>
</tr>
<tr>
<td>2.1.1 Weld Status .............................................................................................................</td>
</tr>
<tr>
<td>2.1.2 I/O Status ..............................................................................................................</td>
</tr>
<tr>
<td>2.1.3 Stepper Status ......................................................................................................</td>
</tr>
<tr>
<td>2.1.4 Fault Status ..........................................................................................................</td>
</tr>
<tr>
<td>2.2 Edit Tab ..........................................................................................................................</td>
</tr>
<tr>
<td>2.2.1 Schedule .................................................................................................................</td>
</tr>
<tr>
<td>2.2.2 Stepper ..................................................................................................................</td>
</tr>
<tr>
<td>2.2.3 EIP Settings ..........................................................................................................</td>
</tr>
<tr>
<td>2.2.4 Setup .....................................................................................................................</td>
</tr>
<tr>
<td>2.2.5 Sys Config .............................................................................................................</td>
</tr>
<tr>
<td>3 Operation ..........................................................................................................................</td>
</tr>
<tr>
<td>3.1 Starting MedWeld 5000 Interface Application ...........................................................</td>
</tr>
<tr>
<td>3.2 Editing Values from the Stepper Status Tab ...............................................................</td>
</tr>
<tr>
<td>3.3 Programming/Editing Weld Schedules .......................................................................</td>
</tr>
<tr>
<td>3.4 Programming/Editing Stepper Profiles .......................................................................</td>
</tr>
<tr>
<td>3.5 Modifying EIP Settings ...............................................................................................</td>
</tr>
<tr>
<td>3.6 Modifying Alarm Message Mapping ..........................................................................</td>
</tr>
<tr>
<td>3.7 Modifying System Configuration ..............................................................................</td>
</tr>
<tr>
<td>3.8 Transferring Files .......................................................................................................</td>
</tr>
<tr>
<td>3.8.1 Exporting Error Log ...............................................................................................</td>
</tr>
<tr>
<td>3.8.2 Loading Configuration Files ..................................................................................</td>
</tr>
<tr>
<td>3.8.3 Exporting Configuration Files ..............................................................................</td>
</tr>
<tr>
<td>3.8.4 Compact Flash .......................................................................................................</td>
</tr>
</tbody>
</table>
1 Introduction

1.1 Overview

The Motoman MedWeld 5000 Interface is part of the Motoman family of standardized solutions. It is a fully integrated interface for the MedWeld 5000 weld timer, supported by Motoman, Inc. The MedWeld 5000 Interface kit includes the MedWeld 5000 Interface teach pendant application. The pendant application allows programming and monitoring of the MedWeld 5000 weld timer directly from the robot programming pendant as opposed to using separate controls.

Fig. 1-1: MedWeld 5000 Interface

The MedWeld 5000 Interface uses the Motoman EtherNet IP board mounted in the NX100 controller to communicate directly with the MedWeld 5000 weld processor boards. While the MedWeld 5000 spot timer controls the actual welding process, the teach pendant application is used to change parameters or programs, as well as monitor faults and alarms directly from the programming pendant. However, once weld schedules have been created, the pendant application is not required to perform a weld sequence.

During the welding process, the weld timer communicates critical sequencing instructions with the robot using Ethernet I/P. The NX100 determines schedule selection, and weld initiation using native Inform instructions and Ethernet IP commands. The PCI Ethernet I/P communication board which can be networked with up to four timers from a single controller.

The MedWeld 5000 Interface provides full Medar functionality as supported in Weld Technology Corporation’s (WTC) Weld Gateway personal computer programming application. The interface is designed to allow the operator to quickly see what weld controls have Faults, and/or Alerts. The application is capable of monitoring and collecting data on the weld control, updating the status of the welder as it changes and alerting the operator to fault conditions.
1.1.1 Features

- Network capability for multiple robot controller (up to four robots)
- Full Medar programming capability from the NX100 teach pendant
- Compatibility with INFORM III spot commands using CIO ladder
- Compatibility with all Motor Gun INFORM commands for servo spot guns
- Optimized interface with minimal amount of network traffic overhead
- Data Collection
  - Collects all data seen by weld control
  - Stores data to file on hard disk or USB drive
  - On-line monitoring of weld operations
  - Weld control faults
  - Weld process faults
  - Last weld data
  - Stepper status
  - Current I/O status
- Off-line Weld Schedule Programming
  - Weld schedule programming
  - Stepper schedule programming
  - Fault level programming
  - Setup programming
  - Stepper and fault reset
  - Stepper reset or advance
  - Fault reset
This chapter describes the basic features of the MedWeld 5000 Interface. Read this chapter thoroughly in order to quickly understand the various tabs and functions of the MedWeld 5000 Interface.

2.1 Monitor Tab

The monitor tab allows the user to view the results of the last weld, monitor inputs and outputs, view stepper status, as well as stepper and fault status.

CAUTION

- The customer is responsible for providing trained operators to run the equipment. The customer is also responsible for making sure that the equipment is operated in accordance with the ANSI/RIA R15.06-1999 Robot Safety standard, as well as any other local or state standards.

The MedWeld 5000 Interface is capable of monitoring up to four weld timers. Each timer can be selected using the Timer tabs or by using the Timers dropdown menu. The application can be minimized to run in the background by using the [Minimize] button. The [Close App] button exits the application.

Fig. 2-2: Monitor Tab
2.1.1 Weld Status

The Weld Status tab displays the results of the last weld completed. Data includes:

- Minimum, average, and maximum DC bus voltage
- Minimum, average, and maximum secondary current
- Minimum, average, and maximum primary current
- Sequence number
- C-Factor
- Turns Ratio
- Desired Current
- Percentage heat to percentage current ratio
- Stepper number, step number
- Total weld count, step weld count
- Average on-time
- High frequency cycle count

*Fig. 2-3: Weld Status Tab*
2.1.2 I/O Status

The I/O Status tab monitors the input and output signals as recorded by the weld timer. Refer to the WTC's MedWeld 5000 Integrated Weld Control manual for a complete list of monitored I/O.

*Fig. 2-4: I/O Status Tab*

<table>
<thead>
<tr>
<th>Input</th>
<th>V1</th>
<th>V2</th>
<th>V3</th>
<th>V4</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

2.1.3 Stepper Status

The Stepper Status tab allows you to monitor the status of each of the available steppers. The number of steppers is determined by the particular weld timer used. The pendant Stepper data is fed directly from the weld timer and include:

- Stepper (ON/OFF)
- Stepper status
- Step number
- Step weld count
- Present percentage current boost
- Total weld count (editable within pre-programmed range)
- Remaining tip dresses (editable within pre-programmed range)
- Stepper auxiliary count (editable within pre-programmed range)

*Fig. 2-5: Stepper Status Tab*

**NOTE**
Small adjustments can be made to the stepper values highlighted in yellow. Any changes made to these values must agree with the original values setup in the weld control.
Stepper Select
The [Stepper Select] dropdown window allows you to select the stepper program you wish to monitor (1-10).

Advance This Stepper
The [Advance This Stepper] button manually steps through the stepper program. This allows you to see the amount of energy being added to each weld step (% current boost).

Reset This Stepper
The [Reset This Stepper] button resets the current stepper back to the first step.

Reset All Steppers
The [Reset All Steppers] button resets all steppers back to the first step.

Refresh
The [Refresh] button resets any edited values to the values that were last saved.

Save
The [Save] button saves all edited stepper values from the programming pendant to the MedWeld 5000 weld control.

2.1.4 Fault Status
The Fault Status tab monitors active faults as well as recent fault history.

Fig. 2-6: Fault Status Tab

Reset Active Fault(s)
The [Reset Active Fault(s)] button clears the Active Faults window and moves the faults to the Fault History. Refer to the WTC’s MedWeld 5000 Integrated Weld Control manual for a complete list of faults and their remedy.

The [Reset Active Fault(s)] button does not clear the faults from the weld timer. If a fault condition has not been properly resolved, it will continue to re-appear in the Active Fault window.
2.2 Edit Tab

The Edit tab allows the user to create and edit weld schedules, steppers, EIP settings as well as system configurations and error message settings.

Fig. 2-7: Edit Tab

2.2.1 Schedule

The Schedule tab allows the user to program weld sequences or schedules directly from the programming pendant. By selecting from a standard list of commands or weld functions, the user is able to create new weld sequences or modify existing schedules. For a complete list of MedWeld 5000 functions, refer to the WTC’s MedWeld 5000 Integrated Weld Control manual.

Fig. 2-8: Schedule Tab

**Insert**

The [Insert] button displays the list of available functions to be used to create or modify the weld schedule. The function appears in the Edit frame for programming of variables before being recorded in the schedule when the [Apply] button is pressed. Changes do not take effect until the schedule is saved to the weld timer.

**Delete**

The [Delete] button removes the currently highlighted function from the current weld schedule. Changes do not take effect until the schedule is saved to the weld timer.
2.2 Edit Tab

Duplicate
The [Duplicate] button allows the user to copy an entire weld schedule.

Schedule
The [Schedule] dropdown window selects the schedule to be viewed.

Refresh
The [Refresh] button reloads the last schedule values recorded in the weld timer. Any changes not saved are lost.

Save
The [Save] button writes the new or modified schedule to the weld timer.

Edit Frame
The Edit Frame displays the selected command line with editable variables.

Apply
The [Apply] button moves the modified command from the Edit Frame to the schedule. Changes are not recorded to the weld timer until the [Save] button is pressed.

2.2.2 Stepper

The Stepper tab allows the user to program stepper values directly from the programming pendant.

Fig. 2-9: Stepper Tab

Duplicate
The [Duplicate] button allows the user to copy an entire stepper profile.

Stepper
The Stepper dropdown window selects the stepper profile to be viewed.

Refresh
The [Refresh] button reloads the last stepper values recorded in the weld timer. Any changes not saved are lost.

Save
The [Save] button writes the new or modified stepper profile to the weld timer.

Edit Frame
The Edit Frame displays the selected stepper command line with editable variables.

Apply
The [Apply] button moves the modified command from the Edit Frame to the stepper profile. Changes are not recorded to the weld timer until the [Save] button is pressed.
2.2.3 EIP Settings

The EIP Settings tab allows the user to view and modify the network configuration for their system.

Fig. 2-10: EIP Settings Tab

Refresh
The [Refresh] button reloads the last network configuration settings recorded in the weld timer. Any changes not saved are lost.

Save
The [Save] button writes the new or modified network configuration profile to the weld timer.

2.2.4 Setup

The Setup tab allows the user to modify how alarm messages are defined. Alarm messages can be mapped as either Fault, or Alert messages. These messages trigger a specific response in the weld timer. Fault conditions typically inhibit welding or inhibit initiation of a new schedule until the fault condition is cleared. Alert conditions serve as a warning of potential problems and maintenance alert.

Fig. 2-11: Setup Tab

Refresh
The [Refresh] button reloads the last alarm mapping profile recorded in the weld timer. Any changes not saved are lost.

Save
The [Save] button writes the new or modified alarm mapping profile to the weld timer.

Edit Frame
The Edit Frame displays the selected alarm message with a dropdown menu of the Fault/Error/None variables.
MedWeld 5000 Interface Quick Tour

2.2 Edit Tab

**Apply**
The [Apply] button moves the modified alarm setting from the Edit Frame to the alarm mapping profile. Changes are not recorded to the weld timer until the [Save] button is pressed.

### 2.2.5 Sys Config

The Sys Config tab allows the user to configure the system date as well as enable or disable various functions including:

- Reload defaults
- Function timing (cycle or millisecond)
- Isolation contactor
- Date

The default settings were designed as testing solutions for WTC. The Reload Defaults setting loads the WTC standard control test defaults for firing loads. Motoman does not recommend using these defaults in actual welding applications.

**Fig. 2-12: System Configuration Tab**

**NOTE**

Refresh
The [Refresh] button reloads the last system configuration profile recorded in the weld timer. Any changes not saved are lost.

Save
The [Save] button writes the new or modified system configuration profile to the weld timer.

Edit Frame
The Edit Frame displays the selected configuration setting with the editable variables.

Apply
The [Apply] button moves the modified configuration setting from the Edit Frame to the system configuration profile. Changes are not recorded to the weld timer until the [Save] button is pressed.
3 Operation

3.1 Starting MedWeld 5000 Interface Application

Procedure
1. Select the [PP Application] menu button. A sub menu of installed applications is displayed.
2. Select MedWeld 5000 Interface from the list of applications.

3.2 Editing Values from the Stepper Status Tab

While monitoring stepper values from the Stepper Status tab, small adjustments can be made to the stepper values highlighted in yellow. Any changes made to these values must agree with the original values setup in the weld control.

Fig. 3-13: Stepper Status Tab

Procedure
1. Using your stylus, tap in the table cell you wish to edit.
2. Using the number keypad on the programming pendant, enter the desired value.
4. Press [Save] to load the new stepper values to the weld timer.

CAUTION
The customer is responsible for providing trained operators to run the equipment. The customer is also responsible for making sure that the equipment is operated in accordance with the ANSI/RIA R15.06-1999 Robot Safety standard, as well as any other local or state standards.
3.3 Programming/Editing Weld Schedules

Procedure
1. Open the Schedule tab from the Edit tab.

Fig. 3-14: Edit Schedule Tab

2. Select the schedule you wish to create or modify using the Schedule dropdown menu.

3. You can copy an existing schedule by clicking the [Duplicate] button. The Duplicate Dialog appears.

Fig. 3-15: Duplicate Dialog

4. Enter the timer number you would like to save to as well as the schedule number and click [OK]. The schedule is copied to the selected timer location.

5. Insert new command lines by pressing the [Insert] button. The list of schedule functions appears.

7. Edit function variables and press [Apply]. The new function appears in the schedule.

8. Press [Refresh] to cancel the change and revert back to original schedule.

9. Press [Save] to load the new schedule to the weld timer.
3.4 Programming/Editing Stepper Profiles

Procedure
1. Open the Stepper tab from the Edit tab.

Fig. 3-18: Edit Stepper Tab

2. Select the stepper profile you wish to create or modify using the Stepper dropdown menu.

3. You can copy an existing stepper profile by clicking the [Duplicate] button. The Duplicate Dialog appears.

Fig. 3-19:

4. Enter the timer number you would like to save to as well as the stepper number and click [OK]. The stepper profile is copied to the selected timer location.

5. Select the step you want to modify. The step appears in the Edit Frame.
3.5 Modifying EIP Settings

Procedure
1. Open the EIP Settings tab from the Edit tab.

Fig. 3-22: Edit EIP Settings Tab

2. Select the network variable you want to modify.

3. Enter new data using the keypad.

4. Press [Refresh] to cancel the change and revert back to original network settings.

5. Press [Save] to load the new network settings to the weld timer.

6. Edit step variables and press [Apply]. The modified step appears in the stepping profile.

7. Press [Refresh] to cancel the change and revert back to original stepping profile.

8. Press [Save] to load the new stepping profile to the weld timer.
3 Operation
3.6 Modifying Alarm Message Mapping

3.6 Modifying Alarm Message Mapping

Procedure
1. Open the Setup tab from the Edit tab.

Fig. 3-23: Edit Setup Tab

2. Select alarm message. The alarm appears in the Edit frame.
3. Select Fault, Alert, or None from the dropdown menu.
4. Press [Apply]. The modified alarm appears in the profile.
5. Press [Refresh] to cancel the change and revert back to original setting.
6. Press [Save] to load the new alarm mapping to the weld timer.
3.7 Modifying System Configuration

Procedure
1. Open the Sys Config tab from the Edit tab.

Fig. 3-24: Edit System Configuration Tab

2. Edit configuration variables and press [Apply]. The modified variables appears in the system configuration profile.

3. Press [Refresh] to cancel the changes and revert back to the original settings.

4. Press [Save] to load the new system configuration to the weld timer.

3.8 Transferring Files

CAUTION

Never insert or remove Compact Flash while NX100 power ON. Turn power OFF before inserting or removing Compact Flash.

3.8.1 Exporting Error Log

The error log can be exported to a compact flash card. To export data, insert a Compact Flash in the Compact Flash slot on the programming pendant.

Procedure
1. Select File -> Error Log -> Export. The Error Log is transferred to the compact flash card.

3.8.2 Loading Configuration Files

Procedure
1. Select File -> Config -> Load. The Config file is transferred from the compact flash card to the application.
3.8.3 Exporting Configuration Files

Procedure
1. Select File -> Config -> Export. The Config file is transferred from the application to the compact flash card.

3.8.4 Compact Flash

The following CompactFlash can be used with the NX100. CompactFlash is optional. Yaskawa supplies the CompactFlash No.1: CFC-064MBA (HOOAA) manufactured by Hagiwara Sys-Com when ordered (Refer to the following table).

<table>
<thead>
<tr>
<th>No.</th>
<th>Manufacturer</th>
<th>Model</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Hagiwara Sys-Com</td>
<td>CFC-064MBA (HOOAA)</td>
<td>Consumer product (64MB)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>&lt;Yaskawa-recommended&gt;</td>
</tr>
<tr>
<td>2</td>
<td>Hagiwara Sys-Com</td>
<td>CFI-064MBA (HOOAA)</td>
<td>Industrial product (64MB)</td>
</tr>
<tr>
<td>3</td>
<td>SanDisk (U.S.A.)</td>
<td>SDCFBI-64-EXPP-80</td>
<td>Industrial product (64MB)</td>
</tr>
</tbody>
</table>