COMPLETE OUR ONLINE SURVEY

Motoman is committed to total customer satisfaction! Please give us your feedback on the technical manuals you received with your Motoman robotic solution.

To participate, go to the following website:

http://www.motoman.com/forms/techpubs.asp
# TABLE OF CONTENTS

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 INTRODUCTION</td>
<td></td>
</tr>
<tr>
<td>1.1 Description</td>
<td>1-1</td>
</tr>
<tr>
<td>1.2 Features</td>
<td>1-1</td>
</tr>
<tr>
<td>1.3 System Requirements</td>
<td>1-1</td>
</tr>
<tr>
<td>1.4 User Requirements</td>
<td>1-1</td>
</tr>
<tr>
<td>1.5 Job Editor Components</td>
<td>1-1</td>
</tr>
<tr>
<td>1.6 Care of Components</td>
<td>1-2</td>
</tr>
<tr>
<td>1.7 Reference to Other Documentation</td>
<td>1-2</td>
</tr>
<tr>
<td>1.8 Customer Service Information</td>
<td>1-2</td>
</tr>
<tr>
<td>2 SAFETY</td>
<td></td>
</tr>
<tr>
<td>2.1 Introduction</td>
<td>2-1</td>
</tr>
<tr>
<td>2.2 Standard Conventions</td>
<td>2-2</td>
</tr>
<tr>
<td>2.3 General Safeguarding Tips</td>
<td>2-2</td>
</tr>
<tr>
<td>2.4 Mechanical Safety Devices</td>
<td>2-3</td>
</tr>
<tr>
<td>2.5 Installation Safety</td>
<td>2-3</td>
</tr>
<tr>
<td>2.6 Programming Safety</td>
<td>2-4</td>
</tr>
<tr>
<td>2.7 Operation Safety</td>
<td>2-4</td>
</tr>
<tr>
<td>2.8 Maintenance Safety</td>
<td>2-5</td>
</tr>
<tr>
<td>3 INSTALLING JOB EDITOR</td>
<td></td>
</tr>
<tr>
<td>3.1 Installing the Software</td>
<td>3-1</td>
</tr>
<tr>
<td>3.2 Installing the Hardware Key</td>
<td>3-1</td>
</tr>
<tr>
<td>4 BASIC OPERATION</td>
<td></td>
</tr>
<tr>
<td>4.1 Changes for this Version</td>
<td>4-1</td>
</tr>
<tr>
<td>4.2 Operation Sequence</td>
<td>4-1</td>
</tr>
<tr>
<td>4.3 XRC Job Editor Startup and Setup</td>
<td>4-1</td>
</tr>
<tr>
<td>4.4 Selecting a Job</td>
<td>4-2</td>
</tr>
<tr>
<td>4.5 Creating a Job</td>
<td>4-2</td>
</tr>
<tr>
<td>4.6 Editing a Job</td>
<td>4-3</td>
</tr>
<tr>
<td>4.7 Copying a Job</td>
<td>4-3</td>
</tr>
<tr>
<td>4.8 Deleting a Job</td>
<td>4-4</td>
</tr>
<tr>
<td>4.9 Selecting a Parameter File</td>
<td>4-4</td>
</tr>
<tr>
<td>4.10 Saving a Job</td>
<td>4-4</td>
</tr>
<tr>
<td>4.11 Creating an OLE Link</td>
<td>4-4</td>
</tr>
</tbody>
</table>
SECTION 1
INTRODUCTION

1.1 Description
XRC Job Editor edits robot jobs written in the INFORM2 control language used by the YASNAC XRC and PC/XRC.

1.2 Features
Job Editor can be used to edit jobs in the same manner as with a programming pendant. Job Editor dialogs appear very similar to the screens on the programming pendant, making Job Editor very easy to use for operators who are already familiar with the XRC Controller.

Job Editor allows you to create and edit *.jbi files which can also be edited with simple text editors such as Microsoft Notepad.

1.3 System Requirements
- Operating System: Microsoft Windows 95/98/NT4.0\(^1\)
- Memory: 16 MB minimum
- CPU: Pentium II running at 90 MHz or faster
- Disk space: 30 MB required
- Display: Will work at any resolution supported by Windows
- Hardware Key: Provided (one key per license)

1.4 User Requirements
This user’s manual assumes the user of XRC Job Editor has a working knowledge of robotic programming and is familiar with XRC Controller features and functions.

1.5 Job Editor Components
- CD Browser disc (P/N 141720-1)
- Hardware Key (P/N 141723-1)
- XRC Job Editor User’s Manual (P/N 143686-1)

---

1. Windows 95/98/NT are registered trademarks of Microsoft Corporation.
1.6 Care of Components

**CAUTION!**

*Keep the hardware key in a safe place. If you lose the hardware key, XRC Job Editor will not work and you will have to purchase a new copy of the software. If the key is accidentally damaged, return it to Motoman for replacement.*

Take precautions to avoid scratching the CD’s. Always store the CD’s in their cases and avoid placing the CD’s on any surface when not in its protective case. Keep this user’s manual in a safe place and refer to it whenever necessary. Additional copies of this manual are available from Motoman.

1.7 Reference to Other Documentation

For additional information refer to the following:

- Manipulator Manual for your robot model
- XRC Concurrent I/O Parameter Manual (P/N 142102-1)
- Application-specific Motoman manuals
- Vendor manuals for system components not manufactured by Motoman

1.8 Customer Service Information

If you are in need of technical assistance, contact the Motoman service staff at (937) 847-3200. Please have the following information ready before you call:

- XRC Job Editor version
- Operating system (Windows 95/98/NT)
- System configuration (hard disk capacity, memory, software, etc.)
- Description of difficulty (make a note of any error messages)
SECTION 2
SAFETY

2.1 Introduction

It is the purchaser’s responsibility to ensure that all local, county, state, and national codes, regulations, rules, or laws relating to safety and safe operating conditions for each installation are met and followed.

We suggest that you obtain and review a copy of the ANSI/RIA National Safety Standard for Industrial Robots and Robot Systems. This information can be obtained from the Robotic Industries Association by requesting ANSI/RIA R15.06. The address is as follows:

Robotic Industries Association
900 Victors Way
P.O. Box 3724
Ann Arbor, Michigan 48106
TEL: 313/994-6088
FAX: 313/994-3338

Ultimately, the best safeguard is trained personnel. The user is responsible for providing personnel who are adequately trained to operate, program, and maintain the robot cell. **The robot must not be operated by personnel who have not been trained!**

We recommend that all personnel who intend to operate, program, repair, or use the robot system be trained in an approved Motoman training course and become familiar with the proper operation of the system.

This safety section addresses the following:

- Standard Conventions (Section 2.2)
- General Safeguarding Tips (Section 2.3)
- Mechanical Safety Devices (Section 2.4)
- Installation Safety (Section 2.5)
- Programming Safety (Section 2.6)
- Operation Safety (Section 2.7)
- Maintenance Safety (Section 2.8)
2.2 Standard Conventions

This manual includes information essential to the safety of personnel and equipment. As you read through this manual, be alert to the four signal words:

- DANGER
- WARNING
- CAUTION
- NOTE

Pay particular attention to the information provided under these headings which are defined below (in descending order of severity).

⚠️ **DANGER!**

Information appearing under the DANGER caption concerns the protection of personnel from the immediate and imminent hazards that, if not avoided, will result in immediate, serious personal injury or loss of life in addition to equipment damage.

⚠️ **WARNING!**

Information appearing under the WARNING caption concerns the protection of personnel and equipment from potential hazards that can result in personal injury or loss of life in addition to equipment damage.

⚠️ **CAUTION!**

Information appearing under the CAUTION caption concerns the protection of personnel and equipment, software, and data from hazards that can result in minor personal injury or equipment damage.

NOTE: Information appearing in a NOTE caption provides additional information which is helpful in understanding the item being explained.

2.3 General Safeguarding Tips

All operators, programmers, plant and tooling engineers, maintenance personnel, supervisors, and anyone working near the robot must become familiar with the operation of this equipment. All personnel involved with the operation of the equipment must understand potential dangers of operation. General safeguarding tips are as follows:

- Improper operation can result in personal injury and/or damage to the equipment. Only trained personnel familiar with the operation of this robot, the operator's manuals, the system equipment, and options and accessories should be permitted to operate this robot system.
- Do not enter the robot cell while it is in automatic operation. Programmers must have the teach pendant when they enter the robot cell.
- Improper connections can damage the robot. All connections must be made
within the standard voltage and current ratings of the robot I/O (Inputs and Outputs).

- The robot must be placed in Emergency Stop (E-STOP) mode whenever it is not in use.
- In accordance with ANSI/RIA R15.06, section 6.13.4 and 6.13.5, use lockout/tagout procedures during equipment maintenance. Refer also to Section 1910.147 (29CFR, Part 1910), Occupational Safety and Health Standards for General Industry (OSHA).

### 2.4 Mechanical Safety Devices

The safe operation of the robot, positioner, auxiliary equipment, and system is ultimately the user's responsibility. The conditions under which the equipment will be operated safely should be reviewed by the user. The user must be aware of the various national codes, ANSI/RIA R15.06 safety standards, and other local codes that may pertain to the installation and use of industrial equipment. Additional safety measures for personnel and equipment may be required depending on system installation, operation, and/or location. The following safety measures are available:

- Safety fences and barriers
- Light curtains
- Door interlocks
- Safety mats
- Floor markings
- Warning lights

Check all safety equipment frequently for proper operation. Repair or replace any non-functioning safety equipment immediately.

### 2.5 Installation Safety

Safe installation is essential for protection of people and equipment. The following suggestions are intended to supplement, but not replace, existing federal, local, and state laws and regulations. Additional safety measures for personnel and equipment may be required depending on system installation, operation, and/or location. Installation tips are as follows:

- Be sure that only qualified personnel familiar with national codes, local codes, and ANSI/RIA R15.06 safety standards are permitted to install the equipment.
- Identify the work envelope of each robot with floor markings, signs, and barriers.
- Position all controllers outside the robot work envelope.
- Whenever possible, install safety fences to protect against unauthorized entry into the work envelope.
- Eliminate areas where personnel might get trapped between a moving robot and other equipment (pinch points).
- Provide sufficient room inside the workcell to permit safe teaching and maintenance procedures.
2.6 Programming Safety

All operators, programmers, plant and tooling engineers, maintenance personnel, supervisors, and anyone working near the robot must become familiar with the operation of this equipment. All personnel involved with the operation of the equipment must understand potential dangers of operation. Programming tips are as follows:

- Any modifications to PART 1 of the MRC controller PLC can cause severe personal injury or death, as well as damage to the robot! Do not make any modifications to PART 1. Making any changes without the written permission of Motoman will VOID YOUR WARRANTY!

- Some operations require standard passwords and some require special passwords. Special passwords are for Motoman use only. YOUR WARRANTY WILL BE VOID if you use these special passwords.

- Back up all programs and jobs onto a floppy disk whenever program changes are made. To avoid loss of information, programs, or jobs, a backup must always be made before any service procedures are done and before any changes are made to options, accessories, or equipment.

- The concurrent I/O (Input and Output) function allows the customer to modify the internal ladder inputs and outputs for maximum robot performance. Great care must be taken when making these modifications. Double-check all modifications under every mode of robot operation to ensure that you have not created hazards or dangerous situations that may damage the robot or other parts of the system.

- Improper operation can result in personal injury and/or damage to the equipment. Only trained personnel familiar with the operation, manuals, electrical design, and equipment interconnections of this robot should be permitted to operate the system.

- Inspect the robot and work envelope to be sure no potentially hazardous conditions exist. Be sure the area is clean and free of water, oil, debris, etc.

- Be sure that all safeguards are in place.

- Check the E-STOP button on the teach pendant for proper operation before programming.

- Carry the teach pendant with you when you enter the workcell.

- Be sure that only the person holding the teach pendant enters the workcell.

- Test any new or modified program at low speed for at least one full cycle.

2.7 Operation Safety

All operators, programmers, plant and tooling engineers, maintenance personnel, supervisors, and anyone working near the robot must become familiar with the operation of this equipment. All personnel involved with the operation of the equipment must understand potential dangers of operation. Operation tips are as follows:

- Be sure that only trained personnel familiar with the operation of this robot, the operator's manuals, the system equipment, and options and accessories are permitted to operate this robot system.

- Check all safety equipment for proper operation. Repair or replace any non-functioning safety equipment immediately.
• Inspect the robot and work envelope to ensure no potentially hazardous conditions exist. Be sure the area is clean and free of water, oil, debris, etc.

• Ensure that all safeguards are in place.

• Improper operation can result in personal injury and/or damage to the equipment. Only trained personnel familiar with the operation, manuals, electrical design, and equipment interconnections of this robot should be permitted to operate the system.

• Do not enter the robot cell while it is in automatic operation. Programmers must have the teach pendant when they enter the cell.

• The robot must be placed in Emergency Stop (E-STOP) mode whenever it is not in use.

• This equipment has multiple sources of electrical supply. Electrical interconnections are made between the controller, external servo box, and other equipment. Disconnect and lockout/tagout all electrical circuits before making any modifications or connections.

• All modifications made to the controller will change the way the robot operates and can cause severe personal injury or death, as well as damage the robot. This includes controller parameters, ladder parts 1 and 2, and I/O (Input and Output) modifications. Check and test all changes at slow speed.

2.8 Maintenance Safety

All operators, programmers, plant and tooling engineers, maintenance personnel, supervisors, and anyone working near the robot must become familiar with the operation of this equipment. All personnel involved with the operation of the equipment must understand potential dangers of operation. Maintenance tips are as follows:

• Do not perform any maintenance procedures before reading and understanding the proper procedures in the appropriate manual.

• Check all safety equipment for proper operation. Repair or replace any non-functioning safety equipment immediately.

• Improper operation can result in personal injury and/or damage to the equipment. Only trained personnel familiar with the operation, manuals, electrical design, and equipment interconnections of this robot should be permitted to operate the system.

• Back up all your programs and jobs onto a floppy disk whenever program changes are made. A backup must always be made before any servicing or changes are made to options, accessories, or equipment to avoid loss of information, programs, or jobs.

• Do not enter the robot cell while it is in automatic operation. Programmers must have the teach pendant when they enter the cell.

• The robot must be placed in Emergency Stop (E-STOP) mode whenever it is not in use.

• Be sure all safeguards are in place.

• Use proper replacement parts.

• This equipment has multiple sources of electrical supply. Electrical interconnections are made between the controller, external servo box, and other equipment. Disconnect and lockout/tagout all electrical circuits before making any modifications or connections.
making any modifications or connections.

- All modifications made to the controller will change the way the robot operates and can cause severe personal injury or death, as well as damage the robot. This includes controller parameters, ladder parts 1 and 2, and I/O (Input and Output) modifications. Check and test all changes at slow speed.

- Improper connections can damage the robot. All connections must be made within the standard voltage and current ratings of the robot I/O (Inputs and Outputs).
SECTION 3
INSTALLING JOB EDITOR

3.1 Installing the Software

1. Insert the installation CD-ROM into your computer’s CD-ROM drive.
2. Select Settings ➔ Control Panel from the Windows Start menu.
3. Double-click Add/Remove Programs.
4. Click Install.
5. Follow the on-screen instructions to run "D:/DISK1/setup.exe."
6. Clicking the [Finish] button and the [Execute Application] button calls up the [Setup] dialog box.
7. Follow the on-screen instructions.
8. When the setup is completed, [Job Editor] is registered under the [Job Editor] folder that appears by clicking the [Start] button in the task bar and selecting [Program] and then [Motoman].

NOTE: To re-install the Job Editor for some reason, click the [Start] button and point to [Settings]. Click [Control Panel], and double-click the [Add/Remove Programs] icon. Then select [Job Editor], and delete all the Job Editor application files before starting re-installation.

3.2 Installing the Hardware Key

The hardware key supplied with Job Editor must be installed on your computer or Job Editor will not function properly. The hardware key attaches to the computer’s parallel port. This port is commonly used to connect printers and other peripheral devices to your computer. To attach the hardware key:

1. Disconnect any device currently connected to your computer’s parallel port.
2. Carefully insert the hardware key into the parallel port. If the key does not fit, do not force it. The key should fit snugly but does not require significant force to insert.
3. Connect your peripheral cable to the free end of the hardware key. The key will not interfere with the operation of your printer or other peripheral devices.

If you are using two or more MotoSoft™ products that require the use of a hardware key, you can “stack” the keys (connecting them in series).
SECTION 4  
BASIC OPERATION

4.1 Changes for this Version

MRC Editor is the name of the previous version of XRC Job Editor.
MRC Editor used CMOS.HEX files. Job Editor uses *.JBI files. XRC Job Editor cannot read CMOS.HEX files directly.
MRC Editor required registration of each robot before it could work with the CMOS.HEX files. XRC Job Editor does not require robot registration. XRC Job Editor can create a folder, input the parameter file, and save the job file into a folder representing each robot.

4.2 Operation Sequence

XRC Job Editor software requires only parameter files. Save the parameter file from the controller as follows:
1. Use the FC2 or FC1 emulator to save the ALL.PRM file and desired job files to your PC. For detailed instructions on the use of these floppy disk emulation products, consult the documentation that came with your controller and the floppy disk unit.
2. Create a folder on your computer to hold the necessary parameter and job files.
3. Use XRC Job Editor to open, edit, and save the job file.
4. Load the edited job files to the controller

4.3 XRC Job Editor Startup and Setup

Select Program ☰ Motoman ☰ XRC Job Editor ☰ XRC Job Editor from the Windows Start menu. The XRC Job Editor window will appear. Three subwindows may appear inside the XRC Job Editor window: the Main window, the Line Edit window, and the Detail Edit window.
4.4 Selecting a Job

Various sample parameter files and jobs are provided in the installation folder. To open a job:

1. Select Select Job from the File menu. The Open dialog box will appear.

**NOTE:** The XRC parameter file (ALL.PRM) must be in the directory containing the job. If there is no parameter file, an alert will appear.

To open multiple files, hold the CTRL key while making your file selections.

2. Click Open to open the file(s).

4.5 Creating a Job

1. Select Create Job from the File menu. The Create Job dialog box will appear.

2. Enter a job name using a maximum of eight characters.

3. Select the desired file extension. The “JBI” and “JBB” options will make XRC Job Editor create ASCII and binary files respectively.

**NOTE:** Binary jobs can only be used with the PC/XRC.

4. Select the desired job type. The “Robot” option is used to create jobs that contain position data for use with a Motoman robot. The “Non Robot” option is used for non robotic equipment such as grippers.

5. Select the desired job control group in the Control Group window. If the desired control group is not listed, register the group in the Group Combination Registry, reopen the Create Job dialog, and perform Steps 2-5.

6. Click OK. A new Line Edit window will appear.

**NOTE:** If you entered a name for a job that already exists, you will be prompted to overwrite the file or exit.
4.6 **Editing a Job**

1. Open an existing job or create a new one as described in Sections 4.4 and 4.5.
2. Click to select commands in the Line Edit window.

3. When you double click on a command, an edit function bar appears toward the bottom of the screen. Click Edit to edit the selected command. The Detail Edit screen appears.
4. Make desired changes and click **OK**. You will be returned to the Line Edit window.

4.7 **Copying a Job**

Select **Copy Job**… from the File menu. The Copied Job Name Input dialog box will appear.

An existing job name cannot be used for the Copied Job. If you enter a job name that is already in use, an alert dialog will appear. Enter a unique name and try again. If you must name the copied job the same as an existing job, move or delete the existing job first.
4.8  **Deleting a Job**

1. Select Delete Job… from the File menu. The Delete Job dialog will appear.
2. Select the file you wish to delete. Hold the CTRL key while clicking files to select multiple files.
3. Click Open.

4.9  **Selecting a Parameter File**

You must have a parameter file to create an environment for making a new job. To open a parameter file:

1. Select Select Job from the File menu. The Open dialog will appear.
2. Select “PRM Files (*.prm)” from the file type dropdown list.
3. Select ALL.PRM
4. Click Open.

4.10  **Saving a Job**

To save a file:

1. Select Save… or Save As…. from the File menu.
2. If you select Save As…, you will be prompted to enter a filename. Enter a filename and click Save.

**NOTE:** If the following error message appears when you are saving a file, it is because the position variable is not defined. Select Position Variable from the View menu to define the position variable.
4.11 Creating an OLE Link

XRC Job Editor supports object linking. OLE Links can easily be created from one OLE client enabled application to another. Changes made in either application are updated in both locations. The following example illustrates how to create a link to a Motoman job file (.jbi) from within a Microsoft Word® document.

1. Open the Word® document you wish to create a link with the job file.
2. From the main menu, select Insert → Object. The Object window appears.

![Object window](image)

3. Select the Create from file tab, and enter the job file name you wish to create a link to.
   
   **NOTE:** You can also click on the Browse... button to locate the file.

4. Select the Link to file option.

![Object window](image)

5. Once you have entered the file name and selected the Link to file option, click OK. The contents of the selected file appear as a link within the Word document.

![Link in Word](image)
6. Double clicking on the link allows you to edit the contents of the file from within the XRC Job Editor application.

7. When you are finished modifying the job, close the application. XRC Job Editor prompts you to save the changes. Pressing *Yes* updates both files automatically.

**NOTE:** Changes made directly to linked files are automatically updated in both locations. The linking option is supported for (*.jbi) files only.
INDEX

A
ANSI/RIA, 2-1

C
Care of Components, 1-2
Customer Service Information, 1-2
Creating an OLE Link, 4-5

G
General Safeguarding Tips, 2-2

I
Installation Safety, 2-3
Installing the Hardware Key, 1-2

M
Maintenance Safety, 2-5
Mechanical Safety Devices, 2-3

O
Operation Safety, 2-4

P
Programming Safety, 2-4

R
Reference to Other Documentation, 1-2
Robotic Industries Association, 2-1

S
Safety, 2-1
Standard Conventions, 2-2